summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-editors/focuswriter/Manifest1
-rw-r--r--app-editors/focuswriter/focuswriter-1.5.5.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/app-editors/focuswriter/Manifest b/app-editors/focuswriter/Manifest
index c2bf16344ccc..72ab73caa6d9 100644
--- a/app-editors/focuswriter/Manifest
+++ b/app-editors/focuswriter/Manifest
@@ -1,2 +1,3 @@
DIST focuswriter-1.5.3-src.tar.bz2 5201148 SHA256 1c48c72879a7b40cf7d97c28abf5cf713c063b7f83a1179093b1241f5797a8c4 SHA512 6796fc8dbe5d5ba545fc8ee5797f620e56dea67a038f4c4eb9e404940a863b32ea2ceb30ed7ea8e22187be2763cc128def3f08f61187ba11de94ec9ae16f807f WHIRLPOOL c5dbf0e739928833bbccdc2e5de6305ca553a3e8f0f1d54d1d2a6bd4636b8ede85c3adedcaee85d66779e25cd53678428cc3817bdedcf30be42c89fc1aebdf07
DIST focuswriter-1.5.4-src.tar.bz2 5247111 SHA256 5ffd74a2d5a790e432d819dfd269ddb8d6c1a0168c91e441b2121fa6eaf8f565 SHA512 f532dac5a0691d7b82a16b5dae115c7d79b161484ba1ad2243fd1ccaeba8ae9c9ed0019eba6cd87cc4155a51f5a97cad16c92b9453671426e214e139d78bc526 WHIRLPOOL aca3722b60aee8bec0979f71a04d28217c82c9a2fb60b49a19a58596c9d67bd160626d14cc950eeaa9c0543001f93ec9576a1561c24bbe29a98eeec708287331
+DIST focuswriter-1.5.5-src.tar.bz2 5249014 SHA256 b6a2085587864b2685516d20870d9375803ccdf3472e66bf457382d028c1da0e SHA512 aed6a2e203dcf349ff7fef6caa8e7ab1dbba80da988933c06d6f4ea1ad49ad4c4546b30aaacf9373d1234cb8934daac36f00d0d7b3512d9c3fc4f1e1b273a766 WHIRLPOOL 29795304e6d6687d16d2774cd4d28d0c45382474391d7ad62fa557a134e7c5d11ba6bf81bb81df2b0fb3727b4bb32f705d8fe73a7129f44c8485cc9d8b19b2e1
diff --git a/app-editors/focuswriter/focuswriter-1.5.5.ebuild b/app-editors/focuswriter/focuswriter-1.5.5.ebuild
new file mode 100644
index 000000000000..f2e23064f6b9
--- /dev/null
+++ b/app-editors/focuswriter/focuswriter-1.5.5.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PLOCALES="ar ca cs da de el en en_GB es_MX es fi fr he hu hy id it ja ko nl pl
+pt_BR pt ro ru sk sr sv tr uk vi zh_CN zh_TW"
+PLOCALE_BACKUP="en"
+inherit fdo-mime gnome2-utils l10n readme.gentoo qt4-r2
+
+DESCRIPTION="A fullscreen and distraction-free word processor"
+HOMEPAGE="http://gottcode.org/focuswriter/"
+SRC_URI="http://gottcode.org/${PN}/${P}-src.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+RDEPEND="app-text/hunspell
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+ dev-qt/qtsingleapplication[qt4(+),X]
+ sys-libs/zlib"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS=( ChangeLog CREDITS NEWS README )
+DOC_CONTENTS="Focuswriter has optional sound support if media-libs/sdl-mixer is
+installed with wav useflag enabled."
+
+PATCHES=( "${FILESDIR}/${PN}-1.5.2-unbundle-qtsingleapplication.patch" )
+
+rm_loc() {
+ sed -e "s|translations/${PN}_${1}.ts||" -i ${PN}.pro || die 'sed failed'
+ rm translations/${PN}_${1}.{ts,qm} || die "removing ${1} locale failed"
+}
+
+src_prepare() {
+ l10n_for_each_disabled_locale_do rm_loc
+ qt4-r2_src_prepare
+}
+
+src_configure() {
+ eqmake4 PREFIX="${EPREFIX}/usr"
+}
+
+src_install() {
+ readme.gentoo_create_doc
+ qt4-r2_src_install
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ readme.gentoo_pkg_postinst
+ gnome2_icon_cache_update
+ fdo-mime_desktop_database_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ fdo-mime_desktop_database_update
+}