summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-firmware/intel-microcode/Manifest2
-rw-r--r--sys-firmware/intel-microcode/intel-microcode-20191115_p20200429.ebuild248
2 files changed, 0 insertions, 250 deletions
diff --git a/sys-firmware/intel-microcode/Manifest b/sys-firmware/intel-microcode/Manifest
index fe0b99d2f727..0985b1cce929 100644
--- a/sys-firmware/intel-microcode/Manifest
+++ b/sys-firmware/intel-microcode/Manifest
@@ -1,4 +1,2 @@
-DIST intel-microcode-collection-20200429.tar.xz 6012000 BLAKE2B 38821d7732c952f2d1db17d3c289a53bc060d87fbaa4ba2b6c5875aab48d8ac695d11b57d83658633278f0227d9683b20af8141c67563b694fb05b41b3812651 SHA512 8c9004f8c7c08dbf69fad3dd195f1646a6aab9f8720c7fbeba57989c091e1adbaec1c85c079f1a74d8f07168120bdc575660b46391eaf854b4140596c11f53be
DIST intel-microcode-collection-20200508.tar.xz 6010560 BLAKE2B ebbbac3b474644d983f8f6f1a3b305b60a65732883658d18efe8c918f6d1ec55f8439313ccc2fe5d90a5ca5e207bcc2db9b9299148157f233007046fa3090e19 SHA512 48dde26041afb3a82afd3f4f8a2539ccf0da4a42c802b45aa776e16ceebf72cb39ce828278a423d4f2b2c0d7c29c5701978b4a223d135b453bc63cb1db3e5373
-DIST microcode-20191115.tar.gz 2998063 BLAKE2B a06f2769da1577b9ce3a34f447e182312d003842b043372d850de51012efd9c0247f9a6bc8964e3da6127f8afb58f3fb31b1204e7286af9b27c795c00419ef7e SHA512 11014c16bde83ac290bc75e458242f5e64b8dffd49de2e938f61f4a09979cd5e80dd1a85d2ccbac067e4398dc3d93ef3583e4aa9b2e545ba46d26e65ec1e2881
DIST microcode-20200508.tar.gz 3002932 BLAKE2B 01964ca9cf6f3d0255d85d6bff9c8fedb127884a034d34eeec97e24d6689aa81eba758306316346cd686d2aee6c0cbc4afc0a2ccb49c3a4b2c5f0d6b1e543063 SHA512 00fa15464c7637c080c49d63b73c197418f4709eaaf55d515504f3bb8aab06dc97206c4fbef57250dc6ca8abf226e0f1fc39bad76ca8b0d705c820e3d1d8ffc9
diff --git a/sys-firmware/intel-microcode/intel-microcode-20191115_p20200429.ebuild b/sys-firmware/intel-microcode/intel-microcode-20191115_p20200429.ebuild
deleted file mode 100644
index 0a7fafc268df..000000000000
--- a/sys-firmware/intel-microcode/intel-microcode-20191115_p20200429.ebuild
+++ /dev/null
@@ -1,248 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="7"
-
-inherit linux-info toolchain-funcs mount-boot
-
-# Find updates by searching and clicking the first link (hopefully it's the one):
-# https://www.intel.com/content/www/us/en/search.html?keyword=Processor+Microcode+Data+File
-
-COLLECTION_SNAPSHOT="${PV##*_p}"
-INTEL_SNAPSHOT="${PV/_p*}"
-#NUM="28087"
-#https://downloadcenter.intel.com/Detail_Desc.aspx?DwnldID=${NUM}
-#https://downloadmirror.intel.com/${NUM}/eng/microcode-${INTEL_SNAPSHOT}.tgz
-DESCRIPTION="Intel IA32/IA64 microcode update data"
-HOMEPAGE="https://github.com/intel/Intel-Linux-Processor-Microcode-Data-Files http://inertiawar.com/microcode/"
-SRC_URI="https://github.com/intel/Intel-Linux-Processor-Microcode-Data-Files/archive/microcode-${INTEL_SNAPSHOT}.tar.gz
- https://dev.gentoo.org/~whissi/dist/intel-microcode/intel-microcode-collection-${COLLECTION_SNAPSHOT}.tar.xz"
-
-LICENSE="intel-ucode"
-SLOT="0"
-KEYWORDS="-* amd64 x86"
-IUSE="hostonly initramfs +split-ucode vanilla"
-REQUIRED_USE="|| ( initramfs split-ucode )"
-
-BDEPEND="sys-apps/iucode_tool"
-
-# !<sys-apps/microcode-ctl-1.17-r2 due to bug #268586
-RDEPEND="hostonly? ( sys-apps/iucode_tool )"
-
-RESTRICT="binchecks bindist mirror strip"
-
-S=${WORKDIR}
-
-# Blacklist bad microcode here.
-# 0x000406f1 aka 06-4f-01 aka CPUID 406F1 require newer microcode loader
-MICROCODE_BLACKLIST_DEFAULT="-s !0x000406f1"
-
-# In case we want to set some defaults ...
-MICROCODE_SIGNATURES_DEFAULT=""
-
-# Advanced users only!
-# Set MIRCOCODE_SIGNATURES to merge with:
-# only current CPU: MICROCODE_SIGNATURES="-S"
-# only specific CPU: MICROCODE_SIGNATURES="-s 0x00000f4a -s 0x00010676"
-# exclude specific CPU: MICROCODE_SIGNATURES="-s !0x00000686"
-
-pkg_pretend() {
- use initramfs && mount-boot_pkg_pretend
-}
-
-src_prepare() {
- default
-
- if cd Intel-Linux-Processor-Microcode-Data* &>/dev/null; then
- # new tarball format from GitHub
- mv * ../ || die "Failed to move Intel-Linux-Processor-Microcode-Data*"
- cd .. || die
- rm -r Intel-Linux-Processor-Microcode-Data* || die
- fi
-
- # Prevent "invalid file format" errors from iucode_tool
- rm -f "${S}"/intel-ucod*/list || die
-}
-
-src_install() {
- # This will take ALL of the upstream microcode sources:
- # - microcode.dat
- # - intel-ucode/
- # In some cases, they have not contained the same content (eg the directory has newer stuff).
- MICROCODE_SRC=(
- "${S}"/intel-ucode/
- "${S}"/intel-ucode-with-caveats/
- )
-
- # Allow users who are scared about microcode updates not included in Intel's official
- # microcode tarball to opt-out and comply with Intel marketing
- if ! use vanilla; then
- MICROCODE_SRC+=( "${S}"/intel-microcode-collection-${COLLECTION_SNAPSHOT} )
- fi
-
- # These will carry into pkg_preinst via env saving.
- : ${MICROCODE_BLACKLIST=${MICROCODE_BLACKLIST_DEFAULT}}
- : ${MICROCODE_SIGNATURES=${MICROCODE_SIGNATUES_DEFAULT}}
-
- opts=(
- ${MICROCODE_BLACKLIST}
- ${MICROCODE_SIGNATURES}
- # be strict about what we are doing
- --overwrite
- --strict-checks
- --no-ignore-broken
- # we want to install latest version
- --no-downgrade
- # show everything we find
- --list-all
- # show what we selected
- --list
- )
-
- # The earlyfw cpio needs to be in /boot because it must be loaded before
- # rootfs is mounted.
- use initramfs && dodir /boot && opts+=( --write-earlyfw="${ED}/boot/intel-uc.img" )
-
- keepdir /lib/firmware/intel-ucode
- opts+=( --write-firmware="${ED}/lib/firmware/intel-ucode" )
-
- iucode_tool \
- "${opts[@]}" \
- "${MICROCODE_SRC[@]}" \
- || die "iucode_tool ${opts[@]} ${MICROCODE_SRC[@]}"
-
- dodoc releasenote
-}
-
-pkg_preinst() {
- if [[ ${MICROCODE_BLACKLIST} != ${MICROCODE_BLACKLIST_DEFAULT} ]]; then
- ewarn "MICROCODE_BLACKLIST is set to \"${MICROCODE_BLACKLIST}\" instead of default \"${MICROCODE_BLACKLIST_DEFAULT}\". You are on your own!"
- fi
-
- if [[ ${MICROCODE_SIGNATURES} != ${MICROCODE_SIGNATURES_DEFAULT} ]]; then
- ewarn "Package was created using advanced options:"
- ewarn "MICROCODE_SIGNATURES is set to \"${MICROCODE_SIGNATURES}\" instead of default \"${MICROCODE_SIGNATURES_DEFAULT}\"!"
- fi
-
- # Make sure /boot is available if needed.
- use initramfs && mount-boot_pkg_preinst
-
- local _initramfs_file="${ED}/boot/intel-uc.img"
-
- if use hostonly; then
- # While this output looks redundant we do this check to detect
- # rare cases where iucode_tool was unable to detect system's processor(s).
- local _detected_processors=$(iucode_tool --scan-system 2>&1)
- if [[ -z "${_detected_processors}" ]]; then
- ewarn "Looks like iucode_tool was unable to detect any processor!"
- else
- einfo "Only installing ucode(s) for ${_detected_processors#iucode_tool: system has } due to USE=hostonly ..."
- fi
-
- opts=(
- --scan-system
- # be strict about what we are doing
- --overwrite
- --strict-checks
- --no-ignore-broken
- # we want to install latest version
- --no-downgrade
- # show everything we find
- --list-all
- # show what we selected
- --list
- )
-
- # The earlyfw cpio needs to be in /boot because it must be loaded before
- # rootfs is mounted.
- use initramfs && opts+=( --write-earlyfw=${_initramfs_file} )
-
- if use split-ucode; then
- opts+=( --write-firmware="${ED}/lib/firmware/intel-ucode" )
- fi
-
- opts+=( "${ED}/lib/firmware/intel-ucode-temp" )
-
- mv "${ED}"/lib/firmware/intel-ucode{,-temp} || die
- keepdir /lib/firmware/intel-ucode
-
- iucode_tool "${opts[@]}" || die "iucode_tool ${opts[@]}"
-
- rm -r "${ED}"/lib/firmware/intel-ucode-temp || die
-
- elif ! use split-ucode; then # hostonly disabled
- rm -r "${ED}"/lib/firmware/intel-ucode || die
- fi
-
- # Because it is possible that this package will install not one single file
- # due to user selection which is still somehow unexpected we add the following
- # check to inform user so that the user has at least a chance to detect
- # a problem/invalid select.
- local _has_installed_something=
- if use initramfs && [[ -s "${_initramfs_file}" ]]; then
- _has_installed_something="yes"
- elif use split-ucode; then
- _has_installed_something=$(find "${ED}/lib/firmware/intel-ucode" -maxdepth 0 -not -empty -exec echo yes \;)
- fi
-
- if use hostonly && [[ -n "${_has_installed_something}" ]]; then
- elog "You only installed ucode(s) for all currently available (=online)"
- elog "processor(s). Remember to re-emerge this package whenever you"
- elog "change the system's processor model."
- elog ""
- elif [[ -z "${_has_installed_something}" ]]; then
- ewarn "WARNING:"
- if [[ ${MICROCODE_SIGNATURES} != ${MICROCODE_SIGNATURES_DEFAULT} ]]; then
- ewarn "No ucode was installed! Because you have created this package"
- ewarn "using MICROCODE_SIGNATURES variable please double check if you"
- ewarn "have an invalid select."
- ewarn "It's rare but it is also possible that just no ucode update"
- ewarn "is available for your processor(s). In this case it is safe"
- ewarn "to ignore this warning."
- else
- ewarn "No ucode was installed! It's rare but it is also possible"
- ewarn "that just no ucode update is available for your processor(s)."
- ewarn "In this case it is safe to ignore this warning."
- fi
-
- ewarn ""
-
- if use hostonly; then
- ewarn "Unset \"hostonly\" USE flag to install all available ucodes."
- ewarn ""
- fi
- fi
-}
-
-pkg_prerm() {
- # Make sure /boot is mounted so that we can remove /boot/intel-uc.img!
- use initramfs && mount-boot_pkg_prerm
-}
-
-pkg_postrm() {
- # Don't forget to umount /boot if it was previously mounted by us.
- use initramfs && mount-boot_pkg_postrm
-}
-
-pkg_postinst() {
- # Don't forget to umount /boot if it was previously mounted by us.
- use initramfs && mount-boot_pkg_postinst
-
- # We cannot give detailed information if user is affected or not:
- # If MICROCODE_BLACKLIST wasn't modified, user can still use MICROCODE_SIGNATURES
- # to to force a specific, otherwise blacklisted, microcode. So we
- # only show a generic warning based on running kernel version:
- if kernel_is -lt 4 14 34; then
- ewarn "${P} contains microcode updates which require"
- ewarn "additional kernel patches which aren't yet included in kernel <4.14.34."
- ewarn "Loading such a microcode through kernel interface from an unpatched kernel"
- ewarn "can crash your system!"
- ewarn ""
- ewarn "Those microcodes are blacklisted per default. However, if you have altered"
- ewarn "MICROCODE_BLACKLIST or MICROCODE_SIGNATURES, you maybe have unintentionally"
- ewarn "re-enabled those microcodes...!"
- ewarn ""
- ewarn "Check \"${EROOT}/usr/share/doc/${PN}-*/releasenot*\" if your microcode update"
- ewarn "requires additional kernel patches or not."
- fi
-}