summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/astropy/Manifest2
-rw-r--r--dev-python/astropy/astropy-1.3.ebuild (renamed from dev-python/astropy/astropy-1.1.2.ebuild)37
-rw-r--r--dev-python/astropy/files/astropy-1.1.2-cfitsio-338.patch35
-rw-r--r--dev-python/astropy/files/astropy-1.1.2-fix-for-pytest-28.patch37
-rw-r--r--dev-python/astropy/files/astropy-1.3-mark-known-failures.patch84
5 files changed, 100 insertions, 95 deletions
diff --git a/dev-python/astropy/Manifest b/dev-python/astropy/Manifest
index 6cf0a59f637d..fb18d25d266e 100644
--- a/dev-python/astropy/Manifest
+++ b/dev-python/astropy/Manifest
@@ -1,2 +1,2 @@
-DIST astropy-1.1.2.tar.gz 8059713 SHA256 6f0d84cd7dfb304bb437dda666406a1d42208c16204043bc920308ff8ffdfad1 SHA512 b83c4a1415a3eb8c016507705d0d2f22971e4da937bb97953eec08f8f856933d8fa76ce8c536122235b19e7879b16add2e20fd2fee3e488f9b2b4bf1b9f4dbdb WHIRLPOOL 01cdfd33c29f7128e88be3f53b7ecdec37d95ba06acae6ceeba83746e0454aa220396fb00519b30639ac01b5b297fad004488d34856295735e04924d154c4eb9
DIST astropy-1.2.1.tar.gz 8179665 SHA256 0d7ef702166f26fed239b59fc12edcd5243ca5bf562a36202fd8c6b0270d6e48 SHA512 2ef37537a4c6b2ec50a1d898f600978475c9c5d2cb66ba19d06782656e9ddcb4aa6a8e53217e318448cedac45dac0dce0d8cc2fe94cddc15ebb306b3b0794595 WHIRLPOOL d37374f23a0121fdc92fa572facc248f0a571dacb8edcf1a9d0987d6a40287de199262ec01f654bd6ea5aece826e5588d2869558152adffe9ab490fa46f2e36d
+DIST astropy-1.3.tar.gz 8372366 SHA256 49de3e86482abe24e3cd02c4a30a469ee4b928d5b46ea5f70fa605ff6f9c6d38 SHA512 1dd667af78be568bd4719d273d432881d7dea03725deb24a045726b315f8e5cd8afac3f6f925867b05c4c7924cd71d7e7d6ae15985a95c7fcc4421e52273983b WHIRLPOOL 2913c195989c2af0a58ab5e675bd41607bb28273265c0a502c8b1d33925994f9127c9a03058b55aabc1b3a8c594e89ddbd2d5fc38c42dd4723998bad01c7bd45
diff --git a/dev-python/astropy/astropy-1.1.2.ebuild b/dev-python/astropy/astropy-1.3.ebuild
index c8b61aea91c5..d85184f42f3e 100644
--- a/dev-python/astropy/astropy-1.1.2.ebuild
+++ b/dev-python/astropy/astropy-1.3.ebuild
@@ -6,7 +6,7 @@ EAPI=6
PYTHON_COMPAT=( python2_7 python3_{4,5} )
-inherit distutils-r1
+inherit distutils-r1 xdg-utils
DESCRIPTION="Core functionality for performing astrophysics with Python"
HOMEPAGE="http://astropy.org/"
@@ -18,12 +18,12 @@ KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
IUSE="doc test"
RDEPEND="
- >=dev-libs/expat-2.1.0:0=
+ dev-libs/expat:0=
dev-python/configobj[${PYTHON_USEDEP}]
>=dev-python/numpy-1.10[${PYTHON_USEDEP}]
dev-python/ply[${PYTHON_USEDEP}]
dev-python/six[${PYTHON_USEDEP}]
- >=sci-astronomy/erfa-1.2:0=
+ >=sci-astronomy/erfa-1.3:0=
>=sci-astronomy/wcslib-5:0=
sci-libs/cfitsio:0=
sys-libs/zlib:0="
@@ -34,13 +34,13 @@ DEPEND="${RDEPEND}
virtual/pkgconfig
doc? (
media-gfx/graphviz
- $(python_gen_cond_dep 'dev-libs/libxml2[${PYTHON_USEDEP}]' python2_7)
- $(python_gen_cond_dep 'dev-python/h5py[${PYTHON_USEDEP}]' python2_7)
- $(python_gen_cond_dep 'dev-python/matplotlib[${PYTHON_USEDEP}]' python2_7)
- $(python_gen_cond_dep 'dev-python/pytest[${PYTHON_USEDEP}]' python2_7)
- $(python_gen_cond_dep 'dev-python/sphinx[${PYTHON_USEDEP}]' python2_7)
- $(python_gen_cond_dep 'dev-python/wcsaxes[${PYTHON_USEDEP}]' python2_7)
- $(python_gen_cond_dep 'sci-libs/scipy[${PYTHON_USEDEP}]'python2_7)
+ dev-libs/libxml2[${PYTHON_USEDEP}]
+ dev-python/h5py[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/wcsaxes[${PYTHON_USEDEP}]
+ sci-libs/scipy[${PYTHON_USEDEP}]
)
test? (
dev-libs/libxml2[${PYTHON_USEDEP}]
@@ -50,20 +50,13 @@ DEPEND="${RDEPEND}
sci-libs/scipy[${PYTHON_USEDEP}]
)"
-REQUIRED_USE="doc? ( || ( $(python_gen_useflags 'python2*') ) )"
-
PATCHES=(
- "${FILESDIR}/${PN}-1.0.4-system-six.patch"
- "${FILESDIR}/${PN}-1.0.4-system-configobj.patch"
- "${FILESDIR}/${PN}-1.1.1-mark-kown-failures.patch"
- "${FILESDIR}/${PN}-1.1.2-fix-for-pytest-28.patch"
- "${FILESDIR}/${PN}-1.1.2-cfitsio-338.patch"
+ "${FILESDIR}"/${PN}-1.0.4-system-six.patch
+ "${FILESDIR}"/${PN}-1.0.4-system-configobj.patch
+ "${FILESDIR}"/${PN}-1.3-mark-known-failures.patch
+ "${FILESDIR}"/${PN}-1.2.1-cfitsio-338.patch
)
-pkg_setup() {
- use doc && DISTUTILS_ALL_SUBPHASE_IMPLS=( 'python2*' )
-}
-
python_prepare_all() {
export mydistutilsargs="--offline"
export ASTROPY_USE_SYSTEM_PYTEST=True
@@ -75,12 +68,12 @@ python_prepare_all() {
[build]
use_system_libraries=1
EOF
+ xdg_environment_reset
distutils-r1_python_prepare_all
}
python_compile_all() {
if use doc; then
- python_setup "python2*"
VARTEXFONTS="${T}"/fonts \
MPLCONFIGDIR="${BUILD_DIR}" \
PYTHONPATH="${BUILD_DIR}"/lib \
diff --git a/dev-python/astropy/files/astropy-1.1.2-cfitsio-338.patch b/dev-python/astropy/files/astropy-1.1.2-cfitsio-338.patch
deleted file mode 100644
index d4a8fa072c5d..000000000000
--- a/dev-python/astropy/files/astropy-1.1.2-cfitsio-338.patch
+++ /dev/null
@@ -1,35 +0,0 @@
-Author: Ole Streicher <olebole@debian.org>
-Description: Make TFORMx check more flexible
- The maximal column length in cfitsio changed between version 3370 and 3380.
- This patch checks their syntax, without a specific length.
-Bug: https://github.com/astropy/astropy/issues/4646
---- a/astropy/io/fits/tests/test_image.py
-+++ b/astropy/io/fits/tests/test_image.py
-@@ -4,6 +4,7 @@
-
- import math
- import os
-+import re
- import time
- import warnings
-
-@@ -1010,7 +1011,7 @@
- hdu.writeto(self.temp('test.fits'))
-
- with fits.open(self.temp('test.fits')) as hdul:
-- assert (hdul['SCI'].data == cube).all()
-+ assert np.abs(hdul['SCI'].data - cube).max() < 1./15.
-
- def test_subtractive_dither_seed(self):
- """
-@@ -1265,8 +1266,8 @@
-
- with fits.open(self.temp('test.fits'),
- disable_image_compression=True) as h:
-- assert h[1].header['TFORM1'] == '1PB(30)'
-- assert h[1].header['TFORM2'] == '1PB(359)'
-+ assert re.match(r'^1PB\(\d+\)$', h[1].header['TFORM1'])
-+ assert re.match(r'^1PB\(\d+\)$', h[1].header['TFORM2'])
-
- def test_compression_update_header(self):
- """Regression test for
diff --git a/dev-python/astropy/files/astropy-1.1.2-fix-for-pytest-28.patch b/dev-python/astropy/files/astropy-1.1.2-fix-for-pytest-28.patch
deleted file mode 100644
index 0d62e9c963a4..000000000000
--- a/dev-python/astropy/files/astropy-1.1.2-fix-for-pytest-28.patch
+++ /dev/null
@@ -1,37 +0,0 @@
-From e904df784b91fd45e7dfcdec0713c471bb03efff Mon Sep 17 00:00:00 2001
-From: Thomas Robitaille <thomas.robitaille@gmail.com>
-Date: Fri, 1 Jan 2016 19:36:39 +0000
-Bug: https://bugs.debian.org/812648
-Bug: https://github.com/astropy/astropy/pull/4349
-Subject: [PATCH] Fixes to pytest plugins for pytest >= 2.8.0
---- a/astropy/tests/pytest_plugins.py
-+++ b/astropy/tests/pytest_plugins.py
-@@ -161,7 +161,10 @@
- # handling __doctest_skip__) doesn't happen.
- def collect(self):
- if self.fspath.basename == "conftest.py":
-- module = self.config._conftest.importconftest(self.fspath)
-+ try:
-+ module = self.config._conftest.importconftest(self.fspath)
-+ except AttributeError: # pytest >= 2.8.0
-+ module = self.config.pluginmanager._importconftest(self.fspath)
- else:
- try:
- module = self.fspath.pyimport()
-@@ -191,8 +194,14 @@
- def runtest(self):
- # satisfy `FixtureRequest` constructor...
- self.funcargs = {}
-- self._fixtureinfo = doctest_plugin.FuncFixtureInfo((), [], {})
-- fixture_request = doctest_plugin.FixtureRequest(self)
-+ try:
-+ self._fixtureinfo = doctest_plugin.FuncFixtureInfo((), [], {})
-+ fixture_request = doctest_plugin.FixtureRequest(self)
-+ except AttributeError: # pytest >= 2.8.0
-+ python_plugin = config.pluginmanager.getplugin('python')
-+ self._fixtureinfo = python_plugin.FuncFixtureInfo((), [], {})
-+ fixture_request = python_plugin.FixtureRequest(self)
-+
- failed, tot = doctest.testfile(
- str(self.fspath), module_relative=False,
- optionflags=opts, parser=DocTestParserPlus(),
diff --git a/dev-python/astropy/files/astropy-1.3-mark-known-failures.patch b/dev-python/astropy/files/astropy-1.3-mark-known-failures.patch
new file mode 100644
index 000000000000..1a30bc1d10ab
--- /dev/null
+++ b/dev-python/astropy/files/astropy-1.3-mark-known-failures.patch
@@ -0,0 +1,84 @@
+From: Ole Streicher <olebole@debian.org>
+Date: Tue, 13 Dec 2016 09:41:39 +0100
+Subject: Mark all known test failures as xfail. These failures have been
+ discussed with upstream.
+
+---
+ astropy/table/tests/test_info.py | 4 +++-
+ astropy/tests/tests/test_socketblocker.py | 4 ++--
+ astropy/visualization/wcsaxes/tests/test_display_world_coordinates.py | 4 ++++
+ astropy/vo/samp/tests/test_standard_profile.py | 2 ++
+ 4 files changed, 11 insertions(+), 3 deletions(-)
+
+diff --git a/astropy/table/tests/test_info.py b/astropy/table/tests/test_info.py
+index 2bbcc7a..50fbdb4 100644
+--- a/astropy/table/tests/test_info.py
++++ b/astropy/table/tests/test_info.py
+@@ -8,6 +8,7 @@ from collections import OrderedDict
+
+ import numpy as np
+
++from ...tests.helper import pytest
+ from ...extern import six
+ from ...extern.six.moves import cStringIO as StringIO
+ from ... import units as u
+@@ -229,7 +230,8 @@ def test_class_attribute():
+ t.info(out=out)
+ assert out.getvalue().splitlines() == exp
+
+-
++# see https://github.com/astropy/astropy/issues/4336
++@pytest.mark.xfail()
+ def test_ignore_warnings():
+ t = table.Table([[np.nan, np.nan]])
+ with warnings.catch_warnings(record=True) as warns:
+diff --git a/astropy/tests/tests/test_socketblocker.py b/astropy/tests/tests/test_socketblocker.py
+index c362fa5..783defe 100644
+--- a/astropy/tests/tests/test_socketblocker.py
++++ b/astropy/tests/tests/test_socketblocker.py
+@@ -66,8 +66,8 @@ PY3_4 = sys.version_info[:2] >= (3, 4)
+ def _square(x):
+ return x ** 2
+
+-
+-@pytest.mark.skipif('not PY3_4 or sys.platform == "win32" or sys.platform.startswith("gnu0")')
++# see https://github.com/astropy/astropy/issues/4193
++@pytest.mark.skipif(True, reason="Blocks on Debian CI test")
+ def test_multiprocessing_forkserver():
+ """
+ Test that using multiprocessing with forkserver works. Perhaps
+diff --git a/astropy/visualization/wcsaxes/tests/test_display_world_coordinates.py b/astropy/visualization/wcsaxes/tests/test_display_world_coordinates.py
+index 53436dd..4c710e7 100644
+--- a/astropy/visualization/wcsaxes/tests/test_display_world_coordinates.py
++++ b/astropy/visualization/wcsaxes/tests/test_display_world_coordinates.py
+@@ -3,6 +3,8 @@ from ..core import WCSAxes
+ import matplotlib.pyplot as plt
+ from matplotlib.backend_bases import KeyEvent
+
++import pytest
++
+ from ....wcs import WCS
+ from ....extern import six
+ from ....coordinates import FK5
+@@ -93,6 +95,8 @@ class TestDisplayWorldCoordinate(BaseImageTests):
+
+ assert string_world5 == six.u('267.652 -28\xb046\'23" (world, overlay 3)')
+
++ # See https://github.com/astropy/astropy/issues/5601
++ @pytest.mark.xfail()
+ def test_cube_coords(self, tmpdir):
+ wcs = WCS(self.cube_header)
+
+diff --git a/astropy/vo/samp/tests/test_standard_profile.py b/astropy/vo/samp/tests/test_standard_profile.py
+index 325ac96..ac25e55 100644
+--- a/astropy/vo/samp/tests/test_standard_profile.py
++++ b/astropy/vo/samp/tests/test_standard_profile.py
+@@ -62,6 +62,8 @@ class TestStandardProfile(object):
+
+ self.hub.stop()
+
++ # see https://github.com/astropy/astropy/issues/5460
++ @pytest.mark.skipif(True, reason="Setup fails due to SSL problems")
+ def test_main(self):
+
+ self.client1_id = self.client1.get_public_id()