summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-lang/nqp/Manifest9
-rw-r--r--dev-lang/nqp/metadata.xml1
-rw-r--r--dev-lang/nqp/nqp-2015.01.ebuild66
-rw-r--r--dev-lang/nqp/nqp-2015.02.ebuild66
-rw-r--r--dev-lang/nqp/nqp-2015.03.ebuild66
-rw-r--r--dev-lang/nqp/nqp-2015.04.ebuild66
-rw-r--r--dev-lang/nqp/nqp-2015.05.ebuild66
-rw-r--r--dev-lang/nqp/nqp-2015.06.ebuild66
-rw-r--r--dev-lang/nqp/nqp-2015.07.2.ebuild66
-rw-r--r--dev-lang/nqp/nqp-2015.11.ebuild66
-rw-r--r--dev-lang/nqp/nqp-2015.12.ebuild66
-rw-r--r--dev-lang/nqp/nqp-2016.01.ebuild2
12 files changed, 1 insertions, 605 deletions
diff --git a/dev-lang/nqp/Manifest b/dev-lang/nqp/Manifest
index 940ace5074fb..c9cefeeedc4b 100644
--- a/dev-lang/nqp/Manifest
+++ b/dev-lang/nqp/Manifest
@@ -1,10 +1 @@
-DIST nqp-2015.01.tar.gz 5225188 SHA256 b661cb1c435e64ef39e149d3034414aef17c5bb5d213cdb85c8f30a8e30d475d SHA512 186bc301a55458ca872461b5e4cd98e8abb5163d734427e182112a41e63ba892dedf1f53f10f46f65ac3c3bc101cd74d55942f920f0bbb848fd8e943dc3e294b WHIRLPOOL 34a13340757c1c63172f7499b3ca5f466c8c6bde66c50c5d6b9aa35b9c60b55a18561636fa9bd165b037662fa7cf988addbd7b5c720f505986f0227a9b551219
-DIST nqp-2015.02.tar.gz 5231834 SHA256 f35c480e49fb68e2c7c99f4ab752d59ffecbb017350ed4e11b011335ae673a1b SHA512 cd25e8edb3dd25e16f6fde5d5d1752b6afdb1acb4f00b8be9348cc927bfba3708aef60c1bba63f9856b32e349277e09ed516661b79dd734415d6fbc6466a67b1 WHIRLPOOL 0bc36047ff5bd788691c1a7a0064d766c5b6c5edf4a3f2ab0dbb004f601e665bf67a15cf677a6634a7937c191afbe9eafad99c2096633324f96eaf0bc0b83c56
-DIST nqp-2015.03.tar.gz 5240119 SHA256 203c31c516a370204d8193ac824956ffd7fb5f71edbdb9712da0b20f98729020 SHA512 11f85230277929ea9f78c4c0fad867143b6e8c3eeaeec53ca2cf676c3905d071b147fad42fcbf4e83f01b2afbf80ffae15ce753d615432442af16db5a76af0c5 WHIRLPOOL 3f3944529715b1b52672d0a13bf21509f754606762ed728d503d77d3706ab4725faefc3026d34d2a9ec1efacd3f6fc17c3b9f86018ac3068c2f75a37cc12bd2a
-DIST nqp-2015.04.tar.gz 4995958 SHA256 a58e45ae42035102222bf3b3b62bd3892ccaec5aeb4b9629c6d593749d68d9b3 SHA512 84748167aef995c7e1b4c1b19e165d940ca13c7ee08802a92ada8879247dc91b01ded6d8e2a58772b4e3564628114857dcf7b5f25ce4e63ceeec17c997958fbb WHIRLPOOL c8f16aed500116f70fb7e4b039e636d46d2e519d30740f84ef8f480db0e90865425b9e4b28eaeccdc63bc02841420500562d29a63158fa8afaf83612635e8218
-DIST nqp-2015.05.tar.gz 4985712 SHA256 ad54f05422d0fbe14483b91de26c195a2d7e21e19446c6374aba5342458c7762 SHA512 0190f8e27b6dcc77cfc8f35efb7b7871e2efb56284ad7cb25b5662c14d5844262d2c491a43f8b60d567402bf2dd5264ad8736de3334d804173e3aa36a93c7449 WHIRLPOOL f4ebddf27db049478ed70c6dfbce0bda06aecddc6a088f73ee484b6f2da5aa2c59ea60619b871477b2c08ccf9969ccfcc636972d14c9c3da791a929f402f1259
-DIST nqp-2015.06.tar.gz 4986918 SHA256 07dd6ea9762c9a3d5e477472cd65584b5e00fef1403c540d2b4ce802c2cc9d26 SHA512 f5d8e9dc057d303745d691eb6f92222c6586077a8f5c3ce0bf8557f715fa7e9ddea6a333e7db1743ed9982189e13e920c0228b40e22bfd3eac9b889a589bc3cb WHIRLPOOL a8164398f54fbc1609f52352e01112681390959a53b1c3d61192800ad2ec40e3ac79c2cb67108f10ab3bd277a540b52aa16e2d989461a860990cef5c92f02b3a
-DIST nqp-2015.07.2.tar.gz 5001361 SHA256 45cde1880b314d98dd20062e93ef28f083dbf2239784e8f050456df8520a25c1 SHA512 b40ad51e37504b0c05e3d27c7a09543bb4735b3d8758a34805034600e362ae327434584f6824ef72587c37de5b51b476dbb05e8f0f248dc49ed64449f2ba1917 WHIRLPOOL 692f4ac9c669f7cf3b56e81b659f4b1d50296b4dccf9effa6f08aca9082f3b501fad140f7411e9ddbada15a5c458be21b699e850ed04574ed53699d2d28be084
-DIST nqp-2015.11.tar.gz 5113497 SHA256 f9a5e33e628d56b1210a049363198ed05b465024d4f259809f1b1617eb49b568 SHA512 94f464c055b308ee408240d3cbb7e30b71de99c14e97b5bbaa5fbbe4bc021f60b5567de0113628e2dfb89152eb6a00c8d0cfee92c3b54c5c5fd473c2f00e2cf7 WHIRLPOOL 57151fe290dc6674cb10b190349d8809cff90d10385500fda7772d2d78539d492b18be49d1bd903a96c6a9d1bc26a797f7cf3f956891b0af3820c70ce7307d7d
-DIST nqp-2015.12.tar.gz 5135635 SHA256 4d77681ec4e0fa0c91bf346ab2bb076981921d29e1fbb9964a2a025d7283bbb7 SHA512 97ef4a52b2b7b461f57cbc2c80f3d2b0056125960c77527f1c9ea2ab21f1882bbeb238e7a5b50c7cd88ac60f74a2b600b85ae9ba70db0209b90a91d68b49216d WHIRLPOOL 79257972580ba0737bb2be7eb2cae3203ae9feefa8e268d5f3ef688ba8cfd9b7aa8126e9431a1d4ef7274f9a93a4751741efd79314b300bca177dd3de5e37018
DIST nqp-2016.01.tar.gz 5117110 SHA256 87875120af7167093643f2a35869d66a61f735220a9348627ba89cf294387c8b SHA512 e79668f7f5f3679fe3b93f63e1151da1eab109ef4acc6f8ae3da3d9e5c3da814440dd43279978b1a13f30647d7c52bda5575b02f366bd928965b06b47c6d6d91 WHIRLPOOL d2369417707332d8bc045f6f93da81e1301ec2599f197664d80e6edeefc1bc7a2147ad3b7e893eef0fb6b96adf2f68f5ab44b948801e266e68d99552253abeda
diff --git a/dev-lang/nqp/metadata.xml b/dev-lang/nqp/metadata.xml
index 2a5adc19de0e..a710c2f5990b 100644
--- a/dev-lang/nqp/metadata.xml
+++ b/dev-lang/nqp/metadata.xml
@@ -10,7 +10,6 @@
<name>Gentoo Perl Project</name>
</maintainer>
<use>
- <flag name="parrot">Build the parrot backend (default)</flag>
<flag name="moar">Build the MoarVM backend (experimental/broken)</flag>
</use>
<upstream>
diff --git a/dev-lang/nqp/nqp-2015.01.ebuild b/dev-lang/nqp/nqp-2015.01.ebuild
deleted file mode 100644
index 13c20532a3b4..000000000000
--- a/dev-lang/nqp/nqp-2015.01.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-# still not working
-RESTRICT="test"
-
-inherit eutils multilib versionator
-
-GITCRAP=bba0461
-PARROT_VERSION="6.7.0"
-
-DESCRIPTION="Not Quite Perl, a Perl 6 bootstrapping compiler"
-HOMEPAGE="http://rakudo.org/"
-SRC_URI="https://github.com/perl6/${PN}/tarball/${PV} -> ${P}.tar.gz"
-
-LICENSE="Artistic-2"
-SLOT="0"
-KEYWORDS="~x86 ~amd64"
-IUSE="doc +parrot java moar"
-REQUIRED_USE="|| ( parrot java moar )"
-
-RDEPEND="parrot? ( >=dev-lang/parrot-${PARROT_VERSION}:=[unicode] )
- java? ( >=virtual/jre-1.7 )
- moar? ( =dev-lang/moarvm-${PV} )
- dev-libs/libffi"
-DEPEND="${RDEPEND}
- java? ( >=virtual/jdk-1.7 )
- dev-lang/perl"
-
-S=${WORKDIR}/perl6-nqp-${GITCRAP}
-
-src_configure() {
- use java && myconf+="jvm,"
- use parrot && myconf+="parrot,"
- use moar && myconf+="moar,"
- perl Configure.pl --backend=${myconf} --prefix=/usr || die
- # dirty hack to make dyncall not fail
- sed -i -e 's/-Werror=missing-prototypes//' Makefile || die
- sed -i -e 's/-Werror=missing-declarations//' Makefile || die
- sed -i -e 's/-Werror=strict-prototypes//' Makefile || die
-
- # more dirty hack to allow building with newer gcc
- sed -i -e 's/-Werror=implicit-function-declaration//' Makefile || die
- sed -i -e 's/-Werror=nested-externs//' Makefile || die
-}
-
-src_compile() {
- emake -j1 || die
-}
-
-src_test() {
- emake -j1 test || die
-}
-
-src_install() {
- emake DESTDIR="${ED}" install || die
-
- dodoc CREDITS README.pod || die
-
- if use doc; then
- dodoc -r docs/* || die
- fi
-}
diff --git a/dev-lang/nqp/nqp-2015.02.ebuild b/dev-lang/nqp/nqp-2015.02.ebuild
deleted file mode 100644
index ca5b2d22cb77..000000000000
--- a/dev-lang/nqp/nqp-2015.02.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-# still not working
-RESTRICT="test"
-
-inherit eutils multilib versionator
-
-GITCRAP=48279f9
-PARROT_VERSION="6.7.0"
-
-DESCRIPTION="Not Quite Perl, a Perl 6 bootstrapping compiler"
-HOMEPAGE="http://rakudo.org/"
-SRC_URI="https://github.com/perl6/${PN}/tarball/${PV} -> ${P}.tar.gz"
-
-LICENSE="Artistic-2"
-SLOT="0"
-KEYWORDS="~x86 ~amd64"
-IUSE="doc +parrot java moar"
-REQUIRED_USE="|| ( parrot java moar )"
-
-RDEPEND="parrot? ( >=dev-lang/parrot-${PARROT_VERSION}:=[unicode] )
- java? ( >=virtual/jre-1.7 )
- moar? ( =dev-lang/moarvm-${PV} )
- dev-libs/libffi"
-DEPEND="${RDEPEND}
- java? ( >=virtual/jdk-1.7 )
- dev-lang/perl"
-
-S=${WORKDIR}/perl6-nqp-${GITCRAP}
-
-src_configure() {
- use java && myconf+="jvm,"
- use parrot && myconf+="parrot,"
- use moar && myconf+="moar,"
- perl Configure.pl --backend=${myconf} --prefix=/usr || die
- # dirty hack to make dyncall not fail
- sed -i -e 's/-Werror=missing-prototypes//' Makefile || die
- sed -i -e 's/-Werror=missing-declarations//' Makefile || die
- sed -i -e 's/-Werror=strict-prototypes//' Makefile || die
-
- # more dirty hack to allow building with newer gcc
- sed -i -e 's/-Werror=implicit-function-declaration//' Makefile || die
- sed -i -e 's/-Werror=nested-externs//' Makefile || die
-}
-
-src_compile() {
- emake -j1 || die
-}
-
-src_test() {
- emake -j1 test || die
-}
-
-src_install() {
- emake DESTDIR="${ED}" install || die
-
- dodoc CREDITS README.pod || die
-
- if use doc; then
- dodoc -r docs/* || die
- fi
-}
diff --git a/dev-lang/nqp/nqp-2015.03.ebuild b/dev-lang/nqp/nqp-2015.03.ebuild
deleted file mode 100644
index 2b3f36f3e687..000000000000
--- a/dev-lang/nqp/nqp-2015.03.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-# still not working
-RESTRICT="test"
-
-inherit eutils multilib versionator
-
-GITCRAP=6104d87
-PARROT_VERSION="6.7.0"
-
-DESCRIPTION="Not Quite Perl, a Perl 6 bootstrapping compiler"
-HOMEPAGE="http://rakudo.org/"
-SRC_URI="https://github.com/perl6/${PN}/tarball/${PV} -> ${P}.tar.gz"
-
-LICENSE="Artistic-2"
-SLOT="0"
-KEYWORDS="~x86 ~amd64"
-IUSE="doc +parrot java moar"
-REQUIRED_USE="|| ( parrot java moar )"
-
-RDEPEND="parrot? ( >=dev-lang/parrot-${PARROT_VERSION}:=[unicode] )
- java? ( >=virtual/jre-1.7 )
- moar? ( =dev-lang/moarvm-${PV} )
- dev-libs/libffi"
-DEPEND="${RDEPEND}
- java? ( >=virtual/jdk-1.7 )
- dev-lang/perl"
-
-S=${WORKDIR}/perl6-nqp-${GITCRAP}
-
-src_configure() {
- use java && myconf+="jvm,"
- use parrot && myconf+="parrot,"
- use moar && myconf+="moar,"
- perl Configure.pl --backend=${myconf} --prefix=/usr || die
- # dirty hack to make dyncall not fail
- sed -i -e 's/-Werror=missing-prototypes//' Makefile || die
- sed -i -e 's/-Werror=missing-declarations//' Makefile || die
- sed -i -e 's/-Werror=strict-prototypes//' Makefile || die
-
- # more dirty hack to allow building with newer gcc
- sed -i -e 's/-Werror=implicit-function-declaration//' Makefile || die
- sed -i -e 's/-Werror=nested-externs//' Makefile || die
-}
-
-src_compile() {
- emake -j1 || die
-}
-
-src_test() {
- emake -j1 test || die
-}
-
-src_install() {
- emake DESTDIR="${ED}" install || die
-
- dodoc CREDITS README.pod || die
-
- if use doc; then
- dodoc -r docs/* || die
- fi
-}
diff --git a/dev-lang/nqp/nqp-2015.04.ebuild b/dev-lang/nqp/nqp-2015.04.ebuild
deleted file mode 100644
index 98b5107e7742..000000000000
--- a/dev-lang/nqp/nqp-2015.04.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-# still not working
-RESTRICT="test"
-
-inherit eutils multilib versionator
-
-GITCRAP=e415a4f
-PARROT_VERSION="6.7.0"
-
-DESCRIPTION="Not Quite Perl, a Perl 6 bootstrapping compiler"
-HOMEPAGE="http://rakudo.org/"
-SRC_URI="https://github.com/perl6/${PN}/tarball/${PV} -> ${P}.tar.gz"
-
-LICENSE="Artistic-2"
-SLOT="0"
-KEYWORDS="~x86 ~amd64"
-IUSE="doc +parrot java moar"
-REQUIRED_USE="|| ( parrot java moar )"
-
-RDEPEND="parrot? ( >=dev-lang/parrot-${PARROT_VERSION}:=[unicode] )
- java? ( >=virtual/jre-1.7 )
- moar? ( =dev-lang/moarvm-${PV} )
- dev-libs/libffi"
-DEPEND="${RDEPEND}
- java? ( >=virtual/jdk-1.7 )
- dev-lang/perl"
-
-S=${WORKDIR}/perl6-nqp-${GITCRAP}
-
-src_configure() {
- use java && myconf+="jvm,"
- use parrot && myconf+="parrot,"
- use moar && myconf+="moar,"
- perl Configure.pl --backend=${myconf} --prefix=/usr || die
- # dirty hack to make dyncall not fail
- sed -i -e 's/-Werror=missing-prototypes//' Makefile || die
- sed -i -e 's/-Werror=missing-declarations//' Makefile || die
- sed -i -e 's/-Werror=strict-prototypes//' Makefile || die
-
- # more dirty hack to allow building with newer gcc
- sed -i -e 's/-Werror=implicit-function-declaration//' Makefile || die
- sed -i -e 's/-Werror=nested-externs//' Makefile || die
-}
-
-src_compile() {
- emake -j1 || die
-}
-
-src_test() {
- emake -j1 test || die
-}
-
-src_install() {
- emake DESTDIR="${ED}" install || die
-
- dodoc CREDITS README.pod || die
-
- if use doc; then
- dodoc -r docs/* || die
- fi
-}
diff --git a/dev-lang/nqp/nqp-2015.05.ebuild b/dev-lang/nqp/nqp-2015.05.ebuild
deleted file mode 100644
index e221b8e0d15b..000000000000
--- a/dev-lang/nqp/nqp-2015.05.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-# still not working
-RESTRICT="test"
-
-inherit eutils multilib versionator
-
-GITCRAP=d99efa9
-PARROT_VERSION="6.7.0"
-
-DESCRIPTION="Not Quite Perl, a Perl 6 bootstrapping compiler"
-HOMEPAGE="http://rakudo.org/"
-SRC_URI="https://github.com/perl6/${PN}/tarball/${PV} -> ${P}.tar.gz"
-
-LICENSE="Artistic-2"
-SLOT="0"
-KEYWORDS="~x86 ~amd64"
-IUSE="doc parrot java +moar"
-REQUIRED_USE="|| ( parrot java moar )"
-
-RDEPEND="parrot? ( >=dev-lang/parrot-${PARROT_VERSION}:=[unicode] )
- java? ( >=virtual/jre-1.7 )
- moar? ( =dev-lang/moarvm-${PV} )
- dev-libs/libffi"
-DEPEND="${RDEPEND}
- java? ( >=virtual/jdk-1.7 )
- dev-lang/perl"
-
-S=${WORKDIR}/perl6-nqp-${GITCRAP}
-
-src_configure() {
- use java && myconf+="jvm,"
- use parrot && myconf+="parrot,"
- use moar && myconf+="moar,"
- perl Configure.pl --backend=${myconf} --prefix=/usr || die
- # dirty hack to make dyncall not fail
- sed -i -e 's/-Werror=missing-prototypes//' Makefile || die
- sed -i -e 's/-Werror=missing-declarations//' Makefile || die
- sed -i -e 's/-Werror=strict-prototypes//' Makefile || die
-
- # more dirty hack to allow building with newer gcc
- sed -i -e 's/-Werror=implicit-function-declaration//' Makefile || die
- sed -i -e 's/-Werror=nested-externs//' Makefile || die
-}
-
-src_compile() {
- emake -j1 || die
-}
-
-src_test() {
- emake -j1 test || die
-}
-
-src_install() {
- emake DESTDIR="${ED}" install || die
-
- dodoc CREDITS README.pod || die
-
- if use doc; then
- dodoc -r docs/* || die
- fi
-}
diff --git a/dev-lang/nqp/nqp-2015.06.ebuild b/dev-lang/nqp/nqp-2015.06.ebuild
deleted file mode 100644
index c57cbe3125eb..000000000000
--- a/dev-lang/nqp/nqp-2015.06.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-# still not working
-RESTRICT="test"
-
-inherit eutils multilib versionator
-
-GITCRAP=10ccaf4
-PARROT_VERSION="6.7.0"
-
-DESCRIPTION="Not Quite Perl, a Perl 6 bootstrapping compiler"
-HOMEPAGE="http://rakudo.org/"
-SRC_URI="https://github.com/perl6/${PN}/tarball/${PV} -> ${P}.tar.gz"
-
-LICENSE="Artistic-2"
-SLOT="0"
-KEYWORDS="~x86 ~amd64"
-IUSE="doc parrot java +moar"
-REQUIRED_USE="|| ( parrot java moar )"
-
-RDEPEND="parrot? ( >=dev-lang/parrot-${PARROT_VERSION}:=[unicode] )
- java? ( >=virtual/jre-1.7 )
- moar? ( =dev-lang/moarvm-${PV} )
- dev-libs/libffi"
-DEPEND="${RDEPEND}
- java? ( >=virtual/jdk-1.7 )
- dev-lang/perl"
-
-S=${WORKDIR}/perl6-nqp-${GITCRAP}
-
-src_configure() {
- use java && myconf+="jvm,"
- use parrot && myconf+="parrot,"
- use moar && myconf+="moar,"
- perl Configure.pl --backend=${myconf} --prefix=/usr || die
- # dirty hack to make dyncall not fail
- sed -i -e 's/-Werror=missing-prototypes//' Makefile || die
- sed -i -e 's/-Werror=missing-declarations//' Makefile || die
- sed -i -e 's/-Werror=strict-prototypes//' Makefile || die
-
- # more dirty hack to allow building with newer gcc
- sed -i -e 's/-Werror=implicit-function-declaration//' Makefile || die
- sed -i -e 's/-Werror=nested-externs//' Makefile || die
-}
-
-src_compile() {
- emake -j1 || die
-}
-
-src_test() {
- emake -j1 test || die
-}
-
-src_install() {
- emake DESTDIR="${ED}" install || die
-
- dodoc CREDITS README.pod || die
-
- if use doc; then
- dodoc -r docs/* || die
- fi
-}
diff --git a/dev-lang/nqp/nqp-2015.07.2.ebuild b/dev-lang/nqp/nqp-2015.07.2.ebuild
deleted file mode 100644
index 0c629be4081f..000000000000
--- a/dev-lang/nqp/nqp-2015.07.2.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-# still not working
-RESTRICT="test"
-
-inherit eutils multilib versionator
-
-GITCRAP=2d22571
-PARROT_VERSION="6.7.0"
-
-DESCRIPTION="Not Quite Perl, a Perl 6 bootstrapping compiler"
-HOMEPAGE="http://rakudo.org/"
-SRC_URI="https://github.com/perl6/${PN}/tarball/${PV} -> ${P}.tar.gz"
-
-LICENSE="Artistic-2"
-SLOT="0"
-KEYWORDS="~x86 ~amd64"
-IUSE="doc parrot java +moar"
-REQUIRED_USE="|| ( parrot java moar )"
-
-RDEPEND="parrot? ( >=dev-lang/parrot-${PARROT_VERSION}:=[unicode] )
- java? ( >=virtual/jre-1.7 )
- moar? ( =dev-lang/moarvm-2015.07 )
- dev-libs/libffi"
-DEPEND="${RDEPEND}
- java? ( >=virtual/jdk-1.7 )
- dev-lang/perl"
-
-S=${WORKDIR}/perl6-nqp-${GITCRAP}
-
-src_configure() {
- use java && myconf+="jvm,"
- use parrot && myconf+="parrot,"
- use moar && myconf+="moar,"
- perl Configure.pl --backend=${myconf} --prefix=/usr || die
- # dirty hack to make dyncall not fail
- sed -i -e 's/-Werror=missing-prototypes//' Makefile || die
- sed -i -e 's/-Werror=missing-declarations//' Makefile || die
- sed -i -e 's/-Werror=strict-prototypes//' Makefile || die
-
- # more dirty hack to allow building with newer gcc
- sed -i -e 's/-Werror=implicit-function-declaration//' Makefile || die
- sed -i -e 's/-Werror=nested-externs//' Makefile || die
-}
-
-src_compile() {
- emake -j1 || die
-}
-
-src_test() {
- emake -j1 test || die
-}
-
-src_install() {
- emake DESTDIR="${ED}" install || die
-
- dodoc CREDITS README.pod || die
-
- if use doc; then
- dodoc -r docs/* || die
- fi
-}
diff --git a/dev-lang/nqp/nqp-2015.11.ebuild b/dev-lang/nqp/nqp-2015.11.ebuild
deleted file mode 100644
index 12f4c3c135e0..000000000000
--- a/dev-lang/nqp/nqp-2015.11.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-# still not working
-RESTRICT="test"
-
-inherit eutils multilib versionator
-
-GITCRAP=a796efb
-PARROT_VERSION="6.7.0"
-
-DESCRIPTION="Not Quite Perl, a Perl 6 bootstrapping compiler"
-HOMEPAGE="http://rakudo.org/"
-SRC_URI="https://github.com/perl6/${PN}/tarball/${PV} -> ${P}.tar.gz"
-
-LICENSE="Artistic-2"
-SLOT="0"
-KEYWORDS="~x86 ~amd64"
-IUSE="doc parrot java +moar"
-REQUIRED_USE="|| ( parrot java moar )"
-
-RDEPEND="parrot? ( >=dev-lang/parrot-${PARROT_VERSION}:=[unicode] )
- java? ( >=virtual/jre-1.7 )
- moar? ( =dev-lang/moarvm-${PV} )
- dev-libs/libffi"
-DEPEND="${RDEPEND}
- java? ( >=virtual/jdk-1.7 )
- dev-lang/perl"
-
-S=${WORKDIR}/perl6-nqp-${GITCRAP}
-
-src_configure() {
- use java && myconf+="jvm,"
- use parrot && myconf+="parrot,"
- use moar && myconf+="moar,"
- perl Configure.pl --backend=${myconf} --prefix=/usr || die
- # dirty hack to make dyncall not fail
- sed -i -e 's/-Werror=missing-prototypes//' Makefile || die
- sed -i -e 's/-Werror=missing-declarations//' Makefile || die
- sed -i -e 's/-Werror=strict-prototypes//' Makefile || die
-
- # more dirty hack to allow building with newer gcc
- sed -i -e 's/-Werror=implicit-function-declaration//' Makefile || die
- sed -i -e 's/-Werror=nested-externs//' Makefile || die
-}
-
-src_compile() {
- emake -j1 || die
-}
-
-src_test() {
- emake -j1 test || die
-}
-
-src_install() {
- emake DESTDIR="${ED}" install || die
-
- dodoc CREDITS README.pod || die
-
- if use doc; then
- dodoc -r docs/* || die
- fi
-}
diff --git a/dev-lang/nqp/nqp-2015.12.ebuild b/dev-lang/nqp/nqp-2015.12.ebuild
deleted file mode 100644
index 94d7ff9701e3..000000000000
--- a/dev-lang/nqp/nqp-2015.12.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-# still not working
-RESTRICT="test"
-
-inherit eutils multilib versionator
-
-GITCRAP=a54e409
-PARROT_VERSION="6.7.0"
-
-DESCRIPTION="Not Quite Perl, a Perl 6 bootstrapping compiler"
-HOMEPAGE="http://rakudo.org/"
-SRC_URI="https://github.com/perl6/${PN}/tarball/${PV} -> ${P}.tar.gz"
-
-LICENSE="Artistic-2"
-SLOT="0"
-KEYWORDS="~x86 ~amd64"
-IUSE="doc parrot java +moar"
-REQUIRED_USE="|| ( parrot java moar )"
-
-RDEPEND="parrot? ( >=dev-lang/parrot-${PARROT_VERSION}:=[unicode] )
- java? ( >=virtual/jre-1.7 )
- moar? ( =dev-lang/moarvm-${PV} )
- dev-libs/libffi"
-DEPEND="${RDEPEND}
- java? ( >=virtual/jdk-1.7 )
- dev-lang/perl"
-
-S=${WORKDIR}/perl6-nqp-${GITCRAP}
-
-src_configure() {
- use java && myconf+="jvm,"
- use parrot && myconf+="parrot,"
- use moar && myconf+="moar,"
- perl Configure.pl --backend=${myconf} --prefix=/usr || die
- # dirty hack to make dyncall not fail
- sed -i -e 's/-Werror=missing-prototypes//' Makefile || die
- sed -i -e 's/-Werror=missing-declarations//' Makefile || die
- sed -i -e 's/-Werror=strict-prototypes//' Makefile || die
-
- # more dirty hack to allow building with newer gcc
- sed -i -e 's/-Werror=implicit-function-declaration//' Makefile || die
- sed -i -e 's/-Werror=nested-externs//' Makefile || die
-}
-
-src_compile() {
- emake -j1 || die
-}
-
-src_test() {
- emake -j1 test || die
-}
-
-src_install() {
- emake DESTDIR="${ED}" install || die
-
- dodoc CREDITS README.pod || die
-
- if use doc; then
- dodoc -r docs/* || die
- fi
-}
diff --git a/dev-lang/nqp/nqp-2016.01.ebuild b/dev-lang/nqp/nqp-2016.01.ebuild
index 9a6425148680..39d021f2577d 100644
--- a/dev-lang/nqp/nqp-2016.01.ebuild
+++ b/dev-lang/nqp/nqp-2016.01.ebuild
@@ -23,7 +23,7 @@ REQUIRED_USE="|| ( java moar )"
RDEPEND="
java? ( >=virtual/jre-1.7 )
- moar? ( =dev-lang/moarvm-${PV} )
+ moar? ( ~dev-lang/moarvm-${PV} )
dev-libs/libffi"
DEPEND="${RDEPEND}
java? ( >=virtual/jdk-1.7 )