summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-admin/mongo-tools/Manifest2
-rw-r--r--app-admin/mongo-tools/mongo-tools-3.6.12.ebuild71
-rw-r--r--app-admin/mongo-tools/mongo-tools-4.0.8.ebuild71
3 files changed, 144 insertions, 0 deletions
diff --git a/app-admin/mongo-tools/Manifest b/app-admin/mongo-tools/Manifest
index 10f66a07e88d..4b2f280cd26d 100644
--- a/app-admin/mongo-tools/Manifest
+++ b/app-admin/mongo-tools/Manifest
@@ -1,5 +1,7 @@
DIST mongo-tools-3.4.16.tar.gz 4697191 BLAKE2B 2e9a0e7dc8016d3e7d7c7f8d0cf80a97d3d199603c0b8b791df5a0d79d418ffaa232eee694047a7ca11fa7623023b4123becd437cfe3dec11e26cd525720bcad SHA512 b40c6dee75d860de1da73faf79f5f68c098ce7c80681486c66fff04a937474dcede91c7be907a8e36033b3898f7499e8f53271944c0df3360756c27361efb6f5
DIST mongo-tools-3.6.10.tar.gz 4731097 BLAKE2B dffd18bbcb5a1d869cd3a00b40be7c83d12c2146944044c8d873eba409b9fcb0ce0595c01cd61a6b0405dfce685b8dde7c285380150906d4d38d3de9b42962bf SHA512 3e9808c6b275566215f8c2ce033a6259d373e8b63db5e981cc28235d757404b3209a64dd9aa8a98d9290c5c1da137a1bf9bc48629b278cb27ca28be681e86efc
DIST mongo-tools-3.6.11.tar.gz 4731680 BLAKE2B 88558a26d2552848121d984e4b963acafe9e56b37a3d393bacdcd8c0f71a29e2082845ad6d648c3c4800bd47514d339d1f1e984e339a48572ecb5f6f31d9166d SHA512 2291cb963965a59a89bac35a760ce49b4b835d1447065d558c4b254aae5fe38f7ebe4c9d7a67aa475e06be95c45f8529922c6fb0b78d41bc07d1a83f3a564192
+DIST mongo-tools-3.6.12.tar.gz 4990846 BLAKE2B a2b649df03ba17175d95b0fb7be94e446a0cda8dd45111a41f6f74ee5498b853d9fd361f683d4db558197a1951fc79056b516cff6fcd32cc32877744456b67e3 SHA512 948e49719c958e8b7cd1c27b9d413df6d032189801180540ee86b927d5dd53ab4b8906e5cc7880163ecc6abf11daebfc2fb96fcf8fcfd3e0b1f8c8fedaf54558
DIST mongo-tools-3.6.8.tar.gz 4723878 BLAKE2B a1693024d60f69d25c268eaaa30a478b1e4c0042c5fb7a3fd6252ed00aef2fee3fba94516fe825165a1a57887ed38e4fbce488c48ddd4f45349f0b7a1b244020 SHA512 359e8ce2d847d005d48ff12bc2e8af73213d81cd1521d2b5b5ac94792468218248bebbe808e1bd8fd49234eab8480608f294c1b63f317aed58f456b84ef17dcf
DIST mongo-tools-4.0.6.tar.gz 10879606 BLAKE2B 9a7656ba1486df4b36ceb527735ad46864d7a04f2d0451fb4e04bbbdc09c3bb0ec922aa5daa584b93e123e1c3764c0ebef96a3566dd0d6b646a627d769645619 SHA512 d6185d7442a593d29db78889c55aba53e070bedd522d78d8c0bf52bb27f26c5fee6d010457f65774ea36a2e6d5280f38c95433ff76ed53ed9d74b1c811198cb7
+DIST mongo-tools-4.0.8.tar.gz 11134459 BLAKE2B 4f47fcb0037ab0317a3e774ce8411c8add07218ea076d0b54f5aed3d76ca72e739b61c76bee505df52f1c916c1d77a683bd890a409d1d814e9b2389e37f1ee9b SHA512 9e6886038b8c28d50cbec9f76869aceb79eb3214868bca367a6f7a74c346ff5da8d0ee4567bb6c17436860679ca97add3e24e6ba69a6a8d5764c0e1bc5b04813
diff --git a/app-admin/mongo-tools/mongo-tools-3.6.12.ebuild b/app-admin/mongo-tools/mongo-tools-3.6.12.ebuild
new file mode 100644
index 000000000000..092d770686fb
--- /dev/null
+++ b/app-admin/mongo-tools/mongo-tools-3.6.12.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PV=${PV/_rc/-rc}
+MY_P=${PN}-r${MY_PV}
+
+DESCRIPTION="A high-performance, open source, schema-free document-oriented database"
+HOMEPAGE="https://www.mongodb.com"
+SRC_URI="https://github.com/mongodb/mongo-tools/archive/r${MY_PV}.tar.gz -> mongo-tools-${MY_PV}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="sasl ssl"
+
+DEPEND="dev-lang/go:=
+ net-libs/libpcap
+ sasl? ( dev-libs/cyrus-sasl )
+ ssl? ( dev-libs/openssl:0= )"
+
+# Do not complain about CFLAGS etc since go projects do not use them.
+QA_FLAGS_IGNORED='.*'
+
+EGO_PN="github.com/mongodb/mongo-tools"
+S="${WORKDIR}/src/${EGO_PN}"
+
+src_unpack() {
+ mkdir -p "${S%/*}" || die
+ default
+ mv ${MY_P} "${S}" || die
+}
+
+src_prepare() {
+ default
+
+ # allow building with go 1.12 #678924
+ sed -i 's/_Ctype_struct_/C.struct_/' vendor/github.com/google/gopacket/pcap/pcap.go || die
+}
+
+src_compile() {
+ local myconf=()
+
+ if use sasl; then
+ myconf+=(sasl)
+ fi
+
+ if use ssl; then
+ myconf+=(ssl)
+ fi
+
+ # build pie to avoid text relocations wrt #582854
+ local buildmode="pie"
+
+ # skip on ppc64 wrt #610984
+ if use ppc64; then
+ buildmode="default"
+ fi
+
+ mkdir -p bin || die
+ for i in bsondump mongostat mongofiles mongoexport mongoimport mongorestore mongodump mongotop mongoreplay; do
+ echo "Building $i"
+ GOROOT="$(go env GOROOT)" GOPATH="${WORKDIR}" go build -buildmode="${buildmode}" -o "bin/$i" \
+ -ldflags "-X ${EGO_PN}/common/options.VersionStr=${PV}" --tags "${myconf[*]}" "$i/main/$i.go" || die
+ done
+}
+
+src_install() {
+ dobin bin/*
+}
diff --git a/app-admin/mongo-tools/mongo-tools-4.0.8.ebuild b/app-admin/mongo-tools/mongo-tools-4.0.8.ebuild
new file mode 100644
index 000000000000..092d770686fb
--- /dev/null
+++ b/app-admin/mongo-tools/mongo-tools-4.0.8.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PV=${PV/_rc/-rc}
+MY_P=${PN}-r${MY_PV}
+
+DESCRIPTION="A high-performance, open source, schema-free document-oriented database"
+HOMEPAGE="https://www.mongodb.com"
+SRC_URI="https://github.com/mongodb/mongo-tools/archive/r${MY_PV}.tar.gz -> mongo-tools-${MY_PV}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="sasl ssl"
+
+DEPEND="dev-lang/go:=
+ net-libs/libpcap
+ sasl? ( dev-libs/cyrus-sasl )
+ ssl? ( dev-libs/openssl:0= )"
+
+# Do not complain about CFLAGS etc since go projects do not use them.
+QA_FLAGS_IGNORED='.*'
+
+EGO_PN="github.com/mongodb/mongo-tools"
+S="${WORKDIR}/src/${EGO_PN}"
+
+src_unpack() {
+ mkdir -p "${S%/*}" || die
+ default
+ mv ${MY_P} "${S}" || die
+}
+
+src_prepare() {
+ default
+
+ # allow building with go 1.12 #678924
+ sed -i 's/_Ctype_struct_/C.struct_/' vendor/github.com/google/gopacket/pcap/pcap.go || die
+}
+
+src_compile() {
+ local myconf=()
+
+ if use sasl; then
+ myconf+=(sasl)
+ fi
+
+ if use ssl; then
+ myconf+=(ssl)
+ fi
+
+ # build pie to avoid text relocations wrt #582854
+ local buildmode="pie"
+
+ # skip on ppc64 wrt #610984
+ if use ppc64; then
+ buildmode="default"
+ fi
+
+ mkdir -p bin || die
+ for i in bsondump mongostat mongofiles mongoexport mongoimport mongorestore mongodump mongotop mongoreplay; do
+ echo "Building $i"
+ GOROOT="$(go env GOROOT)" GOPATH="${WORKDIR}" go build -buildmode="${buildmode}" -o "bin/$i" \
+ -ldflags "-X ${EGO_PN}/common/options.VersionStr=${PV}" --tags "${myconf[*]}" "$i/main/$i.go" || die
+ done
+}
+
+src_install() {
+ dobin bin/*
+}