summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-util/kdevelop-pg-qt/Manifest1
-rw-r--r--dev-util/kdevelop-pg-qt/files/kdevelop-pg-qt-2.2.0-qt-5.14.patch60
-rw-r--r--dev-util/kdevelop-pg-qt/kdevelop-pg-qt-2.2.0.ebuild26
3 files changed, 0 insertions, 87 deletions
diff --git a/dev-util/kdevelop-pg-qt/Manifest b/dev-util/kdevelop-pg-qt/Manifest
index 15735a527516..204afab54f44 100644
--- a/dev-util/kdevelop-pg-qt/Manifest
+++ b/dev-util/kdevelop-pg-qt/Manifest
@@ -1,2 +1 @@
-DIST kdevelop-pg-qt-2.2.0.tar.xz 660284 BLAKE2B 103572038bc3c3c43eecd3ff9411e2d28aeabf60bfc0bb91c6056d05901711f2dfe03ba098c658000b1a68998644efe34cede2857b3131e2a59f4accf8cecbf2 SHA512 a34bbdbf6e99d3b004c8a1d925fa5d45d9084b1542551f71de6a79c7ef851ca7057593f09c8824ae7961072c9f5e16199d7c4d7a037174f81163f669c96970f4
DIST kdevelop-pg-qt-2.2.1.tar.xz 660904 BLAKE2B b3874ee4f36d43f6d39a28a79f4638601340ce0545c2fe965393e9fe266a960e904ce5cd3215a7903f7b011f2e138d3be8999563366ce796f50524084a36192b SHA512 0ef3daba60ee6c7d4602b31610bdc68709a730d4c3443770eac1aa1d298fc03e10b38bc0d2e34dd44df5bba1c3af945c87e80d8aaa818e0b1787121f056c78a9
diff --git a/dev-util/kdevelop-pg-qt/files/kdevelop-pg-qt-2.2.0-qt-5.14.patch b/dev-util/kdevelop-pg-qt/files/kdevelop-pg-qt-2.2.0-qt-5.14.patch
deleted file mode 100644
index 5a4dec36d887..000000000000
--- a/dev-util/kdevelop-pg-qt/files/kdevelop-pg-qt-2.2.0-qt-5.14.patch
+++ /dev/null
@@ -1,60 +0,0 @@
-From d05d0b19e9d6f47fee3e11d837c2c21125589763 Mon Sep 17 00:00:00 2001
-From: Alexey Min <alexey.min@gmail.com>
-Date: Thu, 24 Oct 2019 14:34:45 +0300
-Subject: Fix build with Qt 5.14
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-Summary:
-Trying to build kdevelop-pg-qt with Qt 5.14 results in an error:
-```
-.../kdev-pg/kdev-pg-regexp.cpp:44:23: error: redefinition of ‘struct std::hash<QBitArray>’
- template<> struct hash< type > \
- ^~~~~~~~~~~~
-.../kdev-pg/kdev-pg-regexp.cpp:53:1: note: in expansion of macro ‘q_Hash_to_tr1_hash’
- q_Hash_to_tr1_hash(QBitArray)
- ^~~~~~~~~~~~~~~~~~
-In file included from .../prefix514/include/QtCore/qvector.h:47:0,
- from .../prefix514/include/QtCore/QVector:1,
- from .../kdevelop-pg-qt/include/kdev-pg-char-sets.h:36,
- from .../kdevelop-pg-qt/kdev-pg/kdev-pg-regexp.cpp:20:
-.../prefix514/include/QtCore/qhashfunctions.h:209:1: note: previous definition of ‘struct std::hash<QBitArray>’
- QT_SPECIALIZE_STD_HASH_TO_CALL_QHASH_BY_CREF(QBitArray)
- ^
-```
-
-std::hash<QBitArray> is already specialized in Qt 5.14, so avoid redefinition with conditional compilation
-
-Test Plan: try to build with Qt 5.14
-
-Reviewers: apol
-
-Reviewed By: apol
-
-Subscribers: kdevelop-devel
-
-Tags: #kdevelop
-
-Differential Revision: https://phabricator.kde.org/D24914
----
- kdev-pg/kdev-pg-regexp.cpp | 3 +++
- 1 file changed, 3 insertions(+)
-
-diff --git a/kdev-pg/kdev-pg-regexp.cpp b/kdev-pg/kdev-pg-regexp.cpp
-index 8cc0b95..9fee81c 100644
---- a/kdev-pg/kdev-pg-regexp.cpp
-+++ b/kdev-pg/kdev-pg-regexp.cpp
-@@ -50,7 +50,10 @@ namespace std \
- }; \
- }
-
-+#if (QT_VERSION < QT_VERSION_CHECK(5, 14, 0))
-+// Qt >= 5.14 already has std::hash for QBitArray
- q_Hash_to_tr1_hash(QBitArray)
-+#endif
-
- namespace KDevPG
- {
---
-cgit v1.1
diff --git a/dev-util/kdevelop-pg-qt/kdevelop-pg-qt-2.2.0.ebuild b/dev-util/kdevelop-pg-qt/kdevelop-pg-qt-2.2.0.ebuild
deleted file mode 100644
index 7aea0fc71f7d..000000000000
--- a/dev-util/kdevelop-pg-qt/kdevelop-pg-qt-2.2.0.ebuild
+++ /dev/null
@@ -1,26 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-ECM_TEST="true"
-inherit ecm kde.org
-
-if [[ ${KDE_BUILD_TYPE} = release ]]; then
- SRC_URI="mirror://kde/stable/${PN}/${PV}/src/${P}.tar.xz"
- KEYWORDS="amd64 x86"
-fi
-
-DESCRIPTION="LL(1) parser generator used mainly by KDevelop language plugins"
-HOMEPAGE="https://www.kdevelop.org/"
-
-LICENSE="LGPL-2+ LGPL-2.1+"
-SLOT="5"
-IUSE=""
-
-PATCHES=( "${FILESDIR}/${P}-qt-5.14.patch" )
-
-BDEPEND="
- sys-devel/bison
- sys-devel/flex
-"