summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-terms/gnome-terminal/Manifest1
-rw-r--r--x11-terms/gnome-terminal/gnome-terminal-3.23.90.ebuild73
2 files changed, 74 insertions, 0 deletions
diff --git a/x11-terms/gnome-terminal/Manifest b/x11-terms/gnome-terminal/Manifest
index ce9d6b74e955..4297e7216751 100644
--- a/x11-terms/gnome-terminal/Manifest
+++ b/x11-terms/gnome-terminal/Manifest
@@ -1,2 +1,3 @@
DIST gnome-terminal-3.20.3.tar.xz 1925308 SHA256 dac56c4d24c03125e24af7d0a484c1dff3cb16a4443fb1db11e7ae6418e0e2af SHA512 5316c5d4c4326a100469ac9eec372ecc61af1f33fe6047aba9077bc887d98e3a8db39bd64fde863c525ff72cdbcef97e74886cc8fbd38db2fd7e29af3a76c0ff WHIRLPOOL 1e3875a9cf5c3595762310728e51461dc178510c49655fc1134d4f903985aacc8aa83d7e7115e6092006e9e665235890984fa9cb2bdc3e0e8146f596903a7891
DIST gnome-terminal-3.22.1.tar.xz 1944832 SHA256 b00752336eb22d6d9f10c863c166ac73dcbb2ce4b280abdc0c78337e261bb0d4 SHA512 f6ebfa579de1e0f33d77dce75dfcd6ba47fbc0a508448eb16a15267988aa35acf3dd8bdfd55d32c00dcee9f79d4308b998c17500cf7c872ff928ce84e87a730a WHIRLPOOL 359adbdf464a57dcf8c19eab5e8aa0379a373fbbe8376e8e25c8fab9b4953645ebb9b54f40b8617f6542dd72c568c74dcb32a6facb39577df5647bc7c700e7bf
+DIST gnome-terminal-3.23.90.tar.xz 1924436 SHA256 3da921a4d21dd1bc61cb2501a66701b2440bb667f7ff8697a88632685594c29a SHA512 f91c416b24360913b50d234d7f680e6e3e37f25d178fc53ac057bbeafc7cb867cc30f5f303d09b60d9a18cc090dbea2afcc4d2d05bcc4484c29f26993f735e04 WHIRLPOOL 7c6f72be05cdb89883a6fc6092495a2778371cfd26636904e9e5f1b8b170bcbfd5bfa63c8f160b65b6e34556e4ff12b5af580a316350e491273a6f37f969103a
diff --git a/x11-terms/gnome-terminal/gnome-terminal-3.23.90.ebuild b/x11-terms/gnome-terminal/gnome-terminal-3.23.90.ebuild
new file mode 100644
index 000000000000..9991d0009b29
--- /dev/null
+++ b/x11-terms/gnome-terminal/gnome-terminal-3.23.90.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+GNOME2_LA_PUNT="yes"
+
+inherit autotools gnome2 readme.gentoo-r1
+
+DESCRIPTION="The Gnome Terminal"
+HOMEPAGE="https://wiki.gnome.org/Apps/Terminal/"
+
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE="debug +gnome-shell +nautilus vanilla"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux"
+
+# FIXME: automagic dependency on gtk+[X], just transitive but needs proper control
+RDEPEND="
+ >=dev-libs/glib-2.42:2[dbus]
+ >=x11-libs/gtk+-3.20:3[X]
+ >=x11-libs/vte-0.47.90:2.91
+ >=dev-libs/libpcre2-10
+ >=gnome-base/dconf-0.14
+ >=gnome-base/gsettings-desktop-schemas-0.1.0
+ sys-apps/util-linux
+ gnome-shell? ( gnome-base/gnome-shell )
+ nautilus? ( >=gnome-base/nautilus-3 )
+"
+# itstool required for help/* with non-en LINGUAS, see bug #549358
+# xmllint required for glib-compile-resources, see bug #549304
+DEPEND="${RDEPEND}
+ app-text/yelp-tools
+ dev-libs/libxml2
+ dev-util/gdbus-codegen
+ >=dev-util/intltool-0.50
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+DOC_CONTENTS="To get previous working directory inherited in new opened
+ tab you will need to add the following line to your ~/.bashrc:\n
+ . /etc/profile.d/vte.sh"
+
+src_prepare() {
+ if ! use vanilla; then
+ # OpenSuSE patches, https://bugzilla.gnome.org/show_bug.cgi?id=695371
+ # http://pkgs.fedoraproject.org/cgit/rpms/gnome-terminal.git/tree/gnome-terminal-transparency-notify.patch (first 3 parts)
+ eapply "${FILESDIR}"/${PN}-3.22.0-transparency.patch
+ eautoreconf
+ fi
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-static \
+ --disable-migration \
+ $(use_enable debug) \
+ $(use_enable gnome-shell search-provider) \
+ $(use_with nautilus nautilus-extension) \
+ VALAC=$(type -P true)
+}
+
+src_install() {
+ DOCS="AUTHORS ChangeLog HACKING NEWS"
+ gnome2_src_install
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ readme.gentoo_print_elog
+}