summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-libs/libiec61883/files/libiec61883-1.2.0-examples.patch28
-rw-r--r--media-libs/libiec61883/libiec61883-1.2.0-r2.ebuild33
2 files changed, 61 insertions, 0 deletions
diff --git a/media-libs/libiec61883/files/libiec61883-1.2.0-examples.patch b/media-libs/libiec61883/files/libiec61883-1.2.0-examples.patch
new file mode 100644
index 000000000000..9e19151d700f
--- /dev/null
+++ b/media-libs/libiec61883/files/libiec61883-1.2.0-examples.patch
@@ -0,0 +1,28 @@
+diff -Naurp a/examples/Makefile.am b/examples/Makefile.am
+--- a/examples/Makefile.am 2006-09-24 15:34:12.000000000 -0400
++++ b/examples/Makefile.am 2009-01-15 10:29:02.265594991 -0500
+@@ -1,6 +1,6 @@
+
+-noinst_PROGRAMS = test-amdtp test-dv test-mpeg2 test-plugs
+-bin_PROGRAMS = plugreport plugctl
++noinst_PROGRAMS =
++bin_PROGRAMS = plugreport plugctl test-amdtp test-dv test-mpeg2 test-plugs
+ man_MANS = plugreport.1 plugctl.1
+ EXTRA_DIST = plugreport.1 plugctl.1
+
+diff -Naurp a/examples/Makefile.in b/examples/Makefile.in
+--- a/examples/Makefile.in 2009-01-15 01:33:33.000000000 -0500
++++ b/examples/Makefile.in 2009-01-15 10:28:57.088402078 -0500
+@@ -32,9 +32,10 @@ PRE_UNINSTALL = :
+ POST_UNINSTALL = :
+ build_triplet = @build@
+ host_triplet = @host@
+-noinst_PROGRAMS = test-amdtp$(EXEEXT) test-dv$(EXEEXT) \
++noinst_PROGRAMS =
++bin_PROGRAMS = plugreport$(EXEEXT) plugctl$(EXEEXT) \
++ test-amdtp$(EXEEXT) test-dv$(EXEEXT) \
+ test-mpeg2$(EXEEXT) test-plugs$(EXEEXT)
+-bin_PROGRAMS = plugreport$(EXEEXT) plugctl$(EXEEXT)
+ subdir = examples
+ DIST_COMMON = $(srcdir)/Makefile.am $(srcdir)/Makefile.in
+ ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
diff --git a/media-libs/libiec61883/libiec61883-1.2.0-r2.ebuild b/media-libs/libiec61883/libiec61883-1.2.0-r2.ebuild
new file mode 100644
index 000000000000..a987fe211306
--- /dev/null
+++ b/media-libs/libiec61883/libiec61883-1.2.0-r2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit multilib-minimal
+
+DESCRIPTION="Library for capturing video (dv or mpeg2) over the IEEE 1394 bus"
+HOMEPAGE="https://ieee1394.wiki.kernel.org/index.php/Libraries#libiec61883"
+SRC_URI="https://www.kernel.org/pub/linux/libs/ieee1394/${P}.tar.xz"
+
+LICENSE="|| ( LGPL-2.1 GPL-2 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="examples"
+
+RDEPEND=">=sys-libs/libraw1394-2.1.0-r1[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_prepare() {
+ default
+ use examples && eapply "${FILESDIR}/${P}-examples.patch"
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE=${S} econf --disable-static
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ find "${ED}" -type f -name '*.la' -delete || die
+}