summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-themes/light-themes/Manifest1
-rw-r--r--x11-themes/light-themes/light-themes-17.04_p20170406.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/x11-themes/light-themes/Manifest b/x11-themes/light-themes/Manifest
index fbc8e3107e1c..5ddb9ec2256a 100644
--- a/x11-themes/light-themes/Manifest
+++ b/x11-themes/light-themes/Manifest
@@ -1,2 +1,3 @@
DIST Gentoo-Buttons-r1.tar.xz 80476 SHA256 8de84366411d8a67e3550cd131fa9634614212f0127f73336e11f7aba6cc8799 SHA512 d1c093fe8ce905a409cd3ce85fde8490f26b918bb1dd3ccb6695eaa6c7a4908d7ba1e1d14a9443a16331168ca9b3fa58b5b28805fc583b4345932602f7c19168 WHIRLPOOL e12ba8b37260115f395e4a48ab211c788dbb7f967a3be63a6f80dee7841fd1a62adbf2a6c2ec608ed3532b8be513c6750300f7b3b9ed9a82d049dfc8078acba9
DIST ubuntu-themes_16.10+17.04.20161205.orig.tar.gz 13834759 SHA256 ff9c002dd7668fdf65ddab392ed1eedc55c11cd7e2500d765a2d9b4607142799 SHA512 42bb622ad6818f7bf2e9f163f4a9a342fd7d8bad5e8a50db2d439857d053b0827543b7e8f626588316670fd6c63d050ecc522aef52e49c5c336ac08f6f303238 WHIRLPOOL 0dce7927bd66672b64e4db81db77534d648e84b08d65d324bfd44ee16176b789dfff074a33813475df33997b8372848345eb2e34574ffae510806b6cac0ffb43
+DIST ubuntu-themes_16.10+17.04.20170406.orig.tar.gz 13836108 SHA256 791a316b2e9c07f2891d24535067187d53bb2ab84c256f052e8606f8c6c0c517 SHA512 50d65dbe232237e1757b0d7a85ba7c2cafac18861211ca1b33a57de6a4961c325014851d1ee661adec57fac7472b7ae4f78439f30fa6f425eb751e94940d9f91 WHIRLPOOL 3aab2730be1035fcf0353f45658165f20c1e29a5dece23b56f2d5b81b624f03ada2b032340fdefa052126f1b0466fac5087b22e50c75601c10c2da7988d06a95
diff --git a/x11-themes/light-themes/light-themes-17.04_p20170406.ebuild b/x11-themes/light-themes/light-themes-17.04_p20170406.ebuild
new file mode 100644
index 000000000000..e417e9899b5d
--- /dev/null
+++ b/x11-themes/light-themes/light-themes-17.04_p20170406.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit eutils
+
+MY_PN=ubuntu-themes
+MY_PV=16.10+${PV/_p/.}
+
+DESCRIPTION="GTK2/GTK3 Ambiance and Radiance themes from Ubuntu"
+HOMEPAGE="http://packages.ubuntu.com/zesty/light-themes"
+SRC_URI="
+ mirror://ubuntu/pool/main/${MY_PN:0:1}/${MY_PN}/${MY_PN}_${MY_PV}.orig.tar.gz
+ https://dev.gentoo.org/~pacho/${PN}/Gentoo-Buttons-r1.tar.xz
+"
+
+LICENSE="CC-BY-SA-3.0 CC-BY-SA-4.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gtk3"
+
+DEPEND="app-arch/xz-utils"
+RDEPEND="
+ x11-themes/gtk-engines-murrine
+ gtk3? ( x11-themes/gtk-engines-unico )
+"
+
+S="${WORKDIR}"
+
+src_prepare() {
+ cp -RL Ambiance/ Ambiance-Gentoo || die
+ cp -RL Radiance/ Radiance-Gentoo || die
+ sed -i -e 's/Ambiance/Ambiance-Gentoo/g' Ambiance-Gentoo/index.theme \
+ Ambiance-Gentoo/metacity-1/metacity-theme-1.xml || die
+ sed -i -e 's/Radiance/Radiance-Gentoo/g' Radiance-Gentoo/index.theme \
+ Radiance-Gentoo/metacity-1/metacity-theme-1.xml || die
+ sed -i -e 's/nselected_bg_color:#f07746/nselected_bg_color:#755fbb/g' \
+ Ambiance-Gentoo/gtk-2.0/gtkrc Ambiance-Gentoo/gtk-3.*/settings.ini \
+ Radiance-Gentoo/gtk-2.0/gtkrc Radiance-Gentoo/gtk-3.*/settings.ini || die
+ sed -i -e 's/selected_bg_color #f07746/selected_bg_color #755fbb/g' \
+ Ambiance-Gentoo/gtk-3.*/gtk-main.css \
+ Radiance-Gentoo/gtk-3.*/gtk-main.css || die
+
+ cp -f "${WORKDIR}"/Gentoo-Buttons/*.png "${S}"/Ambiance-Gentoo/metacity-1/. || die
+ cp -f "${WORKDIR}"/Gentoo-Buttons/*.png "${S}"/Radiance-Gentoo/metacity-1/. || die
+ cp -f "${WORKDIR}"/Gentoo-Buttons/assets/*.png "${S}"/Ambiance-Gentoo/gtk-3.0/assets/. || die
+ cp -f "${WORKDIR}"/Gentoo-Buttons/assets/*.png "${S}"/Ambiance-Gentoo/gtk-3.20/assets/. || die
+ cp -f "${WORKDIR}"/Gentoo-Buttons/assets/*.png "${S}"/Radiance-Gentoo/gtk-3.0/assets/. || die
+ cp -f "${WORKDIR}"/Gentoo-Buttons/assets/*.png "${S}"/Radiance-Gentoo/gtk-3.20/assets/. || die
+}
+
+src_compile() {
+ :
+}
+
+src_install() {
+ insinto /usr/share/themes
+ doins -r Radiance* Ambiance*
+
+ use gtk3 || {
+ rm -R "${D}"/usr/share/themes/*/gtk-3.0 || die
+ }
+}