summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games-puzzle/tanglet/Manifest1
-rw-r--r--games-puzzle/tanglet/tanglet-1.5.3.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/games-puzzle/tanglet/Manifest b/games-puzzle/tanglet/Manifest
index 2165e2c33a87..b889f9b3d626 100644
--- a/games-puzzle/tanglet/Manifest
+++ b/games-puzzle/tanglet/Manifest
@@ -1 +1,2 @@
DIST tanglet-1.5.2-src.tar.bz2 8646616 BLAKE2B 0a38690069550e27a302f28e7db3753eaf67af7add730d8069ec4df001a431843e204603475146d56049cdf40c0be20d8ef83ea9f47b27cf82cc232e4fecef35 SHA512 a97b9fe3c9c80a843c4696766d15edcab48369bd905e893c2975bfb9faf91d4a58a3c440d242be91f5838aacdf1526022b5ce8c463adfd8b0bb62e008be460ee
+DIST tanglet-1.5.3-src.tar.bz2 8631208 BLAKE2B b7b0b913a1d862f43d4fb215a09aaba379bda95d75d3d2f59b207361efeda6573055f25db9d07d330fe0957ca774679589f87b79d0766ac669709da37d164f5f SHA512 31b7aada8b244969c2581a0879c30ca1a9b9db8e0cff5c802607dd08038af9487ba59db0e64fabb35feade9d5d700a2a1e04a0052d0ff4639c10a42189671267
diff --git a/games-puzzle/tanglet/tanglet-1.5.3.ebuild b/games-puzzle/tanglet/tanglet-1.5.3.ebuild
new file mode 100644
index 000000000000..0987abb49061
--- /dev/null
+++ b/games-puzzle/tanglet/tanglet-1.5.3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit qmake-utils xdg
+
+DESCRIPTION="Single player word finding game based on Boggle"
+HOMEPAGE="https://gottcode.org/tanglet/"
+SRC_URI="https://gottcode.org/${PN}/${P}-src.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+BDEPEND="
+ dev-qt/linguist-tools:5
+"
+DEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ sys-libs/zlib
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}"/${PN}-1.5.2-gentoo.patch )
+
+src_configure() {
+ eqmake5 tanglet.pro
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install
+ einstalldocs
+}