summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-vim/gentoo-syntax/Manifest1
-rw-r--r--app-vim/gentoo-syntax/gentoo-syntax-20181023.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/app-vim/gentoo-syntax/Manifest b/app-vim/gentoo-syntax/Manifest
index cf23411f58ff..c4cd26a26446 100644
--- a/app-vim/gentoo-syntax/Manifest
+++ b/app-vim/gentoo-syntax/Manifest
@@ -1 +1,2 @@
DIST gentoo-syntax-20180821.tar.bz2 18361 BLAKE2B 4134fd0a3d75d86f3984f135021063b68588083f191efcb94d7b599460703d6eb501bad7de2aa0cc9cdc4447d73b83e4b36cee2acdd113e7d0a879e1e864e2fb SHA512 09c70ded667b489e03f02e0e72fca32f13a40501a5e319b387967e75f616c7f3dc44ceab3a46b776a509263f58668223eb85d51ba58ca3fbc48e4c05d7345dfc
+DIST gentoo-syntax-20181023.tar.bz2 18299 BLAKE2B ea037425ab00b05e4a52f943817fb264492793c842b6c9250450ab715fafebc55d0b5b95ff49945f62258f2dc70f357eeef3a5d908592c995cdc6e940f2f15af SHA512 a6bd592dd46ad80a4126321826dbbc4c130624027e7e71f0ea87fb164963e980e3ab3e1db1e87ee0ddad602f2ea2e9e7d955a0016c00eb8aef4c01c29057b737
diff --git a/app-vim/gentoo-syntax/gentoo-syntax-20181023.ebuild b/app-vim/gentoo-syntax/gentoo-syntax-20181023.ebuild
new file mode 100644
index 000000000000..c40de243f4b0
--- /dev/null
+++ b/app-vim/gentoo-syntax/gentoo-syntax-20181023.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: Gentoo and Portage syntax highlighting"
+HOMEPAGE="https://github.com/gentoo/gentoo-syntax"
+SRC_URI="https://gitweb.gentoo.org/proj/gentoo-syntax.git/snapshot/${P}.tar.bz2"
+
+LICENSE="vim"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="ignore-glep31"
+
+VIM_PLUGIN_HELPFILES="gentoo-syntax"
+VIM_PLUGIN_MESSAGES="filetype"
+
+src_prepare() {
+ default
+ if use ignore-glep31 ; then
+ for f in ftplugin/*.vim ; do
+ ebegin "Removing UTF-8 rules from ${f} ..."
+ sed -i -e 's~\(setlocal fileencoding=utf-8\)~" \1~' ${f} \
+ || die "waah! bad sed voodoo. need more goats."
+ eend $?
+ done
+ fi
+}
+
+pkg_postinst() {
+ vim-plugin_pkg_postinst
+
+ if [[ -z ${REPLACING_VERSIONS} ]] ; then
+ if use ignore-glep31 1>/dev/null ; then
+ ewarn "You have chosen to disable the rules which ensure GLEP 31"
+ ewarn "compliance. When editing ebuilds, please make sure you get"
+ ewarn "the character set correct."
+ fi
+ fi
+}