summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-kernel/git-sources/Manifest1
-rw-r--r--sys-kernel/git-sources/git-sources-5.16_rc4.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/sys-kernel/git-sources/Manifest b/sys-kernel/git-sources/Manifest
index e90476a38998..55caaede34f3 100644
--- a/sys-kernel/git-sources/Manifest
+++ b/sys-kernel/git-sources/Manifest
@@ -2,3 +2,4 @@ DIST linux-5.15.tar.xz 121913744 BLAKE2B 3921274b23f7938abdf3ed9334534b4581e13d7
DIST patch-5.16-rc1.patch 45256839 BLAKE2B 180b4fa9bbfad0dce858f7eadbe52960ec86ccbc7e66be3a691824310a0bb1e7f1dc3be1046edeaae7247c80e3a4d963b25db9646a116f8739870e1cacb78411 SHA512 e29dc9ade8101545feb0cda64453acf973cf8c0fd92bfc7eded2d5bc6b9a12ef91e84f79c51edec908e1918e9a9a8e607dc45988f4c618512d9f51110505e8c2
DIST patch-5.16-rc2.patch 45612301 BLAKE2B 26c0d5d0b7cbd277f2c09baf2064fa59ed01089c9853d93baae857d9e603e7b492133c5ab650f96e3ba3e9dfd472255883ebce0f50c9b5fa9571383444dcbfa5 SHA512 678d60793b73f7c5e52955680f695a25995c2fef5872853ceae4a5db99e9f28fcc9a93d595b46f0a076c512b56a643e5a15afef88db956cca3ff954a3377b198
DIST patch-5.16-rc3.patch 46087888 BLAKE2B 9e2234998503e1067afd0e9a3acf66a25459f4dd3913acab3044c8d569b5433c883e5c7774a6d388c66466962946bdc2b35d8e5239d58af98d3d3dd4ba1816d5 SHA512 437876372d93a5326dc32709867ffcad3e6f0fd2922b2e5f16889232a683fb7ef1ce9c08b71feff973d94372bb810621d9d9387c6dcb8ab7923c56e750ca9588
+DIST patch-5.16-rc4.patch 46394228 BLAKE2B 3842d5a428d9623f6c49e785b1d9b9bf9b2b4aad98072b30162af8a361d48a70eb0933462a88e505bac2cdc757aa3bf5138153cdf04c49b15a8b79caa4c28f9c SHA512 72270aa4b4fd7cf290898a8760166022a2cf41566b0b1e7bea285f44b9febb16a02244503f1c585f6ddc9818d7fada7a0a15c1bd00403b2a0c1108b4e7b16264
diff --git a/sys-kernel/git-sources/git-sources-5.16_rc4.ebuild b/sys-kernel/git-sources/git-sources-5.16_rc4.ebuild
new file mode 100644
index 000000000000..806a3e87800e
--- /dev/null
+++ b/sys-kernel/git-sources/git-sources-5.16_rc4.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+UNIPATCH_STRICTORDER="yes"
+K_NOUSENAME="yes"
+K_NOSETEXTRAVERSION="yes"
+K_NOUSEPR="yes"
+K_SECURITY_UNSUPPORTED="1"
+K_BASE_VER="5.15"
+K_EXP_GENPATCHES_NOUSE="1"
+K_FROM_GIT="yes"
+ETYPE="sources"
+CKV="${PVR/-r/-git}"
+
+# only use this if it's not an _rc/_pre release
+[ "${PV/_pre}" == "${PV}" ] && [ "${PV/_rc}" == "${PV}" ] && OKV="${PV}"
+inherit kernel-2
+detect_version
+
+DESCRIPTION="The very latest -git version of the Linux kernel"
+HOMEPAGE="https://www.kernel.org"
+SRC_URI="${KERNEL_URI}"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE=""
+
+K_EXTRAEINFO="This kernel is not supported by Gentoo due to its unstable and
+experimental nature. If you have any issues, try a matching vanilla-sources
+ebuild -- if the problem is not there, please contact the upstream kernel
+developers at https://bugzilla.kernel.org and on the linux-kernel mailing list to
+report the problem so it can be fixed in time for the next kernel release."
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ >=sys-devel/patch-2.7.6-r4"
+
+pkg_postinst() {
+ postinst_sources
+}