summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--kde-plasma/plasma-integration/Manifest1
-rw-r--r--kde-plasma/plasma-integration/plasma-integration-5.19.4.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/kde-plasma/plasma-integration/Manifest b/kde-plasma/plasma-integration/Manifest
index b97f7ad61627..739bf14f6b2d 100644
--- a/kde-plasma/plasma-integration/Manifest
+++ b/kde-plasma/plasma-integration/Manifest
@@ -1,2 +1,3 @@
DIST plasma-integration-5.18.5.tar.xz 57656 BLAKE2B 3cf445f5d84de07e82369a3057a0ac390961634f8926d3491ca8dd0d603d4e4ff9e7487b69c1fbea44a4296c8960f4e3ef677e1bfd183154a36799fc95dbf3c8 SHA512 d217c49555ee17e3b18d006368ec7aa4d8585c05070bcf3a3c7e471b1c7dc830080d0405209979d8a27c7c2fc2adcd3d248e595f43f0b4a2928683f93c6d4b48
DIST plasma-integration-5.19.3.tar.xz 57428 BLAKE2B d1156aba684f29d18466b58ab254c722ce1f49affb9567ee87ee314df2ae0de7906fc4d46246dc737dcea66234056dd2fcc851bfd61ecae25252a354ad6adf0d SHA512 1d12edc834a70b31d0d1caa34974c57b01ad3a9db65b0be801a56ca7f7d04c9f6fd9e18574284c8c95a281895b9bc004be4fff40cc542c009d8bc2041d5bdf51
+DIST plasma-integration-5.19.4.tar.xz 57444 BLAKE2B 1d660ea359e0bfaa75a56fd9e0a70fe752006c7582b1e1ab90732c717c6402bf9134da13e45924fc1fbdf3ccd0a909251e33ea699abf2dd434858d146a29a55c SHA512 f5a85cd55fe0a8595f745e4ea5a8d28f89afd469d81e09d55dad354e5b6a6652e2b024be620e1328a2951bd5ca78a043bb7cb42163159b33a8902f3cb976f979
diff --git a/kde-plasma/plasma-integration/plasma-integration-5.19.4.ebuild b/kde-plasma/plasma-integration/plasma-integration-5.19.4.ebuild
new file mode 100644
index 000000000000..fbf43a6fc30e
--- /dev/null
+++ b/kde-plasma/plasma-integration/plasma-integration-5.19.4.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KFMIN=5.71.0
+PVCUT=$(ver_cut 1-3)
+QTMIN=5.14.2
+VIRTUALX_REQUIRED="test"
+inherit ecm kde.org
+
+DESCRIPTION="Qt Platform Theme integration plugins for the Plasma workspaces"
+
+LICENSE="LGPL-2+"
+SLOT="5"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE=""
+
+DEPEND="
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5=[dbus]
+ >=dev-qt/qtquickcontrols2-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=dev-qt/qtx11extras-${QTMIN}:5
+ >=kde-frameworks/kcompletion-${KFMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kconfigwidgets-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kiconthemes-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ >=kde-frameworks/kjobwidgets-${KFMIN}:5
+ >=kde-frameworks/knotifications-${KFMIN}:5
+ >=kde-frameworks/kwayland-${KFMIN}:5
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
+ >=kde-frameworks/kwindowsystem-${KFMIN}:5
+ >=kde-frameworks/kxmlgui-${KFMIN}:5
+ >=kde-plasma/breeze-${PVCUT}:5
+ x11-libs/libXcursor
+ x11-libs/libxcb
+"
+RDEPEND="${DEPEND}
+ media-fonts/hack
+ media-fonts/noto
+"
+
+# requires running kde environment
+RESTRICT+=" test"