summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/flask-sqlalchemy/flask-sqlalchemy-2.5.1.ebuild5
-rw-r--r--dev-python/humanize/Manifest1
-rw-r--r--dev-python/humanize/humanize-3.11.0.ebuild24
-rw-r--r--dev-python/ipython/Manifest1
-rw-r--r--dev-python/ipython/ipython-7.26.0.ebuild148
-rw-r--r--profiles/package.mask4
-rw-r--r--x11-misc/qt5ct/Manifest1
-rw-r--r--x11-misc/qt5ct/qt5ct-1.3.ebuild49
8 files changed, 229 insertions, 4 deletions
diff --git a/dev-python/flask-sqlalchemy/flask-sqlalchemy-2.5.1.ebuild b/dev-python/flask-sqlalchemy/flask-sqlalchemy-2.5.1.ebuild
index cf700a286175..913b8ec45c3f 100644
--- a/dev-python/flask-sqlalchemy/flask-sqlalchemy-2.5.1.ebuild
+++ b/dev-python/flask-sqlalchemy/flask-sqlalchemy-2.5.1.ebuild
@@ -1,10 +1,9 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
-
-PYTHON_COMPAT=( pypy3 python3_{7..9} )
+EAPI=8
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
inherit distutils-r1
MY_PN="Flask-SQLAlchemy"
diff --git a/dev-python/humanize/Manifest b/dev-python/humanize/Manifest
index 4d4a890111f6..da21d1659948 100644
--- a/dev-python/humanize/Manifest
+++ b/dev-python/humanize/Manifest
@@ -1,2 +1,3 @@
DIST humanize-3.10.0.tar.gz 65658 BLAKE2B c60aff8f5e2044c10e997f3546b30e8ac7c040ee57aea5342ccce7ea6341a8695c1b94bdc8cb2acc18c3f421667fd4090b7b110b47aa229cd10d5ac8b42d6dae SHA512 f31929ddc1055fb54294b67e25e3b41883ef4e8ff9b76082cdd4703d64a066d0a368d116a60e26465f07dd3a0df8c87bb459ff1b03153d8843d3eefb06ff6961
+DIST humanize-3.11.0.tar.gz 67034 BLAKE2B 9e10582139578e8e041d1ce60c9c5d7e071c4c093a64cf620df6ff38f0567e8b2f3134f10722cb724d13343373db0fa2a1ae5bd68700ff85fb58ee318feb0fd0 SHA512 7aa3c513c6702de0e099865f787858de4c9c65cfe95af61fd0204ff6df64e7359474b4067b4672546936beae6c8c512dd9c75f555d7075c94819e81143c21ce9
DIST humanize-3.9.0.tar.gz 64229 BLAKE2B 09aeec6a92c8e2e104032d4c61f054785ff58ce2dda68c4f3acffb17c7fa4e262b28a24b7c06d33671ea18d2eb05c9bcc0a82d5491e60afa161ebc0041945bf2 SHA512 75aa8f9f6b07d4b65e5589c3f337a92ee17769ab8da6608147b0f1ec3965b95788dd90cf0d0cae1b7c9be689b44910029ee72e2eba39a60c9926b67726c74353
diff --git a/dev-python/humanize/humanize-3.11.0.ebuild b/dev-python/humanize/humanize-3.11.0.ebuild
new file mode 100644
index 000000000000..ce3c080a882b
--- /dev/null
+++ b/dev-python/humanize/humanize-3.11.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Common humanization utilities"
+HOMEPAGE="https://github.com/jmoiron/humanize/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? ( dev-python/freezegun[${PYTHON_USEDEP}] )
+"
+
+distutils_enable_tests --install pytest
diff --git a/dev-python/ipython/Manifest b/dev-python/ipython/Manifest
index 96c70171a65b..2a45f4009beb 100644
--- a/dev-python/ipython/Manifest
+++ b/dev-python/ipython/Manifest
@@ -1,2 +1,3 @@
DIST ipython-7.24.1.tar.gz 5146561 BLAKE2B ae63d024f488f44dbd61eb9f3e14ac5b8ad801b1db195632c184c6106d4c2e6d6143c1524ae6fc5a2f6f631683b73f241c9115c439c0f97a4fe540cc232fb181 SHA512 0ea8843a1f2e7f9357ff9896f2b6da058adb5fcbbad5c3b1fc4138a085eb57034c62c0b50d82dea0e563523649ec112edd4ef0c267a914f6a7d33b44be30b977
DIST ipython-7.25.0.tar.gz 5147224 BLAKE2B 0a2ae7cd315ba1abde18cdfcb7ed5227e5fc43b9a053f82e7db0146cbec66b0c2a1585158e60c37559523b457ab339ad42ab8fb3fccfc9e5ea7b880593de2e73 SHA512 726d3577bfb05d0c01c55d7111f8ee03fa879427de0750ee25b0a6451365728b5fb8ccf79c42585268f768680b13f628956d292f27b9e622e5dee0b4d368d22b
+DIST ipython-7.26.0.tar.gz 5147847 BLAKE2B c0cb45550387e47bba6ea67656bbb4561a2250bf9c39b4560b26a8a9e380061f79c5fa663f90df166af1fa49811cb59953fb367b2fea5f07d44ba3f9dae3de44 SHA512 142ff8ebddd61640e6ebff01d16b1310b6370643aa8cf4c7fd076872ad342949a1778c5ad74eccbafdc6b4d31a1849e096d75a28eafc555d629948db523b4776
diff --git a/dev-python/ipython/ipython-7.26.0.ebuild b/dev-python/ipython/ipython-7.26.0.ebuild
new file mode 100644
index 000000000000..870fbdee1654
--- /dev/null
+++ b/dev-python/ipython/ipython-7.26.0.ebuild
@@ -0,0 +1,148 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=no
+PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE='readline,sqlite,threads(+)'
+
+inherit distutils-r1 optfeature virtualx
+
+DESCRIPTION="Advanced interactive shell for Python"
+HOMEPAGE="https://ipython.org/ https://github.com/ipython/ipython/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="doc examples matplotlib notebook nbconvert qt5 +smp test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/backcall[${PYTHON_USEDEP}]
+ dev-python/decorator[${PYTHON_USEDEP}]
+ >=dev-python/jedi-0.16[${PYTHON_USEDEP}]
+ >=dev-python/pexpect-4.3[${PYTHON_USEDEP}]
+ dev-python/pickleshare[${PYTHON_USEDEP}]
+ >=dev-python/prompt_toolkit-2[${PYTHON_USEDEP}]
+ <dev-python/prompt_toolkit-3.1[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/traitlets[${PYTHON_USEDEP}]
+ matplotlib? (
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/matplotlib-inline[${PYTHON_USEDEP}]
+ )
+"
+
+BDEPEND="
+ test? (
+ app-text/dvipng[truetype]
+ >=dev-python/ipykernel-5.1.0[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/matplotlib-inline[${PYTHON_USEDEP}]
+ dev-python/nbformat[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.17[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/testpath[${PYTHON_USEDEP}]
+ )
+ doc? (
+ >=dev-python/ipykernel-5.1.0[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-2[${PYTHON_USEDEP}]
+ dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+RDEPEND+="
+ nbconvert? (
+ dev-python/nbconvert[${PYTHON_USEDEP}]
+ )"
+PDEPEND="
+ notebook? (
+ dev-python/notebook[${PYTHON_USEDEP}]
+ dev-python/ipywidgets[${PYTHON_USEDEP}]
+ dev-python/widgetsnbextension[${PYTHON_USEDEP}]
+ )
+ qt5? ( dev-python/qtconsole[${PYTHON_USEDEP}] )
+ smp? (
+ >=dev-python/ipykernel-5.1.0[${PYTHON_USEDEP}]
+ >=dev-python/ipyparallel-6.2.3[${PYTHON_USEDEP}]
+ )"
+
+PATCHES=( "${FILESDIR}"/2.1.0-substitute-files.patch )
+
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_prepare_all() {
+ # Remove out of date insource files
+ rm IPython/extensions/cythonmagic.py || die
+ rm IPython/extensions/rmagic.py || die
+
+ # Prevent un-needed download during build
+ if use doc; then
+ sed -e "/^ 'sphinx.ext.intersphinx',/d" -i docs/source/conf.py || die
+ fi
+
+ # Rename the test directory to reduce sys.path pollution
+ # https://github.com/ipython/ipython/issues/12892
+ mv IPython/extensions/{,ipython_}tests || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ if use doc; then
+ emake -C docs html_noapi
+ HTML_DOCS=( docs/build/html/. )
+ fi
+}
+
+python_test() {
+ local deselect=()
+ [[ ${EPYTHON} == python3.10 ]] && deselect+=(
+ # fails due to changed argparse output
+ IPython/core/tests/test_magic_arguments.py::test_magic_arguments
+ # py3.10 API incompat, doesn't look important
+ IPython/lib/tests/test_pretty.py::test_pprint_heap_allocated_type
+ )
+ virtx epytest ${deselect[@]/#/--deselect }
+}
+
+python_install() {
+ distutils-r1_python_install
+
+ # Create ipythonX.Y symlinks.
+ # TODO:
+ # 1. do we want them for pypy? No. pypy has no numpy
+ # 2. handle it in the eclass instead (use _python_ln_rel).
+ # With pypy not an option the dosym becomes unconditional
+ dosym ../lib/python-exec/${EPYTHON}/ipython \
+ /usr/bin/ipython${EPYTHON#python}
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}
+
+pkg_postinst() {
+ optfeature "sympyprinting" dev-python/sympy
+ optfeature "cythonmagic" dev-python/cython
+ optfeature "%lprun magic command" dev-python/line_profiler
+ optfeature "%mprun magic command" dev-python/memory_profiler
+
+ if use nbconvert; then
+ if ! has_version app-text/pandoc ; then
+ einfo "Node.js will be used to convert notebooks to other formats"
+ einfo "like HTML. Support for that is still experimental. If you"
+ einfo "encounter any problems, please use app-text/pandoc instead."
+ fi
+ fi
+}
diff --git a/profiles/package.mask b/profiles/package.mask
index c71afacec30b..58eb7e3086af 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -34,8 +34,10 @@
# Sam James <sam@gentoo.org> (2021-08-01)
# Broken with GCC 11, out of date, unmaintained in Gentoo.
-# bug #763651, bug #774009, bug #789027.
+# bug #763651, bug #774009, bug #789027, bug #759988.
+# Removal on 2021-09-01.
dev-util/intel-graphics-compiler
+dev-libs/intel-neo
# Sam James <sam@gentoo.org> (2021-08-01)
# Fails to compile, multiple open bugs.
diff --git a/x11-misc/qt5ct/Manifest b/x11-misc/qt5ct/Manifest
index 8e33534161dc..d048b1957899 100644
--- a/x11-misc/qt5ct/Manifest
+++ b/x11-misc/qt5ct/Manifest
@@ -1 +1,2 @@
DIST qt5ct-1.2.tar.bz2 76052 BLAKE2B bff9dcd6176f856f262f908101f51be5bc5fa56cbf221fb6e1b66cf49867d721f4c1d5707bcd71cb20b1d27d53f5352bcaaa32ed7298f9fe349ac8a90b4a4e23 SHA512 044582440fc3ed8424970a30d7e1562396f9a1651f2c50adbdcb6ec73b35fb8dd23de419df29b92d21a45fea9af4e562b1294f5bfc329419f831775954f8ed6f
+DIST qt5ct-1.3.tar.bz2 80506 BLAKE2B eda2d69fcddf80553358d3c9e9bd0ef33355919c5b62912d8e79a84a36ee5a25d1dab553b6413d78e16ce69435861a01b298ae97202a77f1f50ed805f14445dd SHA512 9f4397d5cfc3dec14330759f213ae99b02ae36d3ea48dfdb3015c3b7d3fe12cde619af855d7320566ca32120e8689e4b39f78e4fdf9886e2472aef570beb75bd
diff --git a/x11-misc/qt5ct/qt5ct-1.3.ebuild b/x11-misc/qt5ct/qt5ct-1.3.ebuild
new file mode 100644
index 000000000000..7a085789c1b3
--- /dev/null
+++ b/x11-misc/qt5ct/qt5ct-1.3.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="Qt5 configuration tool, similar to qtconfig for Qt4"
+HOMEPAGE="https://sourceforge.net/projects/qt5ct/"
+SRC_URI="https://download.sourceforge.net/qt5ct/${P}.tar.bz2"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="+dbus"
+
+RDEPEND="
+ dev-qt/qtconcurrent:5
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5=
+ dev-qt/qtwidgets:5
+ dbus? (
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5[dbus]
+ )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-qt/linguist-tools:5
+ dev-qt/qtpaths:5
+"
+
+src_install() {
+ cmake_src_install
+
+ newenvd - 98qt5ct <<< 'QT_QPA_PLATFORMTHEME=qt5ct'
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ ewarn "qt5ct configuration won't be applied to the currently running sessions."
+ ewarn "Please relogin."
+ fi
+ if ! has_version 'dev-qt/qtsvg:5'; then
+ elog
+ elog "For SVG icon themes, please install 'dev-qt/qtsvg:5'."
+ elog
+ fi
+}