summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-nds/gosa-core/Manifest2
-rw-r--r--net-nds/gosa-core/gosa-core-2.6.10.ebuild106
-rw-r--r--net-nds/gosa-core/gosa-core-2.6.11.ebuild108
3 files changed, 0 insertions, 216 deletions
diff --git a/net-nds/gosa-core/Manifest b/net-nds/gosa-core/Manifest
index 8385c7c77162..fe32f4474397 100644
--- a/net-nds/gosa-core/Manifest
+++ b/net-nds/gosa-core/Manifest
@@ -1,3 +1 @@
-DIST gosa-core-2.6.10.tar.bz2 2651987 SHA256 f372b753a675745b8d177f4cd497b625fd36a49deb84b053d51fe1c133933e5d SHA512 616d9c40cf02ea7da9124ed791c7fd635ec85d149b88c13c3e4587e7d48850d0ab08bcc0b48dc03e502842c4116136d870e8469fe17fd6aba34465a0da498649 WHIRLPOOL 6bc960ceb95ce717dc0128c32e5465326df4443c1cb366007dc8249e676204855677fa37a80d8a3e91e7dcea9c2d1c99f70d494ed979bfe777ebe85bcb2675c6
-DIST gosa-core-2.6.11.tar.bz2 2711910 SHA256 79e484da20524ec17b8da12a146f35e6c5784e7e9f75962c89657680d00ebc30 SHA512 6aaa1896ceb2b860925b3c4aa71f500055b22ef0266f3ff0ce256b03be04c3999c96c6bbe06674694f1713c345015b3325ff570231cc8992f9d459bdd0c500c1 WHIRLPOOL 82e31c44230f525de55a806af7de4a068f072db553571a4137d9fcb47089b85436a612440e7cf9a1e9e36985f10d4d2331c53d1dd66c6f88b7a2cc61c122064b
DIST gosa-core-2.6.12.tar.bz2 2541062 SHA256 dd6cf2bdb32196e6ad68efa4d2400bf6a95b4a7fddf7c11888c60ea8888b8dc0 SHA512 541a7ec780e41cfe025303cb627281e857227aa64cdb831732f527a6221d107cd77f3e55bec7641911fff03836bb9d49ceac45bcacd662020b19497b6aa2ab3d WHIRLPOOL fbaf112d0da47bce1a8fc62d8863e719ece80e8a10e0e1ead3fcce6ac2c8b4c3a0e0fb7b91fd7486e48ee49bad9ba42bd493cd5460a99b520631549239b29476
diff --git a/net-nds/gosa-core/gosa-core-2.6.10.ebuild b/net-nds/gosa-core/gosa-core-2.6.10.ebuild
deleted file mode 100644
index e8c8de9005b7..000000000000
--- a/net-nds/gosa-core/gosa-core-2.6.10.ebuild
+++ /dev/null
@@ -1,106 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=3
-
-inherit eutils
-
-DESCRIPTION="LDAP administration frontend for user administration"
-HOMEPAGE="https://oss.gonicus.de/labs/gosa/wiki/WikiStart."
-SRC_URI="ftp://oss.gonicus.de/pub/gosa/${P}.tar.bz2
- http://oss.gonicus.de/pub/gosa/${P}.tar.bz2
- ftp://oss.gonicus.de/pub/gosa/archive/${P}.tar.bz2
- http://oss.gonicus.de/pub/gosa/archive/${P}.tar.bz2 "
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE=""
-
-DEPEND="dev-lang/php[iconv,imap,ldap,mysql,session,zip]
- sys-devel/gettext"
-RDEPEND="${DEPEND}
- virtual/httpd-php
- dev-perl/Crypt-SmbHash
- media-gfx/imagemagick"
-
-src_prepare() {
- epatch \
- "${S}/redhat/02_fix_class_mapping.patch" \
- "${S}/redhat/03_fix_locale_location.patch" \
- "${S}/redhat/04_fix_online_help_location.patch"
- sed -i \
- -e 's|../contrib|/usr/share/gosa/template|' \
- include/functions.inc || die "sed failed"
-}
-
-src_install() {
- insinto /usr/share/gosa
- doins -r doc html ihtml include locale plugins setup
-
- insinto /usr/share/gosa/template
- doins contrib/gosa.conf
-
- dosbin \
- update-gosa \
- bin/gosa-encrypt-passwords
-
- dobin \
- update-locale \
- update-online-help \
- update-pdf-help \
- dh-make-gosa \
- contrib/gosa
-
- insinto /etc/gosa
- doins \
- contrib/shells \
- contrib/encodings \
- contrib/desktoprc
- touch "${D}/etc/gosa/gosa.secrets"
-
- doicon debian/*.xpm
- domenu debian/gosa-desktop.desktop
-
- doman *.1 contrib/*.1 contrib/*.5
-
- dodoc contrib/openldap/slapd.conf
- insinto /etc/openldap/schema/gosa
- doins contrib/openldap/*.schema
-
- insinto /etc/apache2/vhosts.d
- doins "${FILESDIR}/gosa.include"
-
- dodoc AUTHORS Changelog FAQ README README.safemode
-
- keepdir /etc/gosa
- keepdir /var/spool/gosa
- keepdir /var/cache/gosa
-}
-
-pkg_prerm() {
- ebegin "Flushing the class and locale cache"
- rm -r "${EROOT}"var/cache/gosa/*
- eend $?
- ebegin "Clearing the spool directory"
- rm -r "${EROOT}"var/spool/gosa/*
- eend $?
-}
-
-pkg_postinst() {
- ebegin "Generating class cache and locales"
- "${EROOT}"usr/sbin/update-gosa
- eend $?
-
- elog "Please make sure that the web server you are going to use has"
- elog "read-write access to ${EROOT}var/spool/gosa"
-
- elog "For Apache there is the gosa.include file in ${EROOT}etc/apache/vhosts.d."
- elog "You can either use it as a template for your configuration or directly"
- elog "include it in your apache configuration."
-
- elog "GOsa requires some objectclasses and attributes to be present in the"
- elog "directory. A sample configuration for slapd.conf can be found here:"
- elog " ${EROOR}usr/share/doc/${PF}/slapd.conf[.gz]"
-}
diff --git a/net-nds/gosa-core/gosa-core-2.6.11.ebuild b/net-nds/gosa-core/gosa-core-2.6.11.ebuild
deleted file mode 100644
index 92a75b3283bb..000000000000
--- a/net-nds/gosa-core/gosa-core-2.6.11.ebuild
+++ /dev/null
@@ -1,108 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=3
-
-inherit eutils
-
-DESCRIPTION="LDAP administration frontend for user administration"
-HOMEPAGE="https://oss.gonicus.de/labs/gosa/wiki/WikiStart."
-SRC_URI="ftp://oss.gonicus.de/pub/gosa/${P}.tar.bz2
- http://oss.gonicus.de/pub/gosa/${P}.tar.bz2
- ftp://oss.gonicus.de/pub/gosa/archive/${P}.tar.bz2
- http://oss.gonicus.de/pub/gosa/archive/${P}.tar.bz2 "
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="mail samba"
-
-DEPEND="dev-lang/php[iconv,imap,ldap,mysql,session,zip]
- sys-devel/gettext"
-RDEPEND="${DEPEND}
- virtual/httpd-php
- dev-perl/Crypt-SmbHash
- media-gfx/imagemagick"
-PDEPEND="mail? ( ~net-nds/gosa-plugin-mail-${PV} )
- samba? ( ~net-nds/gosa-plugin-samba-${PV} )"
-
-src_prepare() {
- epatch \
- "${S}/redhat/02_fix_class_mapping.patch" \
- "${S}/redhat/03_fix_locale_location.patch" \
- "${S}/redhat/04_fix_online_help_location.patch"
- sed -i \
- -e 's|../contrib|/usr/share/gosa/template|' \
- include/functions.inc || die "sed failed"
-}
-
-src_install() {
- insinto /usr/share/gosa
- doins -r doc html ihtml include locale plugins setup
-
- insinto /usr/share/gosa/template
- doins contrib/gosa.conf
-
- dosbin \
- update-gosa \
- bin/gosa-encrypt-passwords
-
- dobin \
- update-locale \
- update-online-help \
- update-pdf-help \
- dh-make-gosa \
- contrib/gosa
-
- insinto /etc/gosa
- doins \
- contrib/shells \
- contrib/encodings \
- contrib/desktoprc
- touch "${D}/etc/gosa/gosa.secrets"
-
- doicon debian/*.xpm
- domenu debian/gosa-desktop.desktop
-
- doman *.1 contrib/*.1 contrib/*.5
-
- dodoc contrib/openldap/slapd.conf
- insinto /etc/openldap/schema/gosa
- doins contrib/openldap/*.schema
-
- insinto /etc/apache2/vhosts.d
- doins "${FILESDIR}/gosa.include"
-
- dodoc AUTHORS Changelog FAQ README README.safemode
-
- keepdir /etc/gosa
- keepdir /var/spool/gosa
- keepdir /var/cache/gosa
-}
-
-pkg_prerm() {
- ebegin "Flushing the class and locale cache"
- rm -r "${EROOT}"var/cache/gosa/*
- eend $?
- ebegin "Clearing the spool directory"
- rm -r "${EROOT}"var/spool/gosa/*
- eend $?
-}
-
-pkg_postinst() {
- ebegin "Generating class cache and locales"
- "${EROOT}"usr/sbin/update-gosa
- eend $?
-
- elog "Please make sure that the web server you are going to use has"
- elog "read-write access to ${EROOT}var/spool/gosa"
-
- elog "For Apache there is the gosa.include file in ${EROOT}etc/apache/vhosts.d."
- elog "You can either use it as a template for your configuration or directly"
- elog "include it in your apache configuration."
-
- elog "GOsa requires some objectclasses and attributes to be present in the"
- elog "directory. A sample configuration for slapd.conf can be found here:"
- elog " ${EROOR}usr/share/doc/${PF}/slapd.conf[.gz]"
-}