summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-calculators/hexcalc/files/hexcalc-keypad.diff4
-rw-r--r--sci-calculators/hexcalc/hexcalc-1.11-r3.ebuild39
2 files changed, 41 insertions, 2 deletions
diff --git a/sci-calculators/hexcalc/files/hexcalc-keypad.diff b/sci-calculators/hexcalc/files/hexcalc-keypad.diff
index 1becd895c1c3..c24bc07f7a20 100644
--- a/sci-calculators/hexcalc/files/hexcalc-keypad.diff
+++ b/sci-calculators/hexcalc/files/hexcalc-keypad.diff
@@ -1,5 +1,5 @@
---- hexcalc.c 1989-11-22 22:29:06.000000000 +0100
-+++ hexcalc.c.new 2006-11-27 11:38:07.000000000 +0100
+--- a/hexcalc.c
++++ b/hexcalc.c
@@ -208,46 +208,73 @@
};
diff --git a/sci-calculators/hexcalc/hexcalc-1.11-r3.ebuild b/sci-calculators/hexcalc/hexcalc-1.11-r3.ebuild
new file mode 100644
index 000000000000..47b4f3e455c0
--- /dev/null
+++ b/sci-calculators/hexcalc/hexcalc-1.11-r3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="A simple hex calculator for X"
+HOMEPAGE="ftp://ftp.x.org/R5contrib/"
+SRC_URI="ftp://ftp.x.org/R5contrib/${PN}.tar.Z"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="x11-libs/libXaw"
+DEPEND="${RDEPEND}
+ x11-misc/imake
+ app-text/rman"
+
+S=${WORKDIR}/${PN}
+
+PATCHES=( "${FILESDIR}"/${PN}-{keypad,order}.diff )
+
+src_compile() {
+ xmkmf || die
+ emake \
+ CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS}" \
+ CCLINK="$(tc-getCC)" \
+ LDOPTIONS="${LDFLAGS}"
+}
+
+src_install() {
+ dobin ${PN}
+ newman ${PN}.{man,1}
+}