summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-admin/clsync/Manifest2
-rw-r--r--app-admin/clsync/clsync-0.4.1.ebuild114
2 files changed, 0 insertions, 116 deletions
diff --git a/app-admin/clsync/Manifest b/app-admin/clsync/Manifest
index c29a40464295..908a4bd9d9e1 100644
--- a/app-admin/clsync/Manifest
+++ b/app-admin/clsync/Manifest
@@ -1,3 +1 @@
-DIST clsync-0.4.1-20150524-v2.patch.xz 13632 BLAKE2B 422ec7dc05c2f21aa96c397efa7ce1079b882d5ec4ce14beb8ce5e308e134142dcc557857ff8162b5fba84d8eaa078016794ed26433427d6a80e4e4f81fd90a8 SHA512 d39c3c4f116eff2365668374ef62f4dfd8e5926267cbbf36b430f97ad5306f92cf6be3164c0e1c3d959db55453f5ded00d98d48af62f9eacde39a9f9667cfbf9
-DIST clsync-0.4.1.tar.gz 253890 BLAKE2B c8aada690635f1cac355a1eaa51f4379688b0005869c5dcd6edccf5ae8e86abddf9ff99ccfcffeb165ccc80f407087a3f0863d1b78279894ff410daf25467740 SHA512 875280f706026d44806b92c22fa58d016136b2792f67a6b7e77f932465081da7a1ebaf22c25e538e4b58bfe04cd1cd5450ecab99c3df53ddd2a0fa966442d444
DIST clsync-0.4.2.tar.gz 256042 BLAKE2B 28474fc66341b93705a502fcff390e3affcd89a9e1eb272dce9b28be709562e09c03e9c300cfeb5371e2e618a2239468a58c46212a39d751fbbfddeaab12bcf6 SHA512 d14a2efc4bf58d9d5c7a3fe5634cacdd182cd7cd814b0e9ebd99024a7282b056d1f7ceeec6903666391c3572d599a18e205af818b098ed7768d5c0e0f4cd1200
diff --git a/app-admin/clsync/clsync-0.4.1.ebuild b/app-admin/clsync/clsync-0.4.1.ebuild
deleted file mode 100644
index c037951819d2..000000000000
--- a/app-admin/clsync/clsync-0.4.1.ebuild
+++ /dev/null
@@ -1,114 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-if [[ ${PV} == "9999" ]] ; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/xaionaro/${PN}.git"
-else
- PVER="20150524-v2"
- SRC_URI="
- https://github.com/xaionaro/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
- https://dev.gentoo.org/~bircoph/patches/${P}-${PVER}.patch.xz
- "
- KEYWORDS="~amd64 ~x86"
-fi
-
-inherit autotools eutils linux-info
-
-DESCRIPTION="Live sync tool based on inotify, written in GNU C"
-HOMEPAGE="https://github.com/xaionaro/clsync http://ut.mephi.ru/oss/clsync"
-LICENSE="GPL-3+"
-SLOT="0"
-IUSE="+caps cluster control-socket cgroups debug extra-debug
-extra-hardened gio hardened +highload-locks +inotify mhash
-namespaces seccomp"
-
-REQUIRED_USE="
- || ( gio inotify )
- extra-debug? ( debug )
- extra-hardened? ( hardened )
- mhash? ( cluster )
- seccomp? ( caps )
-"
-CDEPEND="
- dev-libs/glib:2
- cgroups? ( dev-libs/libcgroup )
- mhash? ( app-crypt/mhash )
-"
-DEPEND="${CDEPEND}
- virtual/pkgconfig
-"
-RDEPEND="${CDEPEND}
- ~app-doc/clsync-docs-${PV}
-"
-
-pkg_pretend() {
- use namespaces && CONFIG_CHECK="~NAMESPACES ~UTS_NS ~IPC_NS ~USER_NS ~PID_NS ~NET_NS"
- use seccomp && CONFIG_CHECK+=" ~SECCOMP"
- check_extra_config
-}
-
-src_prepare() {
- # upstream fixes for 0.4.1
- epatch "${WORKDIR}/${P}-${PVER}.patch"
- eautoreconf
-}
-
-src_configure() {
- local harden_level=0
- use hardened && harden_level=1
- use extra-hardened && harden_level=2
-
- local debug_level=0
- use debug && debug_level=1
- use extra-debug && debug_level=2
-
- econf \
- --docdir="${EPREFIX}/usr/share/doc/${PF}" \
- --disable-socket-library \
- --enable-clsync \
- --enable-debug=${debug_level} \
- --enable-paranoid=${harden_level} \
- --without-bsm \
- --without-kqueue \
- $(use_enable caps capabilities) \
- $(use_enable cluster) \
- $(use_enable control-socket socket) \
- $(use_enable highload-locks) \
- $(use_enable namespaces unshare) \
- $(use_enable seccomp) \
- $(use_with cgroups libcgroup) \
- $(use_with gio gio lib) \
- $(use_with inotify inotify native) \
- $(use_with mhash)
-}
-
-src_install() {
- emake DESTDIR="${D}" install
-
- # docs go into clsync-docs
- rm -rf "${ED}/usr/share/doc" || die
-
- newinitd "${FILESDIR}/${PN}.initd" "${PN}"
- newconfd "${FILESDIR}/${PN}.confd" "${PN}"
-
- # filter rules and sync scripts are supposed to be here
- keepdir "${EPREFIX}/etc/${PN}"
- insinto "/etc/${PN}"
- newins "${FILESDIR}/${PN}.conf" "${PN}.conf"
-}
-
-pkg_postinst() {
- einfo "${PN} is just a convenient way to run synchronization tools on live data,"
- einfo "it doesn't copy data itself, so you need to install software to do actual"
- einfo "data transfer. Usually net-misc/rsync is a good choise, but ${PN} is"
- einfo "is flexible enough to use any user tool, see manual page for details."
- einfo
- einfo "${PN} init script can be multiplexed, to use symlink init script to"
- einfo "othername and use conf.d/othername to configure it."
- einfo
- einfo "If you're interested in improved security, enable"
- einfo "USE=\"caps cgroups hardened namespaces seccomp\""
-}