summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-crypt/certbot/Manifest1
-rw-r--r--app-crypt/certbot/certbot-0.10.1.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/app-crypt/certbot/Manifest b/app-crypt/certbot/Manifest
index 845a0fb8a3cf..497ee2ed67a0 100644
--- a/app-crypt/certbot/Manifest
+++ b/app-crypt/certbot/Manifest
@@ -1,2 +1,3 @@
+DIST certbot-0.10.1.tar.gz 823669 SHA256 c91b5fddb50dfd46545c12c1e96d1bb5e2794652c11421a6f5d9dad2bbca4d52 SHA512 4e45280b9cb6db3f8dcecfbf0cf64c990ea58d8607ed1aea9853c7248f8830301cc8685126eeb0d0c2ef0e23298c9070b291110d733e72867967bc9506900702 WHIRLPOOL ae08a9236adf69915c4a141106aa104563b1298f9fd3a32491ed8c45fddc9f32243154ba5bde9af7a8b74a95a1d2b7d337e4cbcc37f35ba997a7a50eb2f15200
DIST certbot-0.8.1.tar.gz 698305 SHA256 1fb4834eba306a656f26257f86ed298df354cdecb1b0bde316a9d23a1e19db01 SHA512 8b21d270b5ee847086369b956b3346fdddd50ab0e4490d988e7ca535f4d4101e2859e99bc5f77ac920afd3a6a9210e407b155c89c28d282dc0544735a27e3eaa WHIRLPOOL 909a3f6f63fac84bf6fe8fb35b9aba46c06912af01d5f702eee5b6aeab49d4f2a92fa05e4f060da11ac6cbc89047e92457f626d6c82aa0de0f1127ca79924fc7
DIST certbot-0.9.3.tar.gz 794146 SHA256 5c40cfcf3a17624e34dcb733148bd247c4f0cee189766fe0fb6d29571d4068bb SHA512 a951e639515fc037721d8b086e53100dcc86974a96c61c7173b2a9c0582bb59380efe219caf3fd1517fcdf28dde4a1f66bba84b51e2a2027df114818ff4d7565 WHIRLPOOL 45c7b17cffc971acf3b6998c5702abd91c067e095acd9a4264109e711b869ac1db9e7d2a4ff9d86d680f5579b6a2fbca610a6905c81e549f72a10adf17f19da2
diff --git a/app-crypt/certbot/certbot-0.10.1.ebuild b/app-crypt/certbot/certbot-0.10.1.ebuild
new file mode 100644
index 000000000000..e7b790e54950
--- /dev/null
+++ b/app-crypt/certbot/certbot-0.10.1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=(python2_7)
+
+if [[ ${PV} == 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/certbot/certbot.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~x86"
+fi
+
+inherit distutils-r1
+
+DESCRIPTION="Let's encrypt client to automate deployment of X.509 certificates"
+HOMEPAGE="https://github.com/certbot/certbot https://letsencrypt.org/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="test"
+
+CDEPEND=">=dev-python/setuptools-1.0[${PYTHON_USEDEP}]"
+RDEPEND="
+ ${CDEPEND}
+ =app-crypt/acme-${PV}[${PYTHON_USEDEP}]
+ >=dev-python/configargparse-0.9.3[${PYTHON_USEDEP}]
+ dev-python/configobj[${PYTHON_USEDEP}]
+ >=dev-python/cryptography-0.7[${PYTHON_USEDEP}]
+ >=dev-python/parsedatetime-1.3[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ dev-python/pyrfc3339[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/zope-component[${PYTHON_USEDEP}]
+ dev-python/zope-interface[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]"
+DEPEND="
+ ${CDEPEND}
+ test? (
+ >=dev-python/astroid-1.3.5[${PYTHON_USEDEP}]
+ dev-python/coverage[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/pep8[${PYTHON_USEDEP}]
+ >=dev-python/psutil-2.2.1[${PYTHON_USEDEP}]
+ >=dev-python/pylint-1.4.2[${PYTHON_USEDEP}]
+ dev-python/wheel[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ nosetests -v ${PN} || die
+}