summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-php/pecl-http/Manifest2
-rw-r--r--dev-php/pecl-http/pecl-http-2.5.6.ebuild38
-rw-r--r--dev-php/pecl-http/pecl-http-3.0.1.ebuild41
3 files changed, 81 insertions, 0 deletions
diff --git a/dev-php/pecl-http/Manifest b/dev-php/pecl-http/Manifest
index 1529ed995423..994e37bccb8c 100644
--- a/dev-php/pecl-http/Manifest
+++ b/dev-php/pecl-http/Manifest
@@ -1 +1,3 @@
DIST pecl_http-1.7.6.tgz 174722 SHA256 e87207a7dcd713bef0eb3701b552e0d173fbd73dbd52f9d3968851112e899983 SHA512 e548073e08d106c9ee633dc00c2728845e3a1403c065134a0e8111899b52dacb7175cea836e19da8cf2b7f42fe58c084602003bb79f16d529bc109c39a78bbca WHIRLPOOL 778bd7f1a0bb1698c4a6a8745a40ea5c757ade6cfc027b99bd10f92cc3b111ceb7887a582216c8a303a2ce8edfc90c653b4c055b057691f873c2e3dbd78f740a
+DIST pecl_http-2.5.6.tgz 200469 SHA256 8435eb9082b8fdc56b630e3d3d8e63617a3bc43d360f6f49fbd7b1856b266be4 SHA512 a4ddb2e55b537a240dc79ad38665f9cb79ef56a70f50e0393ca19c36f744c21374ba801e31e68545516c4be98cff65587ee91b2b25f05dd587120afcb87dfe4a WHIRLPOOL d4d2158b610c959a558b450a79a77a7f9de53d6e75982e920c4b64d48731139223659af149b9894c2fee1a477005af34a57cb33a806429e11446d5162b031b89
+DIST pecl_http-3.0.1.tgz 197372 SHA256 4e45ea546e3245669887ec98187666ccb4aa3df15078335b1c02c824c8165031 SHA512 344ae45987269d9505ffed6059be378005298d89c5e39bda6f771d8bf5a1998e91c214c03d32b9c78329c95e4928d35d3659dd3a1c70071aa5b2bd2763852098 WHIRLPOOL 76538ec0b94ef5d63808b625a8e73ab499c2afc78cd0f31823dcea4de66d865f7cf8387cc67eac1f19fec032a7ac7b7775685048ac0c6f76fadccfc1d932026c
diff --git a/dev-php/pecl-http/pecl-http-2.5.6.ebuild b/dev-php/pecl-http/pecl-http-2.5.6.ebuild
new file mode 100644
index 000000000000..c08fe56f43d4
--- /dev/null
+++ b/dev-php/pecl-http/pecl-http-2.5.6.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="6"
+
+PHP_EXT_NAME="http"
+PHP_EXT_PECL_PKG="pecl_http"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+
+USE_PHP="php5-6"
+
+inherit php-ext-pecl-r3
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="Extended HTTP Support for PHP"
+LICENSE="BSD-2 MIT"
+SLOT="2"
+IUSE="ssl curl_ssl_gnutls curl_ssl_libressl curl_ssl_nss +curl_ssl_openssl"
+
+DEPEND="dev-libs/libevent
+ dev-php/pecl-propro:0
+ dev-php/pecl-raphf:0
+ net-dns/libidn
+ sys-libs/zlib
+ ssl? ( net-misc/curl[ssl,curl_ssl_gnutls=,curl_ssl_libressl=,curl_ssl_nss=,curl_ssl_openssl=] )
+ !ssl? ( net-misc/curl[-ssl] )
+ php_targets_php5-6? ( dev-lang/php:5.6[hash,session,iconv] )"
+RDEPEND="${DEPEND}"
+
+PHP_EXT_ECONF_ARGS=( --with-http --without-http-shared-deps )
+
+pkg_postinst() {
+ ewarn "This API has drastically changed and is not compatible with the 1.x syntax."
+ ewarn "Please review the documentation and update your code."
+}
diff --git a/dev-php/pecl-http/pecl-http-3.0.1.ebuild b/dev-php/pecl-http/pecl-http-3.0.1.ebuild
new file mode 100644
index 000000000000..309a14ee49fc
--- /dev/null
+++ b/dev-php/pecl-http/pecl-http-3.0.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="6"
+
+PHP_EXT_NAME="http"
+PHP_EXT_PECL_PKG="pecl_http"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+
+USE_PHP="php5-6 php7-0"
+
+inherit php-ext-pecl-r3
+
+USE_PHP="php7-0"
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="Extended HTTP Support for PHP"
+LICENSE="BSD-2 MIT"
+SLOT="7"
+IUSE="ssl curl_ssl_gnutls curl_ssl_libressl curl_ssl_nss +curl_ssl_openssl"
+
+DEPEND="dev-libs/libevent
+ dev-php/pecl-propro:7
+ dev-php/pecl-raphf:7
+ net-dns/libidn
+ sys-libs/zlib
+ ssl? ( net-misc/curl[ssl,curl_ssl_gnutls=,curl_ssl_libressl=,curl_ssl_nss=,curl_ssl_openssl=] )
+ !ssl? ( net-misc/curl[-ssl] )
+ php_targets_php7-0? ( dev-lang/php:7.0[hash,session,iconv] )"
+RDEPEND="${DEPEND}
+ php_targets_php5-6? ( dev-php/pecl-http:2 )"
+
+PHP_EXT_ECONF_ARGS=( --with-http --without-http-shared-deps )
+
+pkg_postinst() {
+ ewarn "This API has drastically changed and is not compatible with the 1.x syntax."
+ ewarn "Please review the documentation and update your code."
+}