summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-libs/libvncserver/libvncserver-0.9.10-r3.ebuild1
-rw-r--r--net-libs/libvncserver/libvncserver-0.9.10-r4.ebuild1
-rw-r--r--net-libs/libvncserver/libvncserver-0.9.10_p20160127.ebuild1
3 files changed, 3 insertions, 0 deletions
diff --git a/net-libs/libvncserver/libvncserver-0.9.10-r3.ebuild b/net-libs/libvncserver/libvncserver-0.9.10-r3.ebuild
index 2513920a9deb..298b3dff2e21 100644
--- a/net-libs/libvncserver/libvncserver-0.9.10-r3.ebuild
+++ b/net-libs/libvncserver/libvncserver-0.9.10-r3.ebuild
@@ -14,6 +14,7 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux"
IUSE="+24bpp gcrypt gnutls ipv6 +jpeg +png ssl static-libs test threads +zlib"
+REQUIRED_USE="!gnutls? ( ssl? ( threads ) )"
DEPEND="
gcrypt? ( >=dev-libs/libgcrypt-1.5.3:0[${MULTILIB_USEDEP}] )
diff --git a/net-libs/libvncserver/libvncserver-0.9.10-r4.ebuild b/net-libs/libvncserver/libvncserver-0.9.10-r4.ebuild
index fb9059f56fc0..c5903de34a74 100644
--- a/net-libs/libvncserver/libvncserver-0.9.10-r4.ebuild
+++ b/net-libs/libvncserver/libvncserver-0.9.10-r4.ebuild
@@ -14,6 +14,7 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux"
IUSE="+24bpp gcrypt gnutls ipv6 +jpeg libressl +png ssl static-libs test threads +zlib"
+REQUIRED_USE="!gnutls? ( ssl? ( threads ) )"
DEPEND="
gcrypt? ( >=dev-libs/libgcrypt-1.5.3:0[${MULTILIB_USEDEP}] )
diff --git a/net-libs/libvncserver/libvncserver-0.9.10_p20160127.ebuild b/net-libs/libvncserver/libvncserver-0.9.10_p20160127.ebuild
index 4190a404e2b5..8d83469a3370 100644
--- a/net-libs/libvncserver/libvncserver-0.9.10_p20160127.ebuild
+++ b/net-libs/libvncserver/libvncserver-0.9.10_p20160127.ebuild
@@ -14,6 +14,7 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux"
IUSE="+24bpp gcrypt gnutls ipv6 +jpeg libressl +png ssl static-libs test threads +zlib"
+REQUIRED_USE="!gnutls? ( ssl? ( threads ) )"
DEPEND="
gcrypt? ( >=dev-libs/libgcrypt-1.5.3:0[${MULTILIB_USEDEP}] )