summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--ros-meta/hector_slam/Manifest1
-rw-r--r--ros-meta/hector_slam/hector_slam-0.3.4.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/ros-meta/hector_slam/Manifest b/ros-meta/hector_slam/Manifest
index 8dc36f58a078..7e46dfcbce6b 100644
--- a/ros-meta/hector_slam/Manifest
+++ b/ros-meta/hector_slam/Manifest
@@ -1 +1,2 @@
DIST hector_slam-0.3.3.tar.gz 64368 SHA256 e3da461e7e4020218ae3d26f2eb6e135d1ac486bb0dab52f60e9d2349c637e5c SHA512 755a639b865d897281f01e28ca8dcdf943d953422f38ba73ed7e982c22c178cb5becbb9d2962420136cad0927f5c412ce896fc9b1995b58d7163fb35a82c62c0 WHIRLPOOL 4813768350cb232d4171a2f1335472e07ddb526b8846f56f3820a2dd4c51673d3c26866554e1a5b3e097530265efd104bd2a5eeda7c25639af991b4696971d4d
+DIST hector_slam-0.3.4.tar.gz 64569 SHA256 8675e34e21a348384c67fc873555030298735b23f49fecddf17748951082a80e SHA512 c256ddf199f2b516241a612fb4bf7ab3d5531da20e89293465dd4ea948260c420f7b9c853ce44f9a3c9a18eee882f4e2c80ec18a8d1daf2bfc9d1accf358241a WHIRLPOOL 85d407e2191562599b95af7a16bfccc94b26f1e193a86b4f8bc90bb74c5950743d0195d4317f2f7844d0e83a18c4d73412377b622a62eeacad11f5442c1a1278
diff --git a/ros-meta/hector_slam/hector_slam-0.3.4.ebuild b/ros-meta/hector_slam/hector_slam-0.3.4.ebuild
new file mode 100644
index 000000000000..80e140f221bd
--- /dev/null
+++ b/ros-meta/hector_slam/hector_slam-0.3.4.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/tu-darmstadt-ros-pkg/hector_slam"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="hector_mapping and related packages"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/hector_compressed_map_transport
+ dev-ros/hector_geotiff_plugins
+ dev-ros/hector_imu_tools
+ dev-ros/hector_map_server
+ dev-ros/hector_marker_drawing
+ dev-ros/hector_trajectory_server
+ dev-ros/hector_geotiff
+ dev-ros/hector_imu_attitude_to_tf
+ dev-ros/hector_mapping
+ dev-ros/hector_map_tools
+ dev-ros/hector_nav_msgs
+ dev-ros/hector_slam_launch
+"
+DEPEND=""