summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-util/serialtalk/serialtalk-1.2-r1.ebuild20
-rw-r--r--dev-util/serialtalk/serialtalk-9999.ebuild10
2 files changed, 23 insertions, 7 deletions
diff --git a/dev-util/serialtalk/serialtalk-1.2-r1.ebuild b/dev-util/serialtalk/serialtalk-1.2-r1.ebuild
new file mode 100644
index 000000000000..db77b5ea4160
--- /dev/null
+++ b/dev-util/serialtalk/serialtalk-1.2-r1.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/BGO-OD/serialtalk.git"
+else
+ SRC_URI="https://github.com/BGO-OD/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Simple command-line tool to talk to serial devices"
+HOMEPAGE="https://github.com/BGO-OD/serialtalk"
+
+LICENSE="GPL-3+"
+SLOT="0"
diff --git a/dev-util/serialtalk/serialtalk-9999.ebuild b/dev-util/serialtalk/serialtalk-9999.ebuild
index 59c9ad0a3efd..0943a8aaeff8 100644
--- a/dev-util/serialtalk/serialtalk-9999.ebuild
+++ b/dev-util/serialtalk/serialtalk-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit cmake-utils
+inherit cmake
if [[ ${PV} == 9999 ]]; then
inherit git-r3
@@ -18,7 +18,3 @@ HOMEPAGE="https://github.com/BGO-OD/serialtalk"
LICENSE="GPL-3+"
SLOT="0"
-
-src_install() {
- cmake-utils_src_install
-}