summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-boot/refind/Manifest1
-rw-r--r--sys-boot/refind/refind-0.10.2.ebuild106
2 files changed, 107 insertions, 0 deletions
diff --git a/sys-boot/refind/Manifest b/sys-boot/refind/Manifest
index c65dff541d8a..a023872352e6 100644
--- a/sys-boot/refind/Manifest
+++ b/sys-boot/refind/Manifest
@@ -1,3 +1,4 @@
DIST refind-src-0.10.0.tar.gz 3336917 SHA256 845dc3a18d4c82c1e29d4dbef14a53f4de1401c5bb3ea10f3f39442efa870e2e SHA512 111caea0c1dbd9dde50e7b3cf47c7ad0d5e7f3bec3bb784397171950865cffd8cf589c6a1b821fabd6ed4be191a322757bf94255bfd449ee4a647ad597c3d7ab WHIRLPOOL 8e9070c89b83ff7e49b34c45f5f7d3ecd90824f8ba95eae4105636125500eafc29a7ae34a602cb268bd7bd4e90fe2a7e2a8bad4a9b68baa283a59d0a34ae1d1f
+DIST refind-src-0.10.2.tar.gz 2949593 SHA256 ef6aa17e911ea899c0d5e9482bfe657bc63b425976b0e2f936e67cbec3f1c34c SHA512 7f74109a2f2a8dd5889834c0d9cf9b186ed5487a737b442caed5ce2df06de13efc2553d264792e5f72e4bb281926a772aeca96187209d856a8b9abe9f831580c WHIRLPOOL 224c168b1eb980c850b008f0a6e2148b8bbc0ed1d591c4bdfb1c182af9430e5eb9ac8a58ec8f83a50320d30a946b1feeda12eb02a36450e7912462c6058cc7fc
DIST refind-src-0.9.0.zip 2939724 SHA256 842a01d7964bc8c8000a66e6d08f6fadb4c257d251b1277cebff0bf731e024aa SHA512 c49e3110e6b9f8d44dadae1ab828d3bf59bbce2da9170efed73db961135144ae9963b57d4cc39af2b15ecdf1f289359bda56c3d3e8f72d05be165ae5a3e2654d WHIRLPOOL 225a6b84ea7044e8fe0bab5e268c8c46a4523ab6f408d1bb2a94adfe54afe80c9c83ec0dc104945b332ae6c375c9d041972dee39baa43665588eb0dfc1fe4362
DIST refind-src-0.9.2.zip 2941986 SHA256 9022da3d46493395c273e2d2fc555d1c786fb1b9c11b2912751a88fe3328212a SHA512 6636cf02bb69ffe699d5f9717d09b80db0e4330aa52c14949e8612caed11f032370db17700c15d285173729271d2434fd0fbc39f5b445a3c05255ee14d125d47 WHIRLPOOL 2d81427bf6cc9cf021a4ffc7238bcf914e380fea091cbefaa601e391cf28f43f7c3ef1181744e4aab3d71d2535d88ba633b13cdae696f0baddd26d3c2511a88d
diff --git a/sys-boot/refind/refind-0.10.2.ebuild b/sys-boot/refind/refind-0.10.2.ebuild
new file mode 100644
index 000000000000..db4455b68cff
--- /dev/null
+++ b/sys-boot/refind/refind-0.10.2.ebuild
@@ -0,0 +1,106 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="The rEFInd UEFI Boot Manager by Rod Smith"
+HOMEPAGE="http://www.rodsbooks.com/refind/"
+
+SRC_URI="mirror://sourceforge/project/${PN}/${PV}/${PN}-src-${PV}.tar.gz"
+
+LICENSE="BSD GPL-2 GPL-3 FDL-1.3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+FS_USE="btrfs +ext2 +ext4 hfs +iso9660 ntfs reiserfs"
+IUSE="${FS_USE} doc"
+
+DEPEND=">=sys-boot/gnu-efi-3.0.2"
+
+DOCS="NEWS.txt README.txt docs/refind docs/Styles"
+
+pkg_setup() {
+ if use x86 ; then
+ export EFIARCH=ia32
+ export BUILDARCH=ia32
+ elif use amd64; then
+ export EFIARCH=x64
+ export BUILDARCH=x86_64
+ else
+ # Try to support anyway
+ export BUILDARCH=$( uname -m | sed s,i[3456789]86,ia32, )
+ if [[ ${BUILDARCH} == "x86_64" ]] ; then
+ export EFIARCH=x64
+ else
+ export EFIARCH=${ARCH}
+ fi
+ fi
+}
+
+src_compile() {
+ # Make main EFI
+ all_target=gnuefi
+ emake ARCH=${BUILDARCH} ${all_target}
+
+ # Make filesystem drivers
+ export gnuefi_target="_gnuefi"
+ for fs in ${FS_USE}; do
+ fs=${fs#+}
+ if use "${fs}"; then
+ einfo "Building ${fs} filesystem driver"
+ rm -f "${S}/filesystems/fsw_efi.o"
+ emake -C "${S}/filesystems" ARCH=${BUILDARCH} ${fs}${gnuefi_target}
+ fi
+ done
+}
+
+src_install() {
+ exeinto "/usr/share/${P}"
+ doexe refind-install
+ dosym "/usr/share/${P}/refind-install" "/usr/sbin/refind-install"
+
+ dodoc "${S}"/{COPYING.txt,LICENSE.txt,CREDITS.txt}
+ if use doc; then
+ doman "${S}/docs/man/"*
+ dodoc -r ${DOCS}
+ fi
+
+ insinto "/usr/share/${P}/refind"
+ doins "${S}/refind/refind_${EFIARCH}.efi"
+ doins "${S}/refind.conf-sample"
+ doins -r images icons fonts banners
+
+ if [[ -d "${S}/drivers_${EFIARCH}" ]]; then
+ doins -r "${S}/drivers_${EFIARCH}"
+ fi
+
+ insinto "/usr/share/${P}/refind/tools_${EFIARCH}"
+ doins "${S}/gptsync/gptsync_${EFIARCH}.efi"
+
+ insinto "/etc/refind.d"
+ doins -r "${S}/keys"
+
+ dosbin "${S}/mkrlconf"
+ dosbin "${S}/mvrefind"
+}
+
+pkg_postinst() {
+ elog "rEFInd has been built and installed into /usr/share/${P}"
+ elog "You will need to use the command 'refind-install' to install"
+ elog "the binaries into your EFI System Partition"
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ elog ""
+ elog "refind-install requires additional packages to be fully functional:"
+ elog " app-crypt/sbsigntool for binary signing for use with SecureBoot"
+ elog " sys-boot/efibootmgr for writing to NVRAM"
+ elog " sys-block/parted for automatic ESP location and mount"
+ elog ""
+ elog "A sample configuration can be found at"
+ elog "/usr/share/${P}/refind/refind.conf-sample"
+ else
+ ewarn "Note that this will not update any EFI binaries on your EFI"
+ ewarn "System Partition - this needs to be done manually."
+ fi
+}