summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-admin/eselect/Manifest1
-rw-r--r--app-admin/eselect/eselect-1.4.7.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/app-admin/eselect/Manifest b/app-admin/eselect/Manifest
index dbc11ed87813..fbbce85ff44d 100644
--- a/app-admin/eselect/Manifest
+++ b/app-admin/eselect/Manifest
@@ -1,2 +1,3 @@
DIST eselect-1.4.5.tar.xz 175992 SHA256 15beabb4c2afab4f833ceb2a66859849a5c20b8f8d61366ffe4b556a200d5f12 SHA512 d561b66386ac90335041e8fb88dd85cbe98ea32a98eab309a5fb07de1b9fe10c50dcdd03f93632d4bc938c1729ddb0954fa37482eb7856a87c24f41a7bc29a35 WHIRLPOOL e18839e9ff0ea1af03c6246533e72d39f9f7eb61f28d6cec3ff1a571374f23f7d55751c1f20bfb99c40fb44a81b5754b6c92d62c98f6b1b45dc8bf388b54db40
DIST eselect-1.4.6.tar.xz 176400 SHA256 17a8dae5c84cd29a120ddac3bb7df82ed68f560743f0289d7f64e8a0ba6903b6 SHA512 7ec648346e3810cd753ef736a4a9996ae88037f1dea68b7485bb48964eeb2ae43a7feff5a3957fb3bef7f2b21e0d4bd70b128fbe63d7be17ec4cf9a480371e94 WHIRLPOOL 8a71017359c49c72dd3c7c87cc438a1c6347c4a414e28c437c06a9078ac26ee905c60d35cbe555dad27137e6b3f0ee30fc904070a59b566b683acf8751081afe
+DIST eselect-1.4.7.tar.xz 176412 SHA256 90bdf6e8f1c5f39e3f2d6626d1da25023f881fec997645b0347e2a26568c7e03 SHA512 4e3812e0906c51ea9b7922cc37b2de172a33af59081b5c4e32ed6c2244231a2757ed4508fb43421cf50fc6f04147530a7c199ded8f3037493bcd17a7f0a2734e WHIRLPOOL d4d79bbb0f4104c9a4e692f2f927bcfe3619227d7b9d67fbd29433639eadb6e1d2d02f8458f6a360ad4c3944f173e11a6a337766c66faa476052d82431c7e8b0
diff --git a/app-admin/eselect/eselect-1.4.7.ebuild b/app-admin/eselect/eselect-1.4.7.ebuild
new file mode 100644
index 000000000000..11f0e763eabe
--- /dev/null
+++ b/app-admin/eselect/eselect-1.4.7.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils bash-completion-r1
+
+DESCRIPTION="Gentoo's multi-purpose configuration and management tool"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Eselect"
+SRC_URI="https://dev.gentoo.org/~ulm/eselect/${P}.tar.xz"
+
+LICENSE="GPL-2+ || ( GPL-2+ CC-BY-SA-3.0 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~arm-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc emacs vim-syntax"
+
+RDEPEND="sys-apps/sed
+ || (
+ sys-apps/coreutils
+ sys-freebsd/freebsd-bin
+ app-misc/realpath
+ )"
+DEPEND="${RDEPEND}
+ app-arch/xz-utils
+ doc? ( dev-python/docutils )"
+RDEPEND="${RDEPEND}
+ sys-apps/file
+ sys-libs/ncurses:0"
+
+PDEPEND="emacs? ( app-emacs/eselect-mode )
+ vim-syntax? ( app-vim/eselect-syntax )"
+
+src_compile() {
+ emake
+ use doc && emake html
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ newbashcomp misc/${PN}.bashcomp ${PN}
+ dodoc AUTHORS ChangeLog NEWS README TODO doc/*.txt
+ if use doc; then
+ docinto html
+ dodoc *.html doc/*.html doc/*.css
+ fi
+
+ # needed by news module
+ keepdir /var/lib/gentoo/news
+ if ! use prefix; then
+ fowners root:portage /var/lib/gentoo/news
+ fperms g+w /var/lib/gentoo/news
+ fi
+}
+
+pkg_postinst() {
+ # fowners in src_install doesn't work for the portage group:
+ # merging changes the group back to root
+ if ! use prefix; then
+ chgrp portage "${EROOT}/var/lib/gentoo/news" \
+ && chmod g+w "${EROOT}/var/lib/gentoo/news"
+ fi
+}