summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-irc/ii/Manifest1
-rw-r--r--net-irc/ii/ii-1.8.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/net-irc/ii/Manifest b/net-irc/ii/Manifest
index caa8727424bc..b3af42cfc784 100644
--- a/net-irc/ii/Manifest
+++ b/net-irc/ii/Manifest
@@ -1 +1,2 @@
DIST ii-1.7.tar.gz 10174 BLAKE2B 93af2dc182d77dbfca65cbee6c40aedabe9166be7abcb03c87e80e74273dea1e4dd875d86cf0e1dd04b4a10bfcd825ea9a8c109badb72cc877a484bdaea705d9 SHA512 1fa744bc9b4291b5c6c56e023d982aad59001137db6c7682284a2d63e649a32d558adbb85ae3407e312ae5436852b4278c2c522d4ef03f47cf54ea3a1f13ca90
+DIST ii-1.8.tar.gz 12326 BLAKE2B 7ae90d788aaec0a359ce46370f27c0ce62c6f77e8cda61d9d168d0ebd7de927a478b42a591631f2c193f3816b2a1b39cf79607326b073bcbeefe4291e0fb95f6 SHA512 2b41a0611ac76612c9333e8490709ee22d17506f0c5d7e680a0d8f3f8b511bd5b279555cf609c1543aba71948819369a3c306b1168086890aa49c145b7860e17
diff --git a/net-irc/ii/ii-1.8.ebuild b/net-irc/ii/ii-1.8.ebuild
new file mode 100644
index 000000000000..0a4bb49da753
--- /dev/null
+++ b/net-irc/ii/ii-1.8.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit toolchain-funcs
+
+DESCRIPTION="A minimalist FIFO and filesystem-based IRC client"
+HOMEPAGE="https://tools.suckless.org/ii/"
+SRC_URI="https://dl.suckless.org/tools/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux"
+
+src_prepare() {
+ default
+
+ sed -i \
+ -e '/^CFLAGS/{s: -Os::g; s:= :+= :g}' \
+ -e '/^CC/d' \
+ -e '/^LDFLAGS/{s:-s::g; s:= :+= :g}' \
+ config.mk || die
+ sed -i \
+ -e 's|@${CC}|$(CC)|g' \
+ Makefile || die
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ dobin ii
+ dodoc CHANGES FAQ README
+ doman *.1
+}