summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--mate-base/mate-menus/Manifest1
-rw-r--r--mate-base/mate-menus/files/10-xdg-menu-mate6
-rw-r--r--mate-base/mate-menus/mate-menus-1.22.0-r1.ebuild44
-rw-r--r--mate-base/mate-menus/mate-menus-1.22.0.ebuild53
4 files changed, 0 insertions, 104 deletions
diff --git a/mate-base/mate-menus/Manifest b/mate-base/mate-menus/Manifest
index 93d204822310..03b0ebdd06cb 100644
--- a/mate-base/mate-menus/Manifest
+++ b/mate-base/mate-menus/Manifest
@@ -1,3 +1,2 @@
-DIST mate-menus-1.22.0.tar.xz 355948 BLAKE2B f65bd45c4c7c04f11f9228499991d7c2dfa60a3e74e4cbfcffc3a02f09e8e6cad6b4b4adb6d9227a4e893bad9dc032afc6cce8098ea62fd133ef836cbe9abdf2 SHA512 7ca02c1bb89c83b6b331fc2e8878862fa8f02f5cd52b297aa44b36dd5c2d1ee1ffeb1641d63a10bd4deb99f63ded9c3b890a05ab7f7faf32d7f895b0a2f68d70
DIST mate-menus-1.22.1.tar.xz 351080 BLAKE2B 3ec947d6befefc838580547970ad7753c914077faa8cde2f37b9f3c48cd5d1223f382b67992826017e8ab16353c7fd2b4749a0fbd615668c0a4c6ad638c26014 SHA512 2766cafa35c11da6f6d5d6129a5e39c09e73ca97f72382df757091198260a342d278c53f88cddf75e174231443c1015198dfa1800b3601d5b770553ec7047a00
DIST mate-menus-1.24.0.tar.xz 404028 BLAKE2B 18bea0a6c21444b0b568564d0c15ba0e231643dfcb9c74d6ab9a08cd57cab2289436dada030397737667f5a51c4ab39ab06fff3f585347ebb5f7afc40957acc0 SHA512 27f8ba0666b08fbcfc3f02a42e4b9f3d3431e3d171be0fe9569f412b2f9ead370fff15833feb920b64d2a067e81354970df2ee1c465f10faa3dbd9c97af20406
diff --git a/mate-base/mate-menus/files/10-xdg-menu-mate b/mate-base/mate-menus/files/10-xdg-menu-mate
deleted file mode 100644
index 06a6a91368e2..000000000000
--- a/mate-base/mate-menus/files/10-xdg-menu-mate
+++ /dev/null
@@ -1,6 +0,0 @@
-#!/bin/sh
-
-if [ -z "$XDG_MENU_PREFIX" ] && [ "$DESKTOP_SESSION" = "mate" ]
-then
- export XDG_MENU_PREFIX=mate-
-fi
diff --git a/mate-base/mate-menus/mate-menus-1.22.0-r1.ebuild b/mate-base/mate-menus/mate-menus-1.22.0-r1.ebuild
deleted file mode 100644
index c93dbf13c79c..000000000000
--- a/mate-base/mate-menus/mate-menus-1.22.0-r1.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-GNOME2_LA_PUNT="yes"
-
-inherit mate
-
-if [[ ${PV} != 9999 ]]; then
- KEYWORDS="~amd64 ~arm ~arm64 ~x86"
-fi
-
-DESCRIPTION="MATE menu system, implementing the F.D.O cross-desktop spec"
-LICENSE="GPL-2+ LGPL-2+ LGPL-2.1+"
-SLOT="0"
-
-IUSE="debug +introspection"
-
-COMMON_DEPEND=">=dev-libs/glib-2.50:2
- virtual/libintl
- introspection? ( >=dev-libs/gobject-introspection-0.6.7:= )"
-
-RDEPEND="${COMMON_DEPEND}"
-
-DEPEND="${COMMON_DEPEND}
- >=dev-util/intltool-0.40
- sys-devel/gettext:*
- virtual/pkgconfig:*"
-
-src_configure() {
- # Do NOT compile with --disable-debug/--enable-debug=no as it disables API
- # usage checks.
- mate_src_configure \
- --enable-debug=$(usex debug yes minimum) \
- $(use_enable introspection)
-}
-
-src_install() {
- mate_src_install
-
- exeinto /etc/X11/xinit/xinitrc.d/
- doexe "${FILESDIR}/10-xdg-menu-mate"
-}
diff --git a/mate-base/mate-menus/mate-menus-1.22.0.ebuild b/mate-base/mate-menus/mate-menus-1.22.0.ebuild
deleted file mode 100644
index cce14f63a6fc..000000000000
--- a/mate-base/mate-menus/mate-menus-1.22.0.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-GNOME2_LA_PUNT="yes"
-
-inherit mate
-
-if [[ ${PV} != 9999 ]]; then
- KEYWORDS="amd64 ~arm ~arm64 x86"
-fi
-
-DESCRIPTION="MATE menu system, implementing the F.D.O cross-desktop spec"
-LICENSE="GPL-2+ LGPL-2+ LGPL-2.1+"
-SLOT="0"
-
-IUSE="debug +introspection"
-
-COMMON_DEPEND=">=dev-libs/glib-2.50:2
- virtual/libintl
- introspection? ( >=dev-libs/gobject-introspection-0.6.7:= )"
-
-RDEPEND="${COMMON_DEPEND}"
-
-DEPEND="${COMMON_DEPEND}
- >=dev-util/intltool-0.40
- sys-devel/gettext:*
- virtual/pkgconfig:*"
-
-src_configure() {
- # Do NOT compile with --disable-debug/--enable-debug=no as it disables API
- # usage checks.
- mate_src_configure \
- --enable-debug=$(usex debug yes minimum) \
- $(use_enable introspection)
-}
-
-src_install() {
- mate_src_install
-
- exeinto /etc/X11/xinit/xinitrc.d/
- doexe "${FILESDIR}/10-xdg-menu-mate"
-}
-
-pkg_postinst() {
- mate_pkg_postinst
- einfo "Due to upstream bug"
- einfo "https://github.com/mate-desktop/mate-menus/issues/2,"
- einfo "it is highly recommended to run the following command"
- einfo "once you have logged in to your desktop for the first time:"
- einfo "cd ~/.config/menus && ln -s {,mate-}applications-merged"
-}