summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-analyzer/tcpreplay/Manifest1
-rw-r--r--net-analyzer/tcpreplay/tcpreplay-4.1.1.ebuild72
2 files changed, 0 insertions, 73 deletions
diff --git a/net-analyzer/tcpreplay/Manifest b/net-analyzer/tcpreplay/Manifest
index 2c20c65998bd..ba72adb43759 100644
--- a/net-analyzer/tcpreplay/Manifest
+++ b/net-analyzer/tcpreplay/Manifest
@@ -1,3 +1,2 @@
-DIST tcpreplay-4.1.1.tar.gz 2173781 SHA256 61b916ef91049cad2a9ddc8de6f5e3e3cc5d9998dbb644dc91cf3a798497ffe4 SHA512 6be88d3742b93fa557c9142eebe7ae2cf61a5436087f8400260472f87c1dd0d61515b338706afa1c850ae2380c0d5fa664691052d3dc01f3099ad068b67eee87 WHIRLPOOL ce1e4fe845ffbc019316f7a11249828d7b8c65afd9bfbff04950d0666aa79ee61e3bfd98d0870f820423cfb5b21e5274bf328cb4a020f290b0e7faa81297c544
DIST tcpreplay-4.1.2.tar.gz 2162175 SHA256 da483347e83a9b5df0e0dbb0f822a2d37236e79dda35f4bc4e6684fa827f25ea SHA512 3a7d125f38fe15070d666eacb4a5ef026a73ff850adec7ef3592966f38d1d155002792c5d5ac2476aa034d71be5f31b9dacd5be34af01a336149af3a42cad360 WHIRLPOOL e5ca80234655b3614eebd400954b53d958d08dbe91cf123db07935e5bebfb34ad40cd41a7a25a8d8ee684dbcaeda41c75a18503172830141dca022713b7814d6
DIST tcpreplay-4.2.0_beta2.tar.gz 2484518 SHA256 46e8b8c7b74c7d3aff7d3223f2ccd50a10baa9ee4b475333504a7523d5d57ce4 SHA512 e59b443dff1242dcf50bb9e68efcbaa79df8763192cb20853d3a41b5ba75d87717cf37b2e1227bd45807867442e27547950deb44aab784229b74cb51e4b9bae5 WHIRLPOOL 617d4a2b2739ddc77c7981ef72b7514ebeaf293f461ecb8dda7cbaf5930c16a6840a7ac83fcac41eb614de1a4f905019cbfe886a1c06243e4545c3d8c2cf8279
diff --git a/net-analyzer/tcpreplay/tcpreplay-4.1.1.ebuild b/net-analyzer/tcpreplay/tcpreplay-4.1.1.ebuild
deleted file mode 100644
index 5adf9557c30f..000000000000
--- a/net-analyzer/tcpreplay/tcpreplay-4.1.1.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-inherit autotools eutils flag-o-matic
-
-DESCRIPTION="a suite of utilities for editing and replaying previously captured network traffic"
-HOMEPAGE="http://tcpreplay.appneta.com/ https://github.com/appneta/tcpreplay"
-LICENSE="BSD GPL-3"
-SRC_URI="https://github.com/appneta/${PN}/releases/download/v${PV}/${P}.tar.gz"
-
-SLOT="0"
-KEYWORDS="amd64 ~sparc x86"
-IUSE="debug pcapnav +tcpdump"
-
-DEPEND="
- >=sys-devel/autogen-5.18.4[libopts]
- dev-libs/libdnet
- >=net-libs/libpcap-0.9
- tcpdump? ( net-analyzer/tcpdump )
- pcapnav? ( net-libs/libpcapnav )
-"
-
-RDEPEND="${DEPEND}"
-
-DOCS=( docs/{CHANGELOG,CREDIT,HACKING,TODO} )
-
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-4.1.0-enable-pcap_findalldevs.patch
-
- sed -i \
- -e 's|-O3||g' \
- -e 's|AM_CONFIG_HEADER|AC_CONFIG_HEADERS|g' \
- configure.ac || die
- sed -i \
- -e 's|#include <dnet.h>|#include <dnet/eth.h>|g' \
- src/common/sendpacket.c || die
- sed -i \
- -e 's|@\([A-Z_]*\)@|$(\1)|g' \
- -e '/tcpliveplay_CFLAGS/s|$| $(LDNETINC)|g' \
- -e '/tcpliveplay_LDADD/s|$| $(LDNETLIB)|g' \
- src/Makefile.am || die
-
- eautoreconf
-}
-
-src_configure() {
- # By default it uses static linking. Avoid that, bug 252940
- econf \
- $(use_enable debug) \
- $(use_with pcapnav pcapnav-config /usr/bin/pcapnav-config) \
- $(use_with tcpdump tcpdump /usr/sbin/tcpdump) \
- --disable-local-libopts \
- --enable-dynamic-link \
- --enable-shared \
- --with-libdnet \
- --with-testnic2=lo \
- --with-testnic=lo
-}
-
-src_test() {
- if [[ ! ${EUID} -eq 0 ]]; then
- ewarn "Some tests were disabled due to FEATURES=userpriv"
- ewarn "To run all tests issue the following command as root:"
- ewarn " # make -C ${S}/test"
- emake -j1 -C test tcpprep || die "self test failed - see ${S}/test/test.log"
- else
- emake -j1 test || {
- ewarn "Note, that some tests require eth0 iface to be UP." ;
- die "self test failed - see ${S}/test/test.log" ; }
- fi
-}