summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-print/cups-filters/Manifest1
-rw-r--r--net-print/cups-filters/cups-filters-1.21.4.ebuild137
2 files changed, 138 insertions, 0 deletions
diff --git a/net-print/cups-filters/Manifest b/net-print/cups-filters/Manifest
index 5131ace4663f..badb1d3539bd 100644
--- a/net-print/cups-filters/Manifest
+++ b/net-print/cups-filters/Manifest
@@ -2,3 +2,4 @@ DIST cups-filters-1.17.9.tar.xz 1454068 BLAKE2B 7c4b1c1a017cbaaf5d413071195ce53e
DIST cups-filters-1.20.4.tar.xz 1474700 BLAKE2B 70948565e4a2b35d0c3bc510e7c03d77ac1ed47ab16a22bc9f60a7293fe5b5b08fdb1e95dd7a32f4c99a18676e50c48a515a954d437283ce7011ab616804e235 SHA512 4001cefbee945c326e3c597869763286e8665dee098b9aff76340dd249ef3e615f2a8df5c8e802e388b91dfd06ba9e8313b27908ca89ca120f899060785a6f07
DIST cups-filters-1.21.2.tar.xz 1473008 BLAKE2B fea7f0f92464f5e95f57f71b6f6bb5acc9cd6ccb8c97a6a54a40be4f462b76603879f85c9ae0a0c5f47d113e6de9642ee9707d7af1b5cf93f3c47a619db2be55 SHA512 07672737108e1593374fa95582e2c8ad7a3fec6202846ba85224c1c89f65b7b89de96ebf67841ec5d948fe556dddd06ae6a58ad6c5c0a25a82ce643c9384aaf0
DIST cups-filters-1.21.3.tar.xz 1474152 BLAKE2B 7e5193b6d6989675fa9567cb76b7f29f411b28e251ff9c6fd8fafec9c9c3d914f21d7e51eb562820954b3cee70974c5a55351eb08a1f231fe820513a2ce92644 SHA512 2b00023ac4177046e3ab3c5b563b7bd92bb49e57e645e6e67e7b9358d00919e2d4ca43ef5d57684523d97f1f1df5d1014fc0a3a895476ce285ccb3ed2e3bc758
+DIST cups-filters-1.21.4.tar.xz 1474564 BLAKE2B 10a9ac9133ebefe1e04f329d1ce3ad1a30c4c1922a31e9af10fa26b3d8401753e1f1b66ef4c2869d4a7329af440e6da8c883bc00fddf614af1716a9d9cb83f4f SHA512 6e1e20be0354ba96cf4222c05aadd4a2b3d033d730ff9b7489ba6a3b2b0e1a02ac80a1ebcf5e765b80e5baab2ae0c091c8abbdf159913b70592fb9ba0afd9a5b
diff --git a/net-print/cups-filters/cups-filters-1.21.4.ebuild b/net-print/cups-filters/cups-filters-1.21.4.ebuild
new file mode 100644
index 000000000000..bf15e18628e9
--- /dev/null
+++ b/net-print/cups-filters/cups-filters-1.21.4.ebuild
@@ -0,0 +1,137 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+GENTOO_DEPEND_ON_PERL=no
+
+inherit perl-module systemd flag-o-matic
+
+if [[ "${PV}" == "9999" ]] ; then
+ inherit bzr autotools
+ EBZR_REPO_URI="http://bzr.linuxfoundation.org/openprinting/cups-filters"
+else
+ SRC_URI="http://www.openprinting.org/download/${PN}/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-fbsd ~m68k-mint"
+fi
+DESCRIPTION="Cups filters"
+HOMEPAGE="https://wiki.linuxfoundation.org/openprinting/cups-filters"
+
+LICENSE="MIT GPL-2"
+SLOT="0"
+IUSE="dbus +foomatic ipp_autosetup jpeg ldap pclm pdf perl png +postscript static-libs test tiff zeroconf"
+
+RDEPEND="
+ >=app-text/poppler-0.32:=[cxx,jpeg?,lcms,tiff?,utils]
+ >=app-text/qpdf-8.1.0:=
+ dev-libs/glib:2
+ media-libs/fontconfig
+ media-libs/freetype:2
+ media-libs/lcms:2
+ >=net-print/cups-1.7.3
+ !<=net-print/cups-1.5.9999
+ sys-devel/bc
+ sys-libs/zlib
+ dbus? ( sys-apps/dbus )
+ foomatic? ( !net-print/foomatic-filters )
+ jpeg? ( virtual/jpeg:0 )
+ ldap? ( net-nds/openldap )
+ pclm? ( >=app-text/qpdf-8.1.0:= )
+ pdf? ( app-text/mupdf )
+ perl? ( dev-lang/perl:= )
+ png? ( media-libs/libpng:0= )
+ postscript? ( >=app-text/ghostscript-gpl-9.09[cups] )
+ tiff? ( media-libs/tiff:0 )
+ zeroconf? ( net-dns/avahi[dbus] )
+"
+DEPEND="${RDEPEND}
+ dev-util/gdbus-codegen
+ test? ( media-fonts/dejavu )
+"
+
+src_prepare() {
+ default
+ [[ "${PV}" == "9999" ]] && eautoreconf
+
+ # Bug #626800
+ append-cxxflags -std=c++11
+}
+
+src_configure() {
+ local myeconfargs=(
+ --docdir="${EPREFIX}/usr/share/doc/${PF}"
+ --enable-imagefilters
+ --localstatedir="${EPREFIX}"/var
+ --with-browseremoteprotocols=DNSSD,CUPS
+ --with-cups-rundir="${EPREFIX}"/run/cups
+ --with-fontdir="fonts/conf.avail"
+ --with-pdftops=pdftops
+ --with-rcdir=no
+ --without-php
+ $(use_enable dbus)
+ $(use_enable foomatic)
+ $(use_enable ipp_autosetup auto-setup-driverless)
+ $(use_enable ldap)
+ $(use_enable pclm)
+ $(use_enable pdf mutool)
+ $(use_enable postscript ghostscript)
+ $(use_enable postscript ijs)
+ $(use_enable static-libs static)
+ $(use_enable zeroconf avahi)
+ $(use_with jpeg)
+ $(use_with png)
+ $(use_with tiff)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+ default
+
+ if use perl; then
+ pushd "${S}/scripting/perl" > /dev/null
+ perl-module_src_configure
+ perl-module_src_compile
+ popd > /dev/null
+ fi
+}
+
+src_install() {
+ default
+
+ if use perl; then
+ pushd "${S}/scripting/perl" > /dev/null
+ perl-module_src_install
+ perl_delete_localpod
+ popd > /dev/null
+ fi
+
+ if use postscript; then
+ # workaround: some printer drivers still require pstoraster and pstopxl, bug #383831
+ dosym gstoraster /usr/libexec/cups/filter/pstoraster
+ dosym gstopxl /usr/libexec/cups/filter/pstopxl
+ fi
+
+ find "${ED}" \( -name "*.a" -o -name "*.la" \) -delete || die
+
+ cp "${FILESDIR}"/cups-browsed.init.d-r1 "${T}"/cups-browsed || die
+
+ if ! use zeroconf ; then
+ sed -i -e 's:need cupsd avahi-daemon:need cupsd:g' "${T}"/cups-browsed || die
+ sed -i -e 's:cups\.service avahi-daemon\.service:cups.service:g' "${S}"/utils/cups-browsed.service || die
+ fi
+
+ doinitd "${T}"/cups-browsed
+ systemd_dounit "${S}/utils/cups-browsed.service"
+}
+
+src_test() {
+ emake check
+}
+
+pkg_postinst() {
+ if ! use foomatic ; then
+ ewarn "You are disabling the foomatic code in cups-filters. Please do that ONLY if absolutely."
+ ewarn "necessary. net-print/foomatic-filters as replacement is deprecated and unmaintained."
+ fi
+}