summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-accessibility/nfbtrans/nfbtrans-7.74-r1.ebuild')
-rw-r--r--app-accessibility/nfbtrans/nfbtrans-7.74-r1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/app-accessibility/nfbtrans/nfbtrans-7.74-r1.ebuild b/app-accessibility/nfbtrans/nfbtrans-7.74-r1.ebuild
new file mode 100644
index 000000000000..24ddfb1f2fdd
--- /dev/null
+++ b/app-accessibility/nfbtrans/nfbtrans-7.74-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+
+inherit eutils
+
+DESCRIPTION="braille translator from the National Federation of the Blind"
+HOMEPAGE="http://www.nfb.org/nfbtrans"
+SRC_URI="http://www.nfb.org/Images/nfb/Products_Technology/nfbtr774.zip"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE=""
+
+DEPEND=" >=app-arch/unzip-5.50-r2"
+RDEPEND=""
+
+S=${WORKDIR}
+
+src_prepare() {
+ mv MAKEFILE Makefile
+ mv SPANISH.ZIP spanish.zip
+ make lowercase || die
+ epatch "${FILESDIR}"/${P}-gentoo-fix.patch
+ epatch "${FILESDIR}"/${P}-getline-fix.patch
+}
+
+src_compile() {
+ make CC=$(tc-getCC) \
+ LIBS= \
+ CFLAGS="${CFLAGS} -DLINUX" LDFLAGS="${LDFLAGS}" all || die
+}
+
+src_install() {
+ dobin nfbtrans || die
+ dodoc *fmt readme.txt makedoc
+ insinto /etc/nfbtrans
+ doins *cnf *tab *dic spell.dat *zip
+}