summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-accessibility')
-rw-r--r--app-accessibility/accerciser/Manifest1
-rw-r--r--app-accessibility/accerciser/accerciser-3.22.0.ebuild65
2 files changed, 66 insertions, 0 deletions
diff --git a/app-accessibility/accerciser/Manifest b/app-accessibility/accerciser/Manifest
index 5275c03872c3..45c24a25d87b 100644
--- a/app-accessibility/accerciser/Manifest
+++ b/app-accessibility/accerciser/Manifest
@@ -1 +1,2 @@
DIST accerciser-3.14.0.tar.xz 3213916 SHA256 f5a5915d475e9241396414ccd167724c88807e77e69151cf0b40b32bd57d0574 SHA512 bafc30e15fe0121f8abc64239e48834ab06a03fe64fc368a221d167a13079721962441e0343f17934dde57cd012c9132374739297c23c79c567fc36cc60fb07d WHIRLPOOL 4b9679145ad1ad7f8d059dfdfb12d372c1b27780532a7c19cc25b66bbe0a13db5b864548e332b74e0327eebb488622ae471514046737b738c15624969d8df7a8
+DIST accerciser-3.22.0.tar.xz 3060756 SHA256 883306274442c7ecc076b24afca5190c835c40871ded1b9790da69347e9ca3c5 SHA512 980db5dcd0bdc78314ab87cce95cfcfa018bf302acc66ea2dd1bddfb61de5bfe2e64344cff63740c38be33124ff49c75699aa6867d5e85b25d422b5af1b025c1 WHIRLPOOL b30adca45e02d5fb684adbbbb4a3b608d8703fad0e5e5b9ed690f339419792e3bcd9ef486ca4508ceb7c870ae227243b383daf3cac0af1f6bc39323f0c28b1ef
diff --git a/app-accessibility/accerciser/accerciser-3.22.0.ebuild b/app-accessibility/accerciser/accerciser-3.22.0.ebuild
new file mode 100644
index 000000000000..02899c5ed220
--- /dev/null
+++ b/app-accessibility/accerciser/accerciser-3.22.0.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python{3_4,3_5} )
+PYTHON_REQ_USE="xml"
+
+inherit gnome2 python-r1
+
+DESCRIPTION="Interactive Python accessibility explorer"
+HOMEPAGE="https://wiki.gnome.org/Apps/Accerciser"
+
+LICENSE="BSD CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ >=app-accessibility/at-spi2-core-2.5.2:2
+ >=dev-python/pygobject-2.90.3:3[${PYTHON_USEDEP}]
+ >=x11-libs/gtk+-3.1.13:3[introspection]
+
+ dev-libs/atk[introspection]
+ >=dev-libs/glib-2.28:2
+ dev-libs/gobject-introspection:=
+ >=dev-python/ipython-0.11[${PYTHON_USEDEP}]
+ >=dev-python/pyatspi-2.1.5[${PYTHON_USEDEP}]
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ x11-libs/gdk-pixbuf[introspection]
+ x11-libs/libwnck:3[introspection]
+ x11-libs/pango[introspection]
+ ${PYTHON_DEPS}
+"
+DEPEND="${RDEPEND}
+ app-text/yelp-tools
+ >=dev-util/intltool-0.35
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # Leave shebang alone
+ sed 's:@PYTHON@:/usr/bin/python:' -i src/accerciser.in || die
+
+ python_copy_sources
+}
+
+src_configure() {
+ python_foreach_impl run_in_build_dir gnome2_src_configure
+}
+
+src_compile() {
+ python_foreach_impl run_in_build_dir gnome2_src_compile
+}
+
+src_install() {
+ installing() {
+ gnome2_src_install
+ python_doscript src/accerciser
+ }
+ python_foreach_impl run_in_build_dir installing
+}