summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/abrt/files')
-rw-r--r--app-admin/abrt/files/abrt-2.0.12-automake-1.12.patch64
-rw-r--r--app-admin/abrt/files/abrt-2.0.12-dbus-fallback.patch111
-rw-r--r--app-admin/abrt/files/abrt-2.0.12-gentoo.patch398
-rw-r--r--app-admin/abrt/files/abrt-2.0.12-r1-conf27
-rw-r--r--app-admin/abrt/files/abrt-2.0.12-r1-init77
-rw-r--r--app-admin/abrt/files/abrt-2.0.6-format-security.patch27
6 files changed, 704 insertions, 0 deletions
diff --git a/app-admin/abrt/files/abrt-2.0.12-automake-1.12.patch b/app-admin/abrt/files/abrt-2.0.12-automake-1.12.patch
new file mode 100644
index 000000000000..e2723067cb6e
--- /dev/null
+++ b/app-admin/abrt/files/abrt-2.0.12-automake-1.12.patch
@@ -0,0 +1,64 @@
+From 00704d4eb30dd12d6f4fcf97320c354ed3eacfa7 Mon Sep 17 00:00:00 2001
+From: Alexandre Rostovtsev <tetromino@gentoo.org>
+Date: Sat, 22 Sep 2012 05:50:38 -0400
+Subject: [PATCH] Fix automake-1.12 autoreconf issues
+
+Need -Wno-portablity for '%'-style pattern rules in doc/Makefile.am and
+':='-style assignments and $(wildcard *~) in src/hooks/Makefile.am.
+
+Need AM_PROG_CC_C_O for src/applet/applet.c
+
+gettext-0.18.1.1's AM_GNU_GETTEXT requires AM_PROG_MKDIR_P, causing
+problems for automake-1.12.
+---
+ configure.ac | 8 +++-----
+ src/daemon/Makefile.am | 2 +-
+ 2 files changed, 4 insertions(+), 6 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index a78d9f8..42acccf 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -3,7 +3,7 @@ AC_INIT([abrt],
+ [crash-catcher@fedorahosted.org])
+
+ AC_CONFIG_MACRO_DIR([m4])
+-AM_INIT_AUTOMAKE([-Wall -Werror foreign])
++AM_INIT_AUTOMAKE([-Wall -Wno-portability -Werror foreign])
+ # Support silent build rules. Disable by either passing --disable-silent-rules
+ # to ./configure or passing V=1 to make
+ m4_ifdef([AM_SILENT_RULES], [AM_SILENT_RULES])
+@@ -12,8 +12,9 @@ AM_SILENT_RULES([yes])
+
+
+ AC_DISABLE_STATIC
++AM_PROG_AR
+ AC_PROG_LIBTOOL
+-AC_PROG_CC
++AM_PROG_CC_C_O
+ AC_PROG_LN_S
+
+ AC_SYS_LARGEFILE
+@@ -30,9 +31,6 @@ GETTEXT_PACKAGE=abrt
+ AC_SUBST(GETTEXT_PACKAGE)
+ AC_DEFINE_UNQUOTED(GETTEXT_PACKAGE, "$GETTEXT_PACKAGE", [Package name for gettext])
+
+-AM_GNU_GETTEXT([external])
+-AM_GNU_GETTEXT_VERSION([0.17])
+-
+ IT_PROG_INTLTOOL([0.35.0])
+
+ dnl ****** END ****************************************
+diff --git a/src/daemon/Makefile.am b/src/daemon/Makefile.am
+index 777dfc4..5a5f0ea 100644
+--- a/src/daemon/Makefile.am
++++ b/src/daemon/Makefile.am
+@@ -63,4 +63,4 @@ EXTRA_DIST = abrt-handle-upload
+ DEFS = -DLOCALEDIR=\"$(localedir)\" @DEFS@
+
+ install-data-local:
+- $(mkdir_p) '$(DESTDIR)/$(VAR_RUN)'
++ $(MKDIR_P) '$(DESTDIR)/$(VAR_RUN)'
+--
+1.7.12
+
diff --git a/app-admin/abrt/files/abrt-2.0.12-dbus-fallback.patch b/app-admin/abrt/files/abrt-2.0.12-dbus-fallback.patch
new file mode 100644
index 000000000000..e15731bbf04c
--- /dev/null
+++ b/app-admin/abrt/files/abrt-2.0.12-dbus-fallback.patch
@@ -0,0 +1,111 @@
+From 3ddf2f38a47c7cc13dd6f480841b9b90f6304ed4 Mon Sep 17 00:00:00 2001
+From: Denys Vlasenko <vda.linux@googlemail.com>
+Date: Mon, 3 Sep 2012 19:01:24 +0200
+Subject: [PATCH] abrt-gui: fall back to direct access if dbus access fails.
+ Closes #484
+
+It looks like this:
+
+root> abrt-gui
+Can't connect to system DBus: Error connecting: No such file or directory
+Error in DBus communication, falling back to direct access to '/var/spool/abrt'
+
+Signed-off-by: Denys Vlasenko <vda.linux@googlemail.com>
+---
+ src/gui-gtk/main.c | 44 +++++++++++++++++++++++++++-----------------
+ src/lib/problem_api.c | 5 +++--
+ 2 files changed, 30 insertions(+), 19 deletions(-)
+
+diff --git a/src/gui-gtk/main.c b/src/gui-gtk/main.c
+index 2cc4bef..e6e8ef0 100644
+--- a/src/gui-gtk/main.c
++++ b/src/gui-gtk/main.c
+@@ -252,23 +252,6 @@ static void add_directory_to_dirlist(const char *problem_dir_path, gpointer data
+ VERB1 log("added: %s", problem_dir_path);
+ }
+
+-static void query_dbus_and_add_to_dirlist(void)
+-{
+- GList *problem_dirs = get_problems_over_dbus(g_authorize);
+-
+- if (problem_dirs)
+- {
+- g_list_foreach(problem_dirs, (GFunc)add_directory_to_dirlist, /*use_dbus:*/ (void*)true);
+- list_free_with_free(problem_dirs);
+- }
+-
+- /* HACK ALERT! We "magically know" that dbus-reported problem dirs
+- * live in g_settings_dump_location.
+- * Notifications on changes should be implemented to go over dbus too.
+- */
+- watch_this_dir(g_settings_dump_location);
+-}
+-
+ static void scan_directory_and_add_to_dirlist(const char *path)
+ {
+ DIR *dp = opendir(path);
+@@ -296,6 +279,33 @@ static void scan_directory_and_add_to_dirlist(const char *path)
+ watch_this_dir(path);
+ }
+
++static void query_dbus_and_add_to_dirlist(void)
++{
++ GList *problem_dirs = get_problems_over_dbus(g_authorize);
++
++ if (problem_dirs == ERR_PTR)
++ {
++ /* One way to trigger this is to temporarily rename
++ * dbus socket (/var/run/dbus/system_bus_socket)
++ */
++ error_msg("Error in DBus communication, falling back to direct access to '%s'", g_settings_dump_location);
++ scan_directory_and_add_to_dirlist(g_settings_dump_location);
++ return;
++ }
++
++ if (problem_dirs)
++ {
++ g_list_foreach(problem_dirs, (GFunc)add_directory_to_dirlist, /*use_dbus:*/ (void*)true);
++ list_free_with_free(problem_dirs);
++ }
++
++ /* HACK ALERT! We "magically know" that dbus-reported problem dirs
++ * live in g_settings_dump_location.
++ * Notifications on changes should be implemented to go over dbus too.
++ */
++ watch_this_dir(g_settings_dump_location);
++}
++
+ static void scan_dirs_and_add_to_dirlist(void)
+ {
+ if (!(g_opts & OPT_D))
+diff --git a/src/lib/problem_api.c b/src/lib/problem_api.c
+index b9967e8..04f4069 100644
+--- a/src/lib/problem_api.c
++++ b/src/lib/problem_api.c
+@@ -144,7 +144,7 @@ GList *get_problems_over_dbus(bool authorize)
+ {
+ GDBusProxy *proxy = get_dbus_proxy();
+ if (!proxy)
+- return NULL;
++ return ERR_PTR;
+
+ GError *error = NULL;
+ GVariant *result = g_dbus_proxy_call_sync(proxy,
+@@ -159,6 +159,7 @@ GList *get_problems_over_dbus(bool authorize)
+ {
+ error_msg(_("Can't get problem list from abrt-dbus: %s"), error->message);
+ g_error_free(error);
++ return ERR_PTR;
+ }
+
+ GList *list = NULL;
+@@ -172,4 +173,4 @@ GList *get_problems_over_dbus(bool authorize)
+ }
+
+ return list;
+-}
+\ No newline at end of file
++}
+--
+1.7.12
+
diff --git a/app-admin/abrt/files/abrt-2.0.12-gentoo.patch b/app-admin/abrt/files/abrt-2.0.12-gentoo.patch
new file mode 100644
index 000000000000..0aa4267910e6
--- /dev/null
+++ b/app-admin/abrt/files/abrt-2.0.12-gentoo.patch
@@ -0,0 +1,398 @@
+From 1f56956ade3bd28ef192fba675e798db58b3ae40 Mon Sep 17 00:00:00 2001
+From: Alexandre Rostovtsev <tetromino@gentoo.org>
+Date: Sat, 22 Sep 2012 05:45:28 -0400
+Subject: [PATCH] Disable code not relevant for Gentoo
+
+Disable code that is only relevant for an RPM-based distro or that
+requires additional bugs.gentoo.org infrastructure support. Ensure that
+crashes still get analyzed even if they cannot be assigned to any
+package (since we lack any way of doing that at the moment).
+---
+ configure.ac | 1 -
+ doc/Makefile.am | 2 --
+ src/daemon/Makefile.am | 18 ----------
+ src/daemon/abrt_event.conf | 14 +++++---
+ src/plugins/Makefile.am | 71 +------------------------------------
+ src/plugins/abrt-action-list-dsos | 18 +++-------
+ src/plugins/ccpp_event.conf | 29 +--------------
+ src/plugins/ccpp_retrace_event.conf | 8 +----
+ src/plugins/koops_event.conf | 15 --------
+ src/plugins/python_event.conf | 16 ---------
+ src/plugins/xorg_event.conf | 2 +-
+ 11 files changed, 17 insertions(+), 177 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index bb2b986..a78d9f8 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -79,7 +79,6 @@ PKG_CHECK_MODULES([GTK], [gtk+-3.0])
+ PKG_CHECK_MODULES([GLIB], [glib-2.0 >= 2.21])
+ PKG_CHECK_MODULES([DBUS], [dbus-1])
+ PKG_CHECK_MODULES([LIBXML], [libxml-2.0])
+-PKG_CHECK_MODULES([RPM], [rpm])
+ PKG_CHECK_MODULES([LIBNOTIFY], [libnotify])
+ PKG_CHECK_MODULES([NSS], [nss])
+ PKG_CHECK_MODULES([BTPARSER], [btparser])
+diff --git a/doc/Makefile.am b/doc/Makefile.am
+index 0a829d4..33cc8e6 100644
+--- a/doc/Makefile.am
++++ b/doc/Makefile.am
+@@ -16,11 +16,9 @@ MAN1_TXT += abrt-cli.txt
+ MAN1_TXT += abrt-action-save-package-data.txt
+ MAN1_TXT += abrt-install-ccpp-hook.txt
+ MAN1_TXT += abrt-action-analyze-vmcore.txt
+-MAN1_TXT += abrt-bodhi.txt
+
+ MAN5_TXT =
+ MAN5_TXT += abrt.conf.txt
+-MAN5_TXT += abrt-action-save-package-data.conf.txt
+
+ MAN8_TXT =
+ MAN8_TXT += abrtd.txt abrt-dbus.txt
+diff --git a/src/daemon/Makefile.am b/src/daemon/Makefile.am
+index 2e24403..777dfc4 100644
+--- a/src/daemon/Makefile.am
++++ b/src/daemon/Makefile.am
+@@ -6,9 +6,6 @@ dist_eventsconf_DATA = \
+ bin_SCRIPTS = \
+ abrt-handle-upload
+
+-bin_PROGRAMS = \
+- abrt-action-save-package-data
+-
+ sbin_PROGRAMS = \
+ abrtd \
+ abrt-server
+@@ -55,21 +52,6 @@ abrt_handle_event_LDADD = \
+ $(LIBREPORT_LIBS) \
+ $(BTPARSER_LIBS)
+
+-abrt_action_save_package_data_SOURCES = \
+- rpm.h rpm.c \
+- abrt-action-save-package-data.c
+-abrt_action_save_package_data_CPPFLAGS = \
+- -I$(srcdir)/../include \
+- -I$(srcdir)/../lib \
+- -DCONF_DIR=\"$(CONF_DIR)\" \
+- $(GLIB_CFLAGS) \
+- $(LIBREPORT_CFLAGS) \
+- -D_GNU_SOURCE
+-abrt_action_save_package_data_LDADD = \
+- $(RPM_LIBS) \
+- $(LIBREPORT_LIBS) \
+- ../lib/libabrt.la
+-
+ daemonconfdir = $(CONF_DIR)
+ dist_daemonconf_DATA = \
+ abrt.conf \
+diff --git a/src/daemon/abrt_event.conf b/src/daemon/abrt_event.conf
+index a1411e4..aab7dc0 100644
+--- a/src/daemon/abrt_event.conf
++++ b/src/daemon/abrt_event.conf
+@@ -44,7 +44,7 @@
+
+
+ # Determine in which package/component the crash happened (if not yet done):
+-EVENT=post-create component= remote!=1
++#EVENT=post-create component= remote!=1
+ abrt-action-save-package-data
+
+
+@@ -60,19 +60,19 @@ EVENT=post-create
+ if [ -f uid ]; then getent passwd "`cat uid`" | cut -d: -f1 >username; fi
+
+
+-EVENT=notify package!= uid!=
++EVENT=notify uid!=
+ dbus-send --system --type=signal /com/redhat/abrt com.redhat.abrt.Crash \
+ string:"`cat package`" string:"$DUMP_DIR" string:"`cat uid`"
+
+-EVENT=notify package!= uid=
++EVENT=notify uid=
+ dbus-send --system --type=signal /com/redhat/abrt com.redhat.abrt.Crash \
+ string:"`cat package`" string:"$DUMP_DIR"
+
+-EVENT=notify-dup package!= uid!=
++EVENT=notify-dup uid!=
+ dbus-send --system --type=signal /com/redhat/abrt com.redhat.abrt.Crash \
+ string:"`cat package`" string:"$DUMP_DIR" string:"`cat uid`"
+
+-EVENT=notify-dup package!= uid=
++EVENT=notify-dup uid=
+ dbus-send --system --type=signal /com/redhat/abrt com.redhat.abrt.Crash \
+ string:"`cat package`" string:"$DUMP_DIR"
+
+@@ -108,6 +108,10 @@ EVENT=notify-dup package!= uid=
+ #EVENT=post-create
+ reporter-upload -u scp://user:password@server.name/var/spool/abrt-upload || :
+
++#report-gui event is used for reporting by abrt-applet and abrt-gui
++
++EVENT=report-gui analyzer=CCpp
++ report-gtk -e analyze_LocalGDB -e report_Logger -- "$DUMP_DIR"
+
+ #open-gui event is used by abrt-gui's "Edit"->"Open problem data"
+
+diff --git a/src/plugins/Makefile.am b/src/plugins/Makefile.am
+index 10ab579..f0248b1 100644
+--- a/src/plugins/Makefile.am
++++ b/src/plugins/Makefile.am
+@@ -1,7 +1,6 @@
+ -include ../../config.mak
+
+ bin_SCRIPTS = \
+- abrt-action-install-debuginfo \
+ abrt-action-analyze-core \
+ abrt-action-analyze-vmcore \
+ abrt-action-list-dsos
+@@ -16,12 +15,7 @@ bin_PROGRAMS = \
+ abrt-action-trim-files \
+ abrt-action-generate-backtrace \
+ abrt-action-generate-core-backtrace \
+- abrt-action-analyze-backtrace \
+- abrt-retrace-client \
+- abrt-dedup-client \
+- abrt-bodhi
+-
+-libexec_PROGRAMS = abrt-action-install-debuginfo-to-abrt-cache
++ abrt-action-analyze-backtrace
+
+ #dist_pluginsconf_DATA = Python.conf
+
+@@ -44,7 +38,6 @@ eventsconfdir = $(EVENTS_CONF_DIR)
+
+ dist_eventsconf_DATA = \
+ ccpp_event.conf \
+- ccpp_retrace_event.conf \
+ koops_event.conf \
+ xorg_event.conf \
+ vmcore_event.conf \
+@@ -56,7 +49,6 @@ dist_eventsconf_DATA = \
+
+
+ PYTHON_FILES = \
+- abrt-action-install-debuginfo.in \
+ abrt-action-list-dsos \
+ abrt-action-analyze-core \
+ abrt-action-analyze-vmcore.in
+@@ -69,7 +61,6 @@ EXTRA_DIST = \
+ collect_vimrc_user.xml.in \
+ collect_vimrc_system.xml.in \
+ analyze_LocalGDB.xml.in \
+- analyze_RetraceServer.xml.in \
+ analyze_VMcore.xml.in \
+ abrt-action-analyze-vmcore \
+ https-utils.h \
+@@ -204,64 +195,4 @@ abrt_action_analyze_backtrace_LDADD = \
+ $(LIBREPORT_LIBS) \
+ $(BTPARSER_LIBS)
+
+-abrt_action_install_debuginfo_to_abrt_cache_SOURCES = \
+- abrt-action-install-debuginfo-to-abrt-cache.c
+-abrt_action_install_debuginfo_to_abrt_cache_CPPFLAGS = \
+- -I$(srcdir)/../include \
+- -I$(srcdir)/../lib \
+- -D_GNU_SOURCE \
+- $(LIBREPORT_CFLAGS) \
+- -Wall -Wwrite-strings
+-abrt_action_install_debuginfo_to_abrt_cache_LDADD = \
+- $(LIBREPORT_LIBS) \
+- ../lib/libabrt.la
+-
+-abrt_retrace_client_SOURCES = \
+- abrt-retrace-client.c \
+- https-utils.c
+- abrt_retrace_client_CFLAGS = \
+- -I$(srcdir)/../include \
+- -I$(srcdir)/../lib \
+- $(NSS_CFLAGS) \
+- $(GLIB_CFLAGS) \
+- -D_GNU_SOURCE \
+- $(LIBREPORT_CFLAGS)
+- abrt_retrace_client_LDADD = \
+- $(LIBREPORT_LIBS) \
+- $(BTPARSER_LIBS) \
+- $(NSS_LIBS)
+-
+-abrt_dedup_client_SOURCES = \
+- abrt-dedup-client.c \
+- https-utils.c
+- abrt_dedup_client_CFLAGS = \
+- -I$(srcdir)/../include \
+- -I$(srcdir)/../lib \
+- $(NSS_CFLAGS) \
+- $(GLIB_CFLAGS) \
+- -D_GNU_SOURCE \
+- $(LIBREPORT_CFLAGS)
+- abrt_dedup_client_LDADD = \
+- $(LIBREPORT_LIBS) \
+- $(BTPARSER_LIBS) \
+- $(NSS_LIBS)
+-
+-abrt_bodhi_SOURCES = \
+- bodhi.c
+- abrt_bodhi_CPPFLAGS = \
+- -I$(srcdir)/../include \
+- -I$(srcdir)/../lib \
+- $(GLIB_CFLAGS) \
+- $(LIBREPORT_CFLAGS) \
+- $(LIBREPORT_WEB_CFLAGS) \
+- $(JSON_C_CFLAGS) \
+- $(RPM_CFLAGS) \
+- -D_GNU_SOURCE
+- abrt_bodhi_LDADD = \
+- $(JSON_C_LIBS) \
+- $(RPM_LIBS) \
+- $(LIBREPORT_LIBS) \
+- $(LIBREPORT_WEB_LIBS)
+-
+-
+ DEFS = -DLOCALEDIR=\"$(localedir)\" @DEFS@
+diff --git a/src/plugins/abrt-action-list-dsos b/src/plugins/abrt-action-list-dsos
+index 81a9927..bf1491c 100644
+--- a/src/plugins/abrt-action-list-dsos
++++ b/src/plugins/abrt-action-list-dsos
+@@ -5,7 +5,6 @@
+ import sys
+ import os
+ import getopt
+-import rpm
+
+ def log(s):
+ sys.stderr.write("%s\n" % s)
+@@ -68,19 +67,10 @@ if __name__ == "__main__":
+ try:
+ dso_paths = parse_maps(memfile)
+ for path in dso_paths:
+- ts = rpm.TransactionSet()
+- mi = ts.dbMatch('basenames', path)
+- if len(mi):
+- for h in mi:
+- if outname:
+- outfile = xopen(outname, "w")
+- outname = None
+- outfile.write("%s %s (%s) %s\n" %
+- (path,
+- h[rpm.RPMTAG_NEVRA],
+- h[rpm.RPMTAG_VENDOR],
+- h[rpm.RPMTAG_INSTALLTIME])
+- )
++ if outname:
++ outfile = xopen(outname, "w")
++ outname = None
++ outfile.write(path)
+
+ except Exception, ex:
+ error_msg_and_die("Can't get the DSO list: %s" % ex)
+diff --git a/src/plugins/ccpp_event.conf b/src/plugins/ccpp_event.conf
+index 81b14d2..cda0b7d 100644
+--- a/src/plugins/ccpp_event.conf
++++ b/src/plugins/ccpp_event.conf
+@@ -31,31 +31,4 @@ EVENT=collect_xsession_errors analyzer=CCpp dso_list~=.*/libX11.*
+ # or was this ability lost with move to python installer?
+ EVENT=analyze_LocalGDB analyzer=CCpp
+ abrt-action-analyze-core --core=coredump -o build_ids &&
+- /usr/libexec/abrt-action-install-debuginfo-to-abrt-cache --size_mb=4096 &&
+- abrt-action-generate-backtrace &&
+- abrt-action-analyze-backtrace &&
+- (
+- bug_id=$(reporter-bugzilla -h `cat duphash`) &&
+- if test -n "$bug_id"; then
+- abrt-bodhi -r -b $bug_id
+- fi
+- )
+-
+-
+-# Bugzilla requires nonempty duphash
+-EVENT=report_Bugzilla analyzer=CCpp duphash!=
+- abrt-dedup-client
+- test -f component || abrt-action-save-package-data
+- reporter-bugzilla -b -c /etc/libreport/plugins/bugzilla.conf
+-
+-# Send micro report
+-EVENT=report_uReport analyzer=CCpp
+- reporter-ureport
+-
+-# update ABRT database after successful report to bugzilla
+-EVENT=post_report analyzer=CCpp
+- reporter-ureport -r
+-
+-# Reporting of C/Cpp problems
+-EVENT=report-gui analyzer=CCpp
+- report-gtk -e report_uReport -e analyze_RetraceServer -e report_Bugzilla -e post_report -- "$DUMP_DIR"
++ abrt-action-generate-backtrace
+diff --git a/src/plugins/ccpp_retrace_event.conf b/src/plugins/ccpp_retrace_event.conf
+index 60e53d7..893502f 100644
+--- a/src/plugins/ccpp_retrace_event.conf
++++ b/src/plugins/ccpp_retrace_event.conf
+@@ -1,9 +1,3 @@
+ EVENT=analyze_RetraceServer analyzer=CCpp
+ abrt-retrace-client batch --dir "$DUMP_DIR" --status-delay 10 &&
+- abrt-action-analyze-backtrace &&
+- (
+- bug_id=$(reporter-bugzilla -h `cat duphash`) &&
+- if test -n "$bug_id"; then
+- abrt-bodhi -r -b $bug_id
+- fi
+- )
++ abrt-action-analyze-backtrace
+diff --git a/src/plugins/koops_event.conf b/src/plugins/koops_event.conf
+index 91759b1..41708df 100644
+--- a/src/plugins/koops_event.conf
++++ b/src/plugins/koops_event.conf
+@@ -14,18 +14,3 @@ EVENT=post-create analyzer=Kerneloops
+ # report
+ #EVENT=report_Kerneloops analyzer=Kerneloops
+ reporter-kerneloops
+-
+-EVENT=report_Bugzilla analyzer=Kerneloops
+- reporter-bugzilla -b
+-
+-# Send micro report
+-EVENT=report_uReport analyzer=Kerneloops
+- reporter-ureport
+-
+-# update ABRT database after successful report to bugzilla
+-EVENT=post_report analyzer=Kerneloops
+- reporter-ureport -r
+-
+-# Reporting of kernel oopses
+-EVENT=report-gui analyzer=Kerneloops
+- report-gtk -e report_uReport -e report_Bugzilla -e post_report -- "$DUMP_DIR"
+diff --git a/src/plugins/python_event.conf b/src/plugins/python_event.conf
+index e60df11..66b41f2 100644
+--- a/src/plugins/python_event.conf
++++ b/src/plugins/python_event.conf
+@@ -1,19 +1,3 @@
+ EVENT=post-create analyzer=Python
+ abrt-action-analyze-python
+ abrt-action-generate-core-backtrace
+-
+-EVENT=report_Bugzilla analyzer=Python
+- test -f component || abrt-action-save-package-data
+- reporter-bugzilla -b -c /etc/libreport/plugins/bugzilla.conf
+-
+-# Send micro report
+-EVENT=report_uReport analyzer=Python
+- reporter-ureport
+-
+-# update ABRT database after successful report to bugzilla
+-EVENT=post_report analyzer=Python
+- reporter-ureport -r
+-
+-# Reporting of python exceptions
+-EVENT=report-gui analyzer=Python
+- report-gtk -e report_uReport -e report_Bugzilla -e post_report -- "$DUMP_DIR"
+diff --git a/src/plugins/xorg_event.conf b/src/plugins/xorg_event.conf
+index b974a6b..5476230 100644
+--- a/src/plugins/xorg_event.conf
++++ b/src/plugins/xorg_event.conf
+@@ -33,4 +33,4 @@ EVENT=report_Bugzilla analyzer=xorg
+
+ # Reporting of xorg problems
+ EVENT=report-gui analyzer=xorg
+- report-gtk -e report_Bugzilla -- "$DUMP_DIR"
++ report-gtk -e report_Logger -- "$DUMP_DIR"
+--
+1.7.12
+
diff --git a/app-admin/abrt/files/abrt-2.0.12-r1-conf b/app-admin/abrt/files/abrt-2.0.12-r1-conf
new file mode 100644
index 000000000000..073eb0daf82e
--- /dev/null
+++ b/app-admin/abrt/files/abrt-2.0.12-r1-conf
@@ -0,0 +1,27 @@
+# abrtd command-line options
+# Default: ""
+ABRTD_OPTS=""
+
+# Run abrt-harvest-vmcore to make new kdump dumps available for abrtd
+START_VMCORE="yes"
+
+# Install abrt-ccpp hook to watch for segfaults
+START_CCPP="yes"
+
+# Call abrt-dump-oops to log kernel oops
+START_OOPS="yes"
+# log file to watch for kernel oops
+# Default: "/var/log/messages"
+OOPS_WATCH_LOG="/var/log/messages"
+# abrt-dump-oops command-line options
+# Default: "-xD"
+OOPS_DUMP_OPTS="-xD"
+
+# Call abrt-dump-xorg to log X crashes
+START_XORG="yes"
+# log file to watch for X crashes
+# Default: "/var/log/Xorg.0.log"
+XORG_WATCH_LOG="/var/log/Xorg.0.log"
+# abrt-dump-xorg command-line options
+# Default: "-xD"
+XORG_DUMP_OPTS="-xD"
diff --git a/app-admin/abrt/files/abrt-2.0.12-r1-init b/app-admin/abrt/files/abrt-2.0.12-r1-init
new file mode 100644
index 000000000000..b3e57431bf48
--- /dev/null
+++ b/app-admin/abrt/files/abrt-2.0.12-r1-init
@@ -0,0 +1,77 @@
+#!/sbin/runscript
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+description="Automated crash detection service"
+
+depend() {
+ need dbus logger
+}
+
+start() {
+ ebegin "Starting abrtd"
+ start-stop-daemon --start --quiet --pidfile /var/run/abrt/abrtd.pid \
+ --exec /usr/sbin/abrtd -- ${ABRTD_OPTS}
+ eend $?
+
+ if [[ "${START_VMCORE}" = "yes" ]]; then
+ ebegin "Running abrt-harvest-vmcore"
+ /usr/sbin/abrt-harvest-vmcore
+ eend $?
+ fi
+
+ if [[ "${START_CCPP}" = "yes" ]]; then
+ ebegin "Installing abrt-ccpp hook"
+ /usr/sbin/abrt-install-ccpp-hook install
+ eend $?
+ fi
+
+ if [[ "${START_OOPS}" = "yes" ]]; then
+ ebegin "Starting abrt-dump-oops"
+ start-stop-daemon --start --quiet \
+ --pidfile /var/run/abrt/abrt-dump-oops.pid \
+ --make-pidfile --background \
+ --exec /usr/bin/abrt-watch-log -- \
+ -F "`/usr/bin/abrt-dump-oops -m`" ${OOPS_WATCH_LOG} -- \
+ /usr/bin/abrt-dump-oops ${OOPS_DUMP_OPTS}
+ eend $?
+ fi
+
+ if [[ "${START_XORG}" = "yes" ]]; then
+ ebegin "Starting abrt-dump-xorg"
+ start-stop-daemon --start --quiet \
+ --pidfile /var/run/abrt/abrt-dump-xorg.pid \
+ --make-pidfile --background \
+ --exec /usr/bin/abrt-watch-log -- \
+ -F "`/usr/bin/abrt-dump-xorg -m`" ${XORG_WATCH_LOG} -- \
+ /usr/bin/abrt-dump-xorg ${XORG_DUMP_OPTS}
+ eend $?
+ fi
+}
+
+stop() {
+ if [[ "${START_XORG}" = "yes" ]]; then
+ ebegin "Stopping abrt-dump-xorg"
+ start-stop-daemon --stop --quiet \
+ --pidfile /var/run/abrt/abrt-dump-xorg.pid
+ eend $?
+ fi
+
+ if [[ "${START_OOPS}" = "yes" ]]; then
+ ebegin "Stopping abrt-dump-oops"
+ start-stop-daemon --stop --quiet \
+ --pidfile /var/run/abrt/abrt-dump-oops.pid
+ eend $?
+ fi
+
+ if [[ "${START_CCPP}" = "yes" ]]; then
+ ebegin "Uninstalling abrt-ccpp hook"
+ /usr/sbin/abrt-install-ccpp-hook uninstall
+ eend $?
+ fi
+
+ ebegin "Stopping abrtd"
+ start-stop-daemon --stop --quiet --pidfile /var/run/abrt/abrtd.pid
+ eend $?
+}
diff --git a/app-admin/abrt/files/abrt-2.0.6-format-security.patch b/app-admin/abrt/files/abrt-2.0.6-format-security.patch
new file mode 100644
index 000000000000..6b5c8d0e3721
--- /dev/null
+++ b/app-admin/abrt/files/abrt-2.0.6-format-security.patch
@@ -0,0 +1,27 @@
+From d0d7954713541df4612ab5b54b2808aae9a3d6f0 Mon Sep 17 00:00:00 2001
+From: Alexandre Rostovtsev <tetromino@gentoo.org>
+Date: Wed, 16 Nov 2011 00:41:10 -0500
+Subject: [PATCH] Don't use server response as a format string
+
+It's bad practice even for trusted servers, and makes gcc complain about
+format-security.
+---
+ src/plugins/abrt-retrace-client.c | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/src/plugins/abrt-retrace-client.c b/src/plugins/abrt-retrace-client.c
+index 0fb17a3..4c30334 100644
+--- a/src/plugins/abrt-retrace-client.c
++++ b/src/plugins/abrt-retrace-client.c
+@@ -958,7 +958,7 @@ static int create(bool delete_temp_archive,
+ if (response_code == 500 || response_code == 507)
+ {
+ alert_server_error();
+- error_msg_and_die(http_body);
++ error_msg_and_die("%s", http_body);
+ }
+ else if (response_code == 403)
+ {
+--
+1.7.8.rc1
+