summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/apache-tools')
-rw-r--r--app-admin/apache-tools/Manifest4
-rw-r--r--app-admin/apache-tools/apache-tools-2.2.29.ebuild90
-rw-r--r--app-admin/apache-tools/apache-tools-2.2.31.ebuild90
-rw-r--r--app-admin/apache-tools/apache-tools-2.4.12.ebuild93
-rw-r--r--app-admin/apache-tools/apache-tools-2.4.16.ebuild93
-rw-r--r--app-admin/apache-tools/files/apache-tools-2.2.20-Makefile.patch41
-rw-r--r--app-admin/apache-tools/files/apache-tools-2.4.7-Makefile.patch47
-rw-r--r--app-admin/apache-tools/metadata.xml13
8 files changed, 471 insertions, 0 deletions
diff --git a/app-admin/apache-tools/Manifest b/app-admin/apache-tools/Manifest
new file mode 100644
index 000000000000..d0beaf9580b6
--- /dev/null
+++ b/app-admin/apache-tools/Manifest
@@ -0,0 +1,4 @@
+DIST httpd-2.2.29.tar.bz2 5625498 SHA256 574b4f994b99178dfd5160bcb14025402e2ce381be9889b83e4be0ffbf5839a4 SHA512 0b953c97d79dfaaedaee72c6260e7a8e2e1711d47b19f9ace961b33f1226eeb58e37e04694a3e1207e0cf151a9ffbebf379d2bb81306bbf5111ec6db621a68b8 WHIRLPOOL d161104824c5bd6a42675489facf528a8ac2e727a8d2a295111b182e73bb17e7e8a52b720e74a37371e8bd3ddf5745afea32b32171831d95870daa440e7ac2a7
+DIST httpd-2.2.31.tar.bz2 5610489 SHA256 f32f9d19f535dac63b06cb55dfc023b40dcd28196b785f79f9346779e22f26ac SHA512 5aa47d4b76f692bbd8b309135ff99152df98cf69b505b9daf3f13f7f2a31443eaf4995161adfbc47a133b4d0e091fda2d95fc6b87a956f0ada18d7466ee28e74 WHIRLPOOL a2e3e53c51719cb6f7e641b41788cd89ce7b4d2ea105b403bfa3b3d4479b69c5604228269062f66722594e105e91121d05b1c9f27ca7dc4ecfcf339da8b8375c
+DIST httpd-2.4.12.tar.bz2 5054838 SHA256 ad6d39edfe4621d8cc9a2791f6f8d6876943a9da41ac8533d77407a2e630eae4 SHA512 f69db14b421f0e1e4861fe4d8b652688d50ca9eb41c622242d11ae55687eb6c2142a8505a8c3fb6f2bd53167be535bc0a77ca1af97e0720930fc7f20f4c1f8e8 WHIRLPOOL 56512066e8978c4a3d47d0cc2bb92093fd468a9b2f46b8b07fe4db366f55fa5e74ae58bbebe2377cbe0c66f1585759115c786f62f18ac1abc534fb257689d250
+DIST httpd-2.4.16.tar.bz2 5101005 SHA256 ac660b47aaa7887779a6430404dcb40c0b04f90ea69e7bd49a40552e9ff13743 SHA512 039750ff962c08a7261896acc8272e59874d066f7d52721aaf967ddb737fc5716acc47e1effaf7c4d156ba61bc393e0738f64f8e89cc277ba2651e0f61d56628 WHIRLPOOL f67a4449409cd1a50fcdf4d192a3a0c90e6e3483269d19e9f0454557cbfbda7fb3535063e1738de60d6f524e22eac7fc159d2abe5a60952219c1b01ee143ae05
diff --git a/app-admin/apache-tools/apache-tools-2.2.29.ebuild b/app-admin/apache-tools/apache-tools-2.2.29.ebuild
new file mode 100644
index 000000000000..a0a17b5dee90
--- /dev/null
+++ b/app-admin/apache-tools/apache-tools-2.2.29.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+inherit flag-o-matic eutils
+
+DESCRIPTION="Useful Apache tools - htdigest, htpasswd, ab, htdbm"
+HOMEPAGE="http://httpd.apache.org/"
+SRC_URI="mirror://apache/httpd/httpd-${PV}.tar.bz2"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd"
+IUSE="ssl"
+RESTRICT="test"
+
+RDEPEND="=dev-libs/apr-1*
+ =dev-libs/apr-util-1*
+ dev-libs/expat
+ dev-libs/libpcre
+ kernel_linux? ( sys-apps/util-linux )
+ ssl? ( dev-libs/openssl )
+ !<www-servers/apache-2.2.4"
+
+DEPEND="${RDEPEND}
+ sys-devel/libtool"
+
+S="${WORKDIR}/httpd-${PV}"
+
+src_prepare() {
+ # Apply these patches:
+ # (1) apache-tools-2.2.20-Makefile.patch:
+ # - fix up the `make install' for support/
+ # - remove envvars from `make install'
+ epatch "${FILESDIR}"/${PN}-2.2.20-Makefile.patch
+}
+
+src_configure() {
+ # Brain dead check.
+ tc-is-cross-compiler && export ap_cv_void_ptr_lt_long="no"
+
+ # Instead of filtering --as-needed (bug #128505), append --no-as-needed
+ append-ldflags $(no-as-needed)
+
+ # econf overwrites the stuff from config.layout.
+ econf \
+ --sbindir=/usr/sbin \
+ --with-z=/usr \
+ --with-apr=/usr \
+ --with-apr-util=/usr \
+ --with-pcre=/usr \
+ $(use_enable ssl) \
+ $(usex ssl '--with-ssl=/usr' '')
+}
+
+src_compile() {
+ cd support || die
+ emake
+}
+
+src_install () {
+ cd support || die
+
+ make DESTDIR="${D}" install || die
+
+ # install manpages
+ doman "${S}"/docs/man/{dbmmanage,htdigest,htpasswd,htdbm}.1 \
+ "${S}"/docs/man/{htcacheclean,rotatelogs,ab,logresolve}.8
+
+ # Providing compatiblity symlinks for #177697 (which we'll stop to install
+ # at some point).
+ pushd "${D}"/usr/sbin/ >/dev/null || die
+ for i in *; do
+ dosym /usr/sbin/${i} /usr/sbin/${i}2
+ done
+ popd >/dev/null || die
+
+ # Provide a symlink for ab-ssl
+ if use ssl; then
+ dosym /usr/sbin/ab /usr/sbin/ab-ssl
+ dosym /usr/sbin/ab /usr/sbin/ab2-ssl
+ fi
+
+ # make htpasswd accessible for non-root users
+ dosym /usr/sbin/htpasswd /usr/bin/htpasswd
+ dosym /usr/sbin/htdigest /usr/bin/htdigest
+
+ dodoc "${S}"/CHANGES
+}
diff --git a/app-admin/apache-tools/apache-tools-2.2.31.ebuild b/app-admin/apache-tools/apache-tools-2.2.31.ebuild
new file mode 100644
index 000000000000..abeb8444f490
--- /dev/null
+++ b/app-admin/apache-tools/apache-tools-2.2.31.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+inherit flag-o-matic eutils
+
+DESCRIPTION="Useful Apache tools - htdigest, htpasswd, ab, htdbm"
+HOMEPAGE="http://httpd.apache.org/"
+SRC_URI="mirror://apache/httpd/httpd-${PV}.tar.bz2"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd"
+IUSE="ssl"
+RESTRICT="test"
+
+RDEPEND="=dev-libs/apr-1*
+ =dev-libs/apr-util-1*
+ dev-libs/expat
+ dev-libs/libpcre
+ kernel_linux? ( sys-apps/util-linux )
+ ssl? ( dev-libs/openssl )
+ !<www-servers/apache-2.2.4"
+
+DEPEND="${RDEPEND}
+ sys-devel/libtool"
+
+S="${WORKDIR}/httpd-${PV}"
+
+src_prepare() {
+ # Apply these patches:
+ # (1) apache-tools-2.2.20-Makefile.patch:
+ # - fix up the `make install' for support/
+ # - remove envvars from `make install'
+ epatch "${FILESDIR}"/${PN}-2.2.20-Makefile.patch
+}
+
+src_configure() {
+ # Brain dead check.
+ tc-is-cross-compiler && export ap_cv_void_ptr_lt_long="no"
+
+ # Instead of filtering --as-needed (bug #128505), append --no-as-needed
+ append-ldflags $(no-as-needed)
+
+ # econf overwrites the stuff from config.layout.
+ econf \
+ --sbindir=/usr/sbin \
+ --with-z=/usr \
+ --with-apr=/usr \
+ --with-apr-util=/usr \
+ --with-pcre=/usr \
+ $(use_enable ssl) \
+ $(usex ssl '--with-ssl=/usr' '')
+}
+
+src_compile() {
+ cd support || die
+ emake
+}
+
+src_install () {
+ cd support || die
+
+ make DESTDIR="${D}" install || die
+
+ # install manpages
+ doman "${S}"/docs/man/{dbmmanage,htdigest,htpasswd,htdbm}.1 \
+ "${S}"/docs/man/{htcacheclean,rotatelogs,ab,logresolve}.8
+
+ # Providing compatiblity symlinks for #177697 (which we'll stop to install
+ # at some point).
+ pushd "${D}"/usr/sbin/ >/dev/null || die
+ for i in *; do
+ dosym /usr/sbin/${i} /usr/sbin/${i}2
+ done
+ popd >/dev/null || die
+
+ # Provide a symlink for ab-ssl
+ if use ssl; then
+ dosym /usr/sbin/ab /usr/sbin/ab-ssl
+ dosym /usr/sbin/ab /usr/sbin/ab2-ssl
+ fi
+
+ # make htpasswd accessible for non-root users
+ dosym /usr/sbin/htpasswd /usr/bin/htpasswd
+ dosym /usr/sbin/htdigest /usr/bin/htdigest
+
+ dodoc "${S}"/CHANGES
+}
diff --git a/app-admin/apache-tools/apache-tools-2.4.12.ebuild b/app-admin/apache-tools/apache-tools-2.4.12.ebuild
new file mode 100644
index 000000000000..0dbc9b827f25
--- /dev/null
+++ b/app-admin/apache-tools/apache-tools-2.4.12.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit flag-o-matic eutils multilib toolchain-funcs
+
+DESCRIPTION="Useful Apache tools - htdigest, htpasswd, ab, htdbm"
+HOMEPAGE="http://httpd.apache.org/"
+SRC_URI="mirror://apache/httpd/httpd-${PV}.tar.bz2"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc64-solaris ~x64-solaris"
+IUSE="ssl"
+RESTRICT="test"
+
+RDEPEND=">=dev-libs/apr-1.5.0:1
+ dev-libs/apr-util:1
+ dev-libs/expat
+ dev-libs/libpcre
+ kernel_linux? ( sys-apps/util-linux )
+ ssl? ( dev-libs/openssl:0= )"
+
+DEPEND="${RDEPEND}
+ sys-devel/libtool"
+
+S="${WORKDIR}/httpd-${PV}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-2.4.7-Makefile.patch #459446
+
+ # This package really should upgrade to using pcre's .pc file.
+ cat <<-\EOF >"${T}"/pcre-config
+ #!/bin/sh
+ [ "${flag}" = "--version" ] && set -- --modversion
+ exec ${PKG_CONFIG} libpcre "$@"
+ EOF
+ chmod a+x "${T}"/pcre-config
+}
+
+src_configure() {
+ # Brain dead check.
+ tc-is-cross-compiler && export ap_cv_void_ptr_lt_long="no"
+
+ tc-export PKG_CONFIG
+
+ # Instead of filtering --as-needed (bug #128505), append --no-as-needed
+ append-ldflags $(no-as-needed)
+
+ # econf overwrites the stuff from config.layout.
+ ac_cv_path_PKGCONFIG=${PKG_CONFIG} \
+ econf \
+ --libexecdir="${EPREFIX}"/usr/$(get_libdir)/apache2/modules \
+ --sbindir="${EPREFIX}"/usr/sbin \
+ --with-perl="${EPREFIX}"/usr/bin/perl \
+ --with-expat="${EPREFIX}"/usr \
+ --with-z="${EPREFIX}"/usr \
+ --with-apr="${SYSROOT}${EPREFIX}"/usr \
+ --with-apr-util="${SYSROOT}${EPREFIX}"/usr \
+ --with-pcre="${T}"/pcre-config \
+ $(use_enable ssl) \
+ $(usex ssl '--with-ssl="${EPREFIX}"/usr' '')
+ sed -i \
+ -e '/^LTFLAGS/s:--silent::' \
+ build/rules.mk build/config_vars.mk || die
+}
+
+src_compile() {
+ emake -C support
+}
+
+src_install() {
+ emake -C support DESTDIR="${D}" install
+ dodoc CHANGES
+ doman docs/man/{dbmmanage,htdigest,htpasswd,htdbm,ab,logresolve}.1 \
+ docs/man/{htcacheclean,rotatelogs}.8
+
+ # Providing compatiblity symlinks for #177697 (which we'll stop to install
+ # at some point).
+ pushd "${ED}"/usr/sbin >/dev/null || die
+ local i
+ for i in *; do
+ dosym ${i} /usr/sbin/${i}2
+ done
+ popd >/dev/null || die
+
+ # Provide a symlink for ab-ssl
+ if use ssl; then
+ dosym ab /usr/bin/ab-ssl
+ dosym ab /usr/bin/ab2-ssl
+ fi
+}
diff --git a/app-admin/apache-tools/apache-tools-2.4.16.ebuild b/app-admin/apache-tools/apache-tools-2.4.16.ebuild
new file mode 100644
index 000000000000..0dbc9b827f25
--- /dev/null
+++ b/app-admin/apache-tools/apache-tools-2.4.16.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit flag-o-matic eutils multilib toolchain-funcs
+
+DESCRIPTION="Useful Apache tools - htdigest, htpasswd, ab, htdbm"
+HOMEPAGE="http://httpd.apache.org/"
+SRC_URI="mirror://apache/httpd/httpd-${PV}.tar.bz2"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc64-solaris ~x64-solaris"
+IUSE="ssl"
+RESTRICT="test"
+
+RDEPEND=">=dev-libs/apr-1.5.0:1
+ dev-libs/apr-util:1
+ dev-libs/expat
+ dev-libs/libpcre
+ kernel_linux? ( sys-apps/util-linux )
+ ssl? ( dev-libs/openssl:0= )"
+
+DEPEND="${RDEPEND}
+ sys-devel/libtool"
+
+S="${WORKDIR}/httpd-${PV}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-2.4.7-Makefile.patch #459446
+
+ # This package really should upgrade to using pcre's .pc file.
+ cat <<-\EOF >"${T}"/pcre-config
+ #!/bin/sh
+ [ "${flag}" = "--version" ] && set -- --modversion
+ exec ${PKG_CONFIG} libpcre "$@"
+ EOF
+ chmod a+x "${T}"/pcre-config
+}
+
+src_configure() {
+ # Brain dead check.
+ tc-is-cross-compiler && export ap_cv_void_ptr_lt_long="no"
+
+ tc-export PKG_CONFIG
+
+ # Instead of filtering --as-needed (bug #128505), append --no-as-needed
+ append-ldflags $(no-as-needed)
+
+ # econf overwrites the stuff from config.layout.
+ ac_cv_path_PKGCONFIG=${PKG_CONFIG} \
+ econf \
+ --libexecdir="${EPREFIX}"/usr/$(get_libdir)/apache2/modules \
+ --sbindir="${EPREFIX}"/usr/sbin \
+ --with-perl="${EPREFIX}"/usr/bin/perl \
+ --with-expat="${EPREFIX}"/usr \
+ --with-z="${EPREFIX}"/usr \
+ --with-apr="${SYSROOT}${EPREFIX}"/usr \
+ --with-apr-util="${SYSROOT}${EPREFIX}"/usr \
+ --with-pcre="${T}"/pcre-config \
+ $(use_enable ssl) \
+ $(usex ssl '--with-ssl="${EPREFIX}"/usr' '')
+ sed -i \
+ -e '/^LTFLAGS/s:--silent::' \
+ build/rules.mk build/config_vars.mk || die
+}
+
+src_compile() {
+ emake -C support
+}
+
+src_install() {
+ emake -C support DESTDIR="${D}" install
+ dodoc CHANGES
+ doman docs/man/{dbmmanage,htdigest,htpasswd,htdbm,ab,logresolve}.1 \
+ docs/man/{htcacheclean,rotatelogs}.8
+
+ # Providing compatiblity symlinks for #177697 (which we'll stop to install
+ # at some point).
+ pushd "${ED}"/usr/sbin >/dev/null || die
+ local i
+ for i in *; do
+ dosym ${i} /usr/sbin/${i}2
+ done
+ popd >/dev/null || die
+
+ # Provide a symlink for ab-ssl
+ if use ssl; then
+ dosym ab /usr/bin/ab-ssl
+ dosym ab /usr/bin/ab2-ssl
+ fi
+}
diff --git a/app-admin/apache-tools/files/apache-tools-2.2.20-Makefile.patch b/app-admin/apache-tools/files/apache-tools-2.2.20-Makefile.patch
new file mode 100644
index 000000000000..0ac4885feed6
--- /dev/null
+++ b/app-admin/apache-tools/files/apache-tools-2.2.20-Makefile.patch
@@ -0,0 +1,41 @@
+=== modified file 'support/Makefile.in'
+--- support/Makefile.in 2011-09-01 06:33:22 +0000
++++ support/Makefile.in 2011-09-01 06:43:51 +0000
+@@ -1,9 +1,10 @@
+ DISTCLEAN_TARGETS = apxs apachectl dbmmanage log_server_status \
+- logresolve.pl phf_abuse_log.cgi split-logfile envvars-std
++ logresolve.pl phf_abuse_log.cgi split-logfile
+
+ CLEAN_TARGETS = suexec
+
+-PROGRAMS = htpasswd htdigest rotatelogs logresolve ab htdbm htcacheclean httxt2dbm $(NONPORTABLE_SUPPORT)
++PROGRAMS = htpasswd htdigest rotatelogs logresolve ab htdbm htcacheclean httxt2dbm \
++ $(NONPORTABLE_SUPPORT) log_server_status split-logfile dbmmanage
+ TARGETS = $(PROGRAMS)
+
+ PROGRAM_LDADD = $(UTIL_LDFLAGS) $(PROGRAM_DEPENDENCIES) $(EXTRA_LIBS) $(AP_LIBS)
+@@ -12,22 +13,13 @@
+ include $(top_builddir)/build/rules.mk
+
+ install:
+- @test -d $(DESTDIR)$(bindir) || $(MKINSTALLDIRS) $(DESTDIR)$(bindir)
+ @test -d $(DESTDIR)$(sbindir) || $(MKINSTALLDIRS) $(DESTDIR)$(sbindir)
+- @test -d $(DESTDIR)$(libexecdir) || $(MKINSTALLDIRS) $(DESTDIR)$(libexecdir)
+- @cp -p $(top_builddir)/server/httpd.exp $(DESTDIR)$(libexecdir)
+- @for i in apxs apachectl dbmmanage; do \
++ @for i in $(PROGRAMS) ; do \
+ if test -f "$(builddir)/$$i"; then \
+ cp -p $$i $(DESTDIR)$(sbindir); \
+ chmod 755 $(DESTDIR)$(sbindir)/$$i; \
+ fi ; \
+ done
+- @if test -f "$(builddir)/envvars-std"; then \
+- cp -p envvars-std $(DESTDIR)$(sbindir); \
+- if test ! -f $(DESTDIR)$(sbindir)/envvars; then \
+- cp -p envvars-std $(DESTDIR)$(sbindir)/envvars ; \
+- fi ; \
+- fi
+
+ htpasswd_OBJECTS = htpasswd.lo
+ htpasswd: $(htpasswd_OBJECTS)
+
diff --git a/app-admin/apache-tools/files/apache-tools-2.4.7-Makefile.patch b/app-admin/apache-tools/files/apache-tools-2.4.7-Makefile.patch
new file mode 100644
index 000000000000..b7d3c274ea48
--- /dev/null
+++ b/app-admin/apache-tools/files/apache-tools-2.4.7-Makefile.patch
@@ -0,0 +1,47 @@
+https://bugs.gentoo.org/459446
+
+https://raw.github.com/archlinuxcn/repo/master/apache-tools/apache-tools-Makefile.patch
+
+--- a/support/Makefile.in
++++ b/support/Makefile.in
+@@ -1,9 +1,9 @@
+ DISTCLEAN_TARGETS = apxs apachectl dbmmanage log_server_status \
+- logresolve.pl phf_abuse_log.cgi split-logfile envvars-std
++ logresolve.pl phf_abuse_log.cgi split-logfile
+
+ CLEAN_TARGETS = suexec
+
+-bin_PROGRAMS = htpasswd htdigest htdbm ab logresolve httxt2dbm
++bin_PROGRAMS = htpasswd htdigest htdbm ab logresolve httxt2dbm dbmmanage
+ sbin_PROGRAMS = htcacheclean rotatelogs $(NONPORTABLE_SUPPORT)
+ TARGETS = $(bin_PROGRAMS) $(sbin_PROGRAMS)
+
+@@ -15,26 +15,18 @@
+ install:
+ @test -d $(DESTDIR)$(bindir) || $(MKINSTALLDIRS) $(DESTDIR)$(bindir)
+ @test -d $(DESTDIR)$(sbindir) || $(MKINSTALLDIRS) $(DESTDIR)$(sbindir)
+- @test -d $(DESTDIR)$(libexecdir) || $(MKINSTALLDIRS) $(DESTDIR)$(libexecdir)
+- @cp -p $(top_builddir)/server/httpd.exp $(DESTDIR)$(libexecdir)
+- @for i in apxs dbmmanage; do \
++ @for i in $(bin_PROGRAMS); do \
+ if test -f "$(builddir)/$$i"; then \
+ cp -p $$i $(DESTDIR)$(bindir); \
+ chmod 755 $(DESTDIR)$(bindir)/$$i; \
+ fi ; \
+ done
+- @for i in apachectl; do \
++ @for i in $(sbin_PROGRAMS); do \
+ if test -f "$(builddir)/$$i"; then \
+ cp -p $$i $(DESTDIR)$(sbindir); \
+ chmod 755 $(DESTDIR)$(sbindir)/$$i; \
+ fi ; \
+ done
+- @if test -f "$(builddir)/envvars-std"; then \
+- cp -p envvars-std $(DESTDIR)$(sbindir); \
+- if test ! -f $(DESTDIR)$(sbindir)/envvars; then \
+- cp -p envvars-std $(DESTDIR)$(sbindir)/envvars ; \
+- fi ; \
+- fi
+
+ htpasswd.lo: passwd_common.h
+ passwd_common.lo: passwd_common.h
diff --git a/app-admin/apache-tools/metadata.xml b/app-admin/apache-tools/metadata.xml
new file mode 100644
index 000000000000..0530e463d6b4
--- /dev/null
+++ b/app-admin/apache-tools/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>polynomial-c@gentoo.org</email>
+ <name>Lars Wendler</name>
+ </maintainer>
+ <longdescription lang="en">
+ app-admin/apache-tools contains tools that might be useful without
+ having apache itself installed (like htdigest/htpasswd, but also ab -
+ the apache benchmark).
+ </longdescription>
+</pkgmetadata>