summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/drush')
-rw-r--r--app-admin/drush/Manifest2
-rw-r--r--app-admin/drush/drush-5.8.ebuild58
-rw-r--r--app-admin/drush/drush-6.5.0.ebuild64
-rw-r--r--app-admin/drush/files/update-bash-completion-script-for-2.1.patch39
-rw-r--r--app-admin/drush/metadata.xml17
5 files changed, 180 insertions, 0 deletions
diff --git a/app-admin/drush/Manifest b/app-admin/drush/Manifest
new file mode 100644
index 000000000000..5fd5402239ce
--- /dev/null
+++ b/app-admin/drush/Manifest
@@ -0,0 +1,2 @@
+DIST drush-5.8.tar.gz 409642 SHA256 15dd85f04c49b4a896b02dd6960d3140f3ae680bab3eea5d3aba27be0481e480 SHA512 85f7572aece8590d23164dc938e00b740718a5b9bf20ca866083f9e8ce2025ec07f57e06234bf50bfe2351f407f5bad21789103c1e04d18d2fd202fa735637e6 WHIRLPOOL 68f4a8ca09fc61c36de3d6cc6e3aeaab2021b677ba9d732a65f4d5a9940ebbee3cd63dc84f165e119770168547b1997aff6c23497dc50dbe548df348c296188c
+DIST drush-6.5.0.tar.gz 509643 SHA256 0e6bfb8a4bd75846dbca25f6d3e3130a706546f6a62edadce2eb00099750e2a7 SHA512 4afd348c025b9303386131687205af4219a77e6c822518b079a3f0475cbd7ed03647797d613300c7a281e2354f0d855435222fe1afe13447153cdbd6a4393add WHIRLPOOL 1f2a1a725e1c0f89cac90a1338e1541e587c7834560fd23d1a44341696be320e65cf93508d4841f02ca9b30ac62f3fed7de772e00f4eaeea64f287cf19682fcc
diff --git a/app-admin/drush/drush-5.8.ebuild b/app-admin/drush/drush-5.8.ebuild
new file mode 100644
index 000000000000..daccda321913
--- /dev/null
+++ b/app-admin/drush/drush-5.8.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit bash-completion-r1
+
+DESCRIPTION="Drush is a command line shell and scripting interface for Drupal"
+HOMEPAGE="http://drupal.org/project/drush"
+SRC_URI="http://ftp.drupal.org/files/projects/${PN}-7.x-${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="+examples"
+
+DEPEND="dev-lang/php[cli,ctype,simplexml]
+ dev-php/pear
+ dev-php/PEAR-Console_Table
+ dev-php/PEAR-Console_Getopt"
+RDEPEND="${DEPEND}"
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ sed -i -e \
+ "s!/share/doc/drush!/share/doc/${PF}!" \
+ -e "s!README\.txt!\0.bz2!g" \
+ includes/bootstrap.inc || die
+ sed -i \
+ -e "s!\.php'!.php.bz2'!" \
+ -e "s!\.ini'!.ini.bz2'!" \
+ -e "s!\.txt'!.txt.bz2'!" \
+ -e "s!\.bashrc'!.bashrc.bz2'!" \
+ commands/core/docs.drush.inc || die
+ sed \
+ -e "1,2d" \
+ -e "5,11d" \
+ drush.complete.sh > drush.bashcomp
+}
+
+src_install() {
+ local docs="README.txt docs"
+ use examples && docs="${docs} examples"
+ insinto /usr/share/drush
+ doins -r .
+ exeinto /usr/share/drush
+ doexe drush
+ dosym /usr/share/drush/drush /usr/bin/drush
+ dodoc -r ${docs}
+ # cleanup
+ for i in ${docs} LICENSE.txt drush.bat examples includes/.gitignore \
+ .gitignore .travis.yml drush.complete.sh ; do
+ rm -rf "${D}/usr/share/drush/${i}"
+ done
+ keepdir /etc/drush
+ newbashcomp drush.bashcomp drush
+}
diff --git a/app-admin/drush/drush-6.5.0.ebuild b/app-admin/drush/drush-6.5.0.ebuild
new file mode 100644
index 000000000000..7e6f4af7b634
--- /dev/null
+++ b/app-admin/drush/drush-6.5.0.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit bash-completion-r1 eutils
+
+DESCRIPTION="Command line shell and scripting interface for Drupal"
+HOMEPAGE="https://github.com/drush-ops/${PN}"
+SRC_URI="https://github.com/drush-ops/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="dev-lang/php[cli,ctype,json,simplexml]
+ dev-php/PEAR-Console_Table"
+
+src_prepare() {
+ # Fix the bash completion script, check the patch for Gentoo/upstream
+ # bug numbers.
+ epatch "${FILESDIR}/update-bash-completion-script-for-2.1.patch"
+
+ # dodoc compresses all of the documentation, so we fix the filenames
+ # in a few places.
+
+ # First, the README location in bootstrap.inc.
+ sed -i -e \
+ "s!/share/doc/drush!/share/doc/${PF}!" \
+ -e "s!README\.md!\0.bz2!g" \
+ includes/bootstrap.inc || die
+
+ # Next, the list of documentation in docs.drush.inc. Note that
+ # html files don't get compressed.
+ sed -i \
+ -e "s!\.bashrc'!.bashrc.bz2'!" \
+ -e "s!\.inc'!.inc.bz2'!" \
+ -e "s!\.ini'!.ini.bz2'!" \
+ -e "s!\.md'!.md.bz2'!" \
+ -e "s!\.php'!.php.bz2'!" \
+ -e "s!\.script'!.script.bz2'!" \
+ -e "s!\.txt'!.txt.bz2'!" \
+ commands/core/docs.drush.inc || die
+}
+
+src_install() {
+ # Always install the examples; they're referenced within the source
+ # code and too difficult to exorcise.
+ dodoc -r README.md docs examples
+
+ insinto /usr/share/drush
+ doins -r classes commands includes lib misc
+ doins drush_logo-black.png drush.info drush.php
+
+ exeinto /usr/share/drush
+ doexe drush
+ dosym /usr/share/drush/drush /usr/bin/drush
+
+ keepdir /etc/drush
+ newbashcomp drush.complete.sh drush
+}
diff --git a/app-admin/drush/files/update-bash-completion-script-for-2.1.patch b/app-admin/drush/files/update-bash-completion-script-for-2.1.patch
new file mode 100644
index 000000000000..a6a9b6a0ff43
--- /dev/null
+++ b/app-admin/drush/files/update-bash-completion-script-for-2.1.patch
@@ -0,0 +1,39 @@
+From e0f53949d35f32d251ab003d6e9e70a7f8c0e69a Mon Sep 17 00:00:00 2001
+From: Michael Orlitzky <mjo@gentoo.org>
+Date: Tue, 21 Oct 2014 19:48:37 -0400
+Subject: [PATCH 1/1] Update bash completion script for new
+ bash-completion-2.1 (Gentoo bug #526222).
+
+* Don't use `which drush ...` to detect the presence of drush in the
+ bash-completion script (https://github.com/drush-ops/drush/issues/521).
+
+* Don't install completions for commands that we don't "own"
+ (https://github.com/drush-ops/drush/issues/915).
+
+---
+ drush.complete.sh | 5 +----
+ 1 file changed, 1 insertion(+), 4 deletions(-)
+
+diff --git a/drush.complete.sh b/drush.complete.sh
+index 067a67c..2f97317 100644
+--- a/drush.complete.sh
++++ b/drush.complete.sh
+@@ -5,9 +5,6 @@
+ # examples/example.bashrc instead, as it will automatically find and source
+ # this file.
+
+-# Ensure drush is available.
+-which drush > /dev/null || alias drush &> /dev/null || return
+-
+ __drush_ps1() {
+ f="${TMPDIR:-/tmp/}/drush-env/drush-drupal-site-$$"
+ if [ -f $f ]
+@@ -31,4 +28,4 @@ _drush_completion() {
+ }
+
+ # Register our completion function. We include common short aliases for Drush.
+-complete -o bashdefault -o default -o nospace -F _drush_completion d dr drush drush5 drush6 drush7 drush.php
++complete -o bashdefault -o default -o nospace -F _drush_completion drush
+--
+2.0.4
+
diff --git a/app-admin/drush/metadata.xml b/app-admin/drush/metadata.xml
new file mode 100644
index 000000000000..4cf1bb2441f4
--- /dev/null
+++ b/app-admin/drush/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>mjo@gentoo.org</email>
+ <name>Michael Orlitzky</name>
+ </maintainer>
+ <longdescription lang="en">
+ Drush is a command line shell and scripting interface for Drupal,
+ a veritable Swiss Army knife designed to make life easier for
+ those of us who spend some of our working hours hacking away at
+ the command prompt.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">drush-ops/drush</remote-id>
+ </upstream>
+</pkgmetadata>