summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/equo')
-rw-r--r--app-admin/equo/Manifest1
-rw-r--r--app-admin/equo/equo-254.ebuild39
-rw-r--r--app-admin/equo/metadata.xml11
3 files changed, 51 insertions, 0 deletions
diff --git a/app-admin/equo/Manifest b/app-admin/equo/Manifest
new file mode 100644
index 000000000000..520d012e476c
--- /dev/null
+++ b/app-admin/equo/Manifest
@@ -0,0 +1 @@
+DIST entropy-254.tar.bz2 18516662 SHA256 5e411472eaf7016a68a4aa81ef92dd3aad8403fc65a0ffb09c57b91c959ca3a6 SHA512 3b3e82abad8008720e370b7892b7be1c48aaa6605914db977f68b9a108ada0a4adbaa5b7b50a9a02ba9c8b0bdefadcda1eceee2c7c2abc385b3daf669649e2da WHIRLPOOL 593469b858707e4ceca56146fa1d608141e44dda0a0921ed6a3ec566878c1e3c153410233f088d57db4f8bd9d1c796bd945cbea3ba455572efc05eca42023ce5
diff --git a/app-admin/equo/equo-254.ebuild b/app-admin/equo/equo-254.ebuild
new file mode 100644
index 000000000000..a6987439d5b8
--- /dev/null
+++ b/app-admin/equo/equo-254.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit eutils python-single-r1 bash-completion-r1
+
+DESCRIPTION="Entropy Package Manager text-based client"
+HOMEPAGE="http://www.sabayon.org"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+SRC_URI="mirror://sabayon/sys-apps/entropy-${PV}.tar.bz2"
+
+S="${WORKDIR}/entropy-${PV}"
+
+DEPEND="${PYTHON_DEPS}
+ ~sys-apps/entropy-${PV}[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND} sys-apps/file[python]"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+src_compile() {
+ cd "${S}"/client || die
+ emake || die "make failed"
+}
+
+src_install() {
+ cd "${S}"/client || die
+ emake DESTDIR="${D}" LIBDIR="usr/lib" install || die "make install failed"
+ newbashcomp "${S}/misc/equo-completion.bash" equo
+
+ python_optimize "${D}/usr/lib/entropy/client"
+}
diff --git a/app-admin/equo/metadata.xml b/app-admin/equo/metadata.xml
new file mode 100644
index 000000000000..187f7a710efe
--- /dev/null
+++ b/app-admin/equo/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>lxnay@gentoo.org</email>
+ <name>Fabio Erculiani</name>
+ </maintainer>
+ <use>
+ </use>
+</pkgmetadata>
+