summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/lastpass-cli/lastpass-cli-0.3.0.ebuild')
-rw-r--r--app-admin/lastpass-cli/lastpass-cli-0.3.0.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/app-admin/lastpass-cli/lastpass-cli-0.3.0.ebuild b/app-admin/lastpass-cli/lastpass-cli-0.3.0.ebuild
new file mode 100644
index 000000000000..e1129508d83e
--- /dev/null
+++ b/app-admin/lastpass-cli/lastpass-cli-0.3.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="Interfaces with LastPass.com from the command line."
+SRC_URI="https://github.com/lastpass/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+HOMEPAGE="https://github.com/lastpass/lastpass-cli"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE="X +pinentry"
+
+RDEPEND="
+ X? ( || ( x11-misc/xclip x11-misc/xsel ) )
+ dev-libs/openssl:0
+ net-misc/curl
+ dev-libs/libxml2
+ pinentry? ( app-crypt/pinentry )
+"
+DEPEND="${RDEPEND} app-text/asciidoc"
+
+src_prepare() {
+ sed -i 's/install -s/install/' Makefile || die "Could not remove stripping"
+}
+
+src_compile() {
+ emake PREFIX="${EPREFIX}/usr"
+ emake PREFIX="${EPREFIX}/usr" doc-man
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" install
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" install-doc
+}