summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/mcelog/mcelog-103.ebuild')
-rw-r--r--app-admin/mcelog/mcelog-103.ebuild59
1 files changed, 0 insertions, 59 deletions
diff --git a/app-admin/mcelog/mcelog-103.ebuild b/app-admin/mcelog/mcelog-103.ebuild
deleted file mode 100644
index ba60b1f5c849..000000000000
--- a/app-admin/mcelog/mcelog-103.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-inherit linux-info eutils systemd toolchain-funcs
-
-DESCRIPTION="A tool to log and decode Machine Check Exceptions"
-HOMEPAGE="http://mcelog.org/"
-SRC_URI="https://github.com/andikleen/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="selinux"
-
-RDEPEND="selinux? ( sec-policy/selinux-mcelog )"
-
-CONFIG_CHECK="~X86_MCE"
-
-# TODO: add mce-inject to the tree to support test phase
-RESTRICT="test"
-
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-0.8_pre1-timestamp-${PN}.patch \
- "${FILESDIR}"/${PN}-1.0_pre3_p20120918-build.patch \
- "${FILESDIR}"/${PN}-1.0_pre3_p20120918-bashism.patch
- tc-export CC
-}
-
-src_install() {
- dosbin ${PN}
-
- insinto /etc/cron.daily
- newins ${PN}.cron ${PN}
-
- insinto /etc/logrotate.d/
- newins ${PN}.logrotate ${PN}
-
- newinitd "${FILESDIR}"/${PN}.init-r1 ${PN}
- systemd_dounit "${FILESDIR}"/${PN}.service
-
- insinto /etc/${PN}
- doins mcelog.conf
- exeinto /etc/${PN}
- doexe triggers/*
-
- dodoc CHANGES README TODO *.pdf
- doman ${PN}.8
-}
-
-pkg_postinst() {
- einfo "The default configuration set is now installed in /etc/${PN}"
- einfo "you might want to edit those files."
- einfo
- einfo "A sample cronjob is installed into /etc/cron.daily"
- einfo "without executable bit (system service is the preferred method now)"
-}