summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/verynice/verynice-1.1-r3.ebuild')
-rw-r--r--app-admin/verynice/verynice-1.1-r3.ebuild14
1 files changed, 6 insertions, 8 deletions
diff --git a/app-admin/verynice/verynice-1.1-r3.ebuild b/app-admin/verynice/verynice-1.1-r3.ebuild
index bcb090717f3d..218297dc720a 100644
--- a/app-admin/verynice/verynice-1.1-r3.ebuild
+++ b/app-admin/verynice/verynice-1.1-r3.ebuild
@@ -1,20 +1,18 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit systemd toolchain-funcs
DESCRIPTION="A tool for dynamically adjusting the nice-level of processes"
HOMEPAGE="https://web.archive.org/web/20130621090315/http://thermal.cnde.iastate.edu/~sdh4/verynice/"
SRC_URI="http://gentoo/${P}.tar.gz"
+S="${WORKDIR}"/${PN}
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="amd64 ppc x86"
-IUSE=""
-
-S=${WORKDIR}/${PN}
+KEYWORDS="amd64 arm arm64 ppc x86"
PATCHES=(
"${FILESDIR}"/${PN}-1.1-build.patch
@@ -22,11 +20,11 @@ PATCHES=(
src_compile() {
tc-export CC
- emake RPM_BUILD_ROOT="${D}" PREFIX=/usr
+ emake PREFIX="${EPREFIX}"/usr
}
src_install() {
- emake RPM_BUILD_ROOT="${D}" PREFIX=/usr VERSION=${PVR} install
+ emake RPM_BUILD_ROOT="${D}" PREFIX="${EPREFIX}"/usr VERSION=${PVR} install
doinitd "${FILESDIR}"/verynice
systemd_dounit "${FILESDIR}"/verynice.service
}