summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/consul-template/consul-template-0.9.0-r1.ebuild4
-rw-r--r--app-admin/consul-template/consul-template-0.9.0.ebuild4
-rw-r--r--app-admin/consul-template/consul-template-9999.ebuild4
3 files changed, 6 insertions, 6 deletions
diff --git a/app-admin/consul-template/consul-template-0.9.0-r1.ebuild b/app-admin/consul-template/consul-template-0.9.0-r1.ebuild
index fd646ee7809d..cbc1059efff7 100644
--- a/app-admin/consul-template/consul-template-0.9.0-r1.ebuild
+++ b/app-admin/consul-template/consul-template-0.9.0-r1.ebuild
@@ -4,7 +4,7 @@
EAPI=5
-inherit systemd user
+inherit golang-base systemd user
KEYWORDS="~amd64"
DESCRIPTION="Generic template rendering and notifications with Consul"
@@ -68,7 +68,7 @@ unpack_go_packages() {
src_unpack() {
unpack_go_packages
- export GOPATH=${WORKDIR}
+ export GOPATH=${WORKDIR}:$(get_golibdir_gopath)
}
src_prepare() {
diff --git a/app-admin/consul-template/consul-template-0.9.0.ebuild b/app-admin/consul-template/consul-template-0.9.0.ebuild
index 0abadf7d7d2b..80a3de8adbf5 100644
--- a/app-admin/consul-template/consul-template-0.9.0.ebuild
+++ b/app-admin/consul-template/consul-template-0.9.0.ebuild
@@ -4,7 +4,7 @@
EAPI=5
-inherit systemd user
+inherit golang-base systemd user
KEYWORDS="~amd64"
DESCRIPTION="Generic template rendering and notifications with Consul"
@@ -68,7 +68,7 @@ unpack_go_packages() {
src_unpack() {
unpack_go_packages
- export GOPATH=${WORKDIR}
+ export GOPATH=${WORKDIR}:$(get_golibdir_gopath)
}
src_prepare() {
diff --git a/app-admin/consul-template/consul-template-9999.ebuild b/app-admin/consul-template/consul-template-9999.ebuild
index 40307ab73520..0dcf7f1b9541 100644
--- a/app-admin/consul-template/consul-template-9999.ebuild
+++ b/app-admin/consul-template/consul-template-9999.ebuild
@@ -4,7 +4,7 @@
EAPI=5
-inherit git-r3 systemd user
+inherit git-r3 golang-base systemd user
KEYWORDS=""
DESCRIPTION="Generic template rendering and notifications with Consul"
@@ -32,7 +32,7 @@ pkg_setup() {
}
src_unpack() {
- export GOPATH=${WORKDIR}
+ export GOPATH=${WORKDIR}:$(get_golibdir_gopath)
git-r3_src_unpack
go get -d -v ./... $(go list -f '{{range .TestImports}}{{.}} {{end}}' ./...) || die
}