summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-arch/lz4/lz4-1.8.3.ebuild')
-rw-r--r--app-arch/lz4/lz4-1.8.3.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-arch/lz4/lz4-1.8.3.ebuild b/app-arch/lz4/lz4-1.8.3.ebuild
new file mode 100644
index 000000000000..0e01e4c39d32
--- /dev/null
+++ b/app-arch/lz4/lz4-1.8.3.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-multilib
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lz4/lz4.git"
+ EGIT_BRANCH=dev
+else
+ SRC_URI="https://github.com/Cyan4973/lz4/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~amd64-linux ~x86-linux ~x64-macos"
+fi
+
+DESCRIPTION="Extremely Fast Compression algorithm"
+HOMEPAGE="https://github.com/lz4/lz4"
+
+LICENSE="BSD-2 GPL-2"
+# https://abi-laboratory.pro/tracker/timeline/lz4/
+SLOT="0/r131"
+IUSE="static-libs"
+
+CMAKE_USE_DIR=${S}/contrib/cmake_unofficial
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DBUILD_STATIC_LIBS=$(usex static-libs)
+ )
+
+ cmake-utils_src_configure
+}