summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-arch/pxz/pxz-5.0_pre20220509.ebuild')
-rw-r--r--app-arch/pxz/pxz-5.0_pre20220509.ebuild41
1 files changed, 0 insertions, 41 deletions
diff --git a/app-arch/pxz/pxz-5.0_pre20220509.ebuild b/app-arch/pxz/pxz-5.0_pre20220509.ebuild
deleted file mode 100644
index 72381a102246..000000000000
--- a/app-arch/pxz/pxz-5.0_pre20220509.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit toolchain-funcs vcs-snapshot
-
-PXZ_COMMIT="136e5c25daf545753329d7cee1b06ae482fb9c44"
-DESCRIPTION="Parallel implementation of the XZ compression utility"
-HOMEPAGE="http://jnovy.fedorapeople.org/pxz/"
-SRC_URI="https://github.com/jnovy/pxz/archive/${PXZ_COMMIT}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86 ~amd64-linux"
-
-# needs the library from xz-utils
-RDEPEND="app-arch/xz-utils"
-DEPEND="${RDEPEND}"
-
-pkg_pretend() {
- [[ ${MERGE_TYPE} != binary ]] && tc-check-openmp
-}
-
-pkg_setup() {
- [[ ${MERGE_TYPE} != binary ]] && tc-check-openmp
-}
-
-src_prepare() {
- default
-
- if use elibc_musl ; then
- sed -i -e '/<error.h>/c\#define error(R,E,S,...) fprintf(stderr, S "\\n", ##__VA_ARGS__); exit(R)' pxz.c || die
- fi
-}
-
-src_configure() {
- tc-export CC
- export BINDIR="${EPREFIX}"/usr/bin
- export MANDIR="${EPREFIX}"/usr/share/man
-}