summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-arch/unmakeself/unmakeself-1.0.ebuild')
-rw-r--r--app-arch/unmakeself/unmakeself-1.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/app-arch/unmakeself/unmakeself-1.0.ebuild b/app-arch/unmakeself/unmakeself-1.0.ebuild
new file mode 100644
index 000000000000..cb7906b57440
--- /dev/null
+++ b/app-arch/unmakeself/unmakeself-1.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit toolchain-funcs
+
+DESCRIPTION="extracting Makeself archives without having to run the self-extracting shell script"
+HOMEPAGE="http://www.freshports.org/archivers/unmakeself"
+SRC_URI="http://gentooexperimental.org/~genstef/dist/${P}.tar.bz2"
+#http://cvsup.pt.freebsd.org/cgi-bin/cvsweb/cvsweb.cgi/~checkout~/root/ports/ports/archivers/unmakeself/files/unmakeself.c
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="app-arch/bzip2
+ sys-libs/zlib
+ app-arch/libarchive"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ $(tc-getCC) ${CFLAGS} ${LDFLAGS} unmakeself.c -larchive -lbz2 -lz -o unmakeself
+}
+
+src_install() {
+ dobin unmakeself
+}