summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-arch/unrpa/unrpa-1.4.1.ebuild')
-rw-r--r--app-arch/unrpa/unrpa-1.4.1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-arch/unrpa/unrpa-1.4.1.ebuild b/app-arch/unrpa/unrpa-1.4.1.ebuild
new file mode 100644
index 000000000000..ee99fdb00de8
--- /dev/null
+++ b/app-arch/unrpa/unrpa-1.4.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+inherit python-single-r1
+
+if [[ ${PV} == "9999" ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/Lattyware/unrpa.git"
+else
+ SRC_URI="https://github.com/Lattyware/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Ren'Py's RPA data file extractor"
+HOMEPAGE="https://github.com/Lattyware/unrpa"
+
+LICENSE="GPL-3"
+SLOT="0"
+
+DEPEND="${PYTHON_DEPS}"
+RDEPEND=${DEPEND}
+
+src_install() {
+ dobin ${PN}
+ dodoc README
+}