summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-backup/attic/attic-9999.ebuild')
-rw-r--r--app-backup/attic/attic-9999.ebuild38
1 files changed, 0 insertions, 38 deletions
diff --git a/app-backup/attic/attic-9999.ebuild b/app-backup/attic/attic-9999.ebuild
deleted file mode 100644
index 381506ecc41d..000000000000
--- a/app-backup/attic/attic-9999.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7,8} )
-
-inherit distutils-r1
-
-if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="https://github.com/jborg/attic.git"
- inherit git-r3
-else
- SRC_URI="https://github.com/jborg/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
-fi
-
-DESCRIPTION="Attic is a deduplicating backup program written in Python"
-HOMEPAGE="https://attic-backup.org/"
-
-LICENSE="BSD"
-SLOT="0"
-
-RDEPEND="
- dev-python/msgpack[${PYTHON_USEDEP}]
- dev-libs/openssl:0=
- dev-python/llfuse[${PYTHON_USEDEP}]"
-
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- dev-python/cython[${PYTHON_USEDEP}]
- ${RDEPEND}"
-
-python_prepare_all() {
- # allow use of new (renamed) msgpack
- sed -i '/msgpack/d' setup.py || die
- distutils-r1_python_prepare_all
-}