summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-backup')
-rw-r--r--app-backup/bup/Manifest2
-rw-r--r--app-backup/bup/bup-0.29-r1.ebuild60
-rw-r--r--app-backup/bup/bup-0.29.1.ebuild60
-rw-r--r--app-backup/bup/bup-0.29.ebuild57
4 files changed, 0 insertions, 179 deletions
diff --git a/app-backup/bup/Manifest b/app-backup/bup/Manifest
index ccaedbfe2e9f..61b18d18dc07 100644
--- a/app-backup/bup/Manifest
+++ b/app-backup/bup/Manifest
@@ -1,4 +1,2 @@
DIST bup-0.28.1.tar.gz 377712 BLAKE2B b469af7b40807e1462c603c03078fc4e048fc300f74dccba9db4ee9d5b1cd385b3092c2bcc08b60ba798e4f401953ccb3217275c6afb3ebf8040e6e507fde9fd SHA512 b27a94eeee86366f9f97081611d8e0443686ed8c4070d45729ad4efe1d48ee9f528d3257bfd5d37d6243927f5b63d6b613bf5ae2c39117012979ccd5ccecf9d2
-DIST bup-0.29.1.tar.gz 388654 BLAKE2B e0a1bd6606f0b2fa7fc50f7df46d2f1704b2bec7e9ac7ff8b97f0bc46081fd4c506f2f12af73e952854746bdf0de5b713d0d5519d99bebafb8c4b62f782ebd09 SHA512 2ad142214cf5ee61e2113b49d02761cdf8fdd5928eb4f885230af71f149ba33ee748e1d96e240903f54d3264dc2ad1614e6ece66027b4c7ed1e97b6147a9685e
DIST bup-0.29.2.tar.gz 389145 BLAKE2B 1a54cb68b2c68ecf4902a7f1ee940711b62e413c69d17ba1515f24e115484bac1b4919947f2214ffff784389839f633fbb13dea69c186246426e57c33a148c4c SHA512 10c433d6779b1fd7e1935c587676492d96a330dc3280556332bb55b6e5c62de8631fd755d07d2eaf80cb9fa209dc25b241d5ecf3a6fe2b8210a3d0e1ce4fa4bf
-DIST bup-0.29.tar.gz 388173 BLAKE2B 4d844aa616daa56e457a6164a8a00521c3cc2fe56a4f7b3e73b3cdfa4d42977652b203756198e3b8222de5e49b6d0cadd340f70f79e0a1878f4af80dd2b4d2d7 SHA512 3a70d747c6bae2640809d48141b726fa7897f33af9f19047c8d4cfba88abe04ac907980f0ce572847b900e2c8d02a3303e886c8ad7af9a97a7804540c7da1705
diff --git a/app-backup/bup/bup-0.29-r1.ebuild b/app-backup/bup/bup-0.29-r1.ebuild
deleted file mode 100644
index 86ff4f87983b..000000000000
--- a/app-backup/bup/bup-0.29-r1.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python2_7 )
-
-inherit python-single-r1
-
-DESCRIPTION="A highly efficient backup system based on the git packfile format"
-HOMEPAGE="https://bup.github.io/ https://github.com/bup/bup"
-SRC_URI="https://github.com/bup/bup/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="LGPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="+doc test web"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-RDEPEND="${PYTHON_DEPS}
- app-arch/par2cmdline
- dev-python/fuse-python[${PYTHON_USEDEP}]
- dev-python/pylibacl[${PYTHON_USEDEP}]
- dev-python/pyxattr[${PYTHON_USEDEP}]
- web? ( www-servers/tornado[${PYTHON_USEDEP}] )
- sys-libs/readline:0
- dev-vcs/git"
-DEPEND="${RDEPEND}
- test? (
- dev-lang/perl
- net-misc/rsync
- )
- doc? ( app-text/pandoc )
-"
-
-# unresolved sandbox issues
-RESTRICT="test"
-
-src_prepare() {
- default
-
- sed -e "/^CFLAGS :=/s/-O2 -Werror//" \
- -i Makefile || die
-}
-
-src_configure() {
- # only build/install docs if enabled
- export PANDOC=$(usex doc pandoc "")
-
- ./configure || die
-}
-
-src_test() {
- emake test
-}
-
-src_install() {
- emake DESTDIR="${D}" PREFIX=/usr LIBDIR="/usr/$(get_libdir)/bup" DOCDIR="/usr/share/${PF}" install
- python_fix_shebang "${ED}"
- python_optimize "${ED}"
-}
diff --git a/app-backup/bup/bup-0.29.1.ebuild b/app-backup/bup/bup-0.29.1.ebuild
deleted file mode 100644
index 86ff4f87983b..000000000000
--- a/app-backup/bup/bup-0.29.1.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python2_7 )
-
-inherit python-single-r1
-
-DESCRIPTION="A highly efficient backup system based on the git packfile format"
-HOMEPAGE="https://bup.github.io/ https://github.com/bup/bup"
-SRC_URI="https://github.com/bup/bup/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="LGPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="+doc test web"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-RDEPEND="${PYTHON_DEPS}
- app-arch/par2cmdline
- dev-python/fuse-python[${PYTHON_USEDEP}]
- dev-python/pylibacl[${PYTHON_USEDEP}]
- dev-python/pyxattr[${PYTHON_USEDEP}]
- web? ( www-servers/tornado[${PYTHON_USEDEP}] )
- sys-libs/readline:0
- dev-vcs/git"
-DEPEND="${RDEPEND}
- test? (
- dev-lang/perl
- net-misc/rsync
- )
- doc? ( app-text/pandoc )
-"
-
-# unresolved sandbox issues
-RESTRICT="test"
-
-src_prepare() {
- default
-
- sed -e "/^CFLAGS :=/s/-O2 -Werror//" \
- -i Makefile || die
-}
-
-src_configure() {
- # only build/install docs if enabled
- export PANDOC=$(usex doc pandoc "")
-
- ./configure || die
-}
-
-src_test() {
- emake test
-}
-
-src_install() {
- emake DESTDIR="${D}" PREFIX=/usr LIBDIR="/usr/$(get_libdir)/bup" DOCDIR="/usr/share/${PF}" install
- python_fix_shebang "${ED}"
- python_optimize "${ED}"
-}
diff --git a/app-backup/bup/bup-0.29.ebuild b/app-backup/bup/bup-0.29.ebuild
deleted file mode 100644
index f1071883fb22..000000000000
--- a/app-backup/bup/bup-0.29.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python2_7 )
-
-inherit python-single-r1
-
-DESCRIPTION="A highly efficient backup system based on the git packfile format"
-HOMEPAGE="https://bup.github.io/ https://github.com/bup/bup"
-SRC_URI="https://github.com/bup/bup/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="LGPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test web"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-RDEPEND="${PYTHON_DEPS}
- app-arch/par2cmdline
- dev-python/fuse-python[${PYTHON_USEDEP}]
- dev-python/pylibacl[${PYTHON_USEDEP}]
- dev-python/pyxattr[${PYTHON_USEDEP}]
- web? ( www-servers/tornado[${PYTHON_USEDEP}] )
- sys-libs/readline:0
- dev-vcs/git"
-DEPEND="${RDEPEND}
- test? (
- dev-lang/perl
- net-misc/rsync
- )
- app-text/pandoc
-"
-
-# unresolved sandbox issues
-RESTRICT="test"
-
-src_prepare() {
- default
-
- sed -e "/^CFLAGS :=/s/-O2 -Werror//" \
- -i Makefile || die
-}
-
-src_configure() {
- ./configure || die
-}
-
-src_test() {
- emake test
-}
-
-src_install() {
- emake DESTDIR="${D}" PREFIX=/usr LIBDIR="/usr/$(get_libdir)/bup" DOCDIR="/usr/share/${PF}" install
- python_fix_shebang "${ED}"
- python_optimize "${ED}"
-}