summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-cdr/mirage2iso/mirage2iso-9999.ebuild')
-rw-r--r--app-cdr/mirage2iso/mirage2iso-9999.ebuild29
1 files changed, 10 insertions, 19 deletions
diff --git a/app-cdr/mirage2iso/mirage2iso-9999.ebuild b/app-cdr/mirage2iso/mirage2iso-9999.ebuild
index 117ba275a26e..6eaba9ee1d9f 100644
--- a/app-cdr/mirage2iso/mirage2iso-9999.ebuild
+++ b/app-cdr/mirage2iso/mirage2iso-9999.ebuild
@@ -1,31 +1,26 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
-EGIT_REPO_URI="https://github.com/mgorny/mirage2iso.git"
inherit autotools git-r3
DESCRIPTION="CD/DVD image converter using libmirage"
-HOMEPAGE="https://github.com/mgorny/mirage2iso/"
-SRC_URI=""
+HOMEPAGE="https://github.com/projg2/mirage2iso/"
+EGIT_REPO_URI="https://github.com/projg2/mirage2iso.git"
LICENSE="BSD"
SLOT="0"
-KEYWORDS=""
IUSE="pinentry test"
+RESTRICT="!test? ( test )"
-COMMON_DEPEND=">=dev-libs/libmirage-2.0.0:0=
+DEPEND="
+ >=dev-libs/libmirage-2.0.0:0=
dev-libs/glib:2=
pinentry? ( dev-libs/libassuan:0= )"
-DEPEND="${COMMON_DEPEND}
- dev-libs/libassuan
- virtual/pkgconfig
- test? ( app-arch/xz-utils )"
-RDEPEND="${COMMON_DEPEND}
+RDEPEND="${DEPEND}
pinentry? ( app-crypt/pinentry )"
-
-RESTRICT="!test? ( test )"
+BDEPEND="virtual/pkgconfig"
src_prepare() {
default
@@ -33,9 +28,5 @@ src_prepare() {
}
src_configure() {
- local myconf=(
- $(use_with pinentry libassuan)
- )
-
- econf "${myconf[@]}"
+ econf $(use_with pinentry libassuan)
}