summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/dieharder')
-rw-r--r--app-crypt/dieharder/Manifest2
-rw-r--r--app-crypt/dieharder/dieharder-2.28.1.ebuild38
-rw-r--r--app-crypt/dieharder/dieharder-3.31.1-r1.ebuild45
-rw-r--r--app-crypt/dieharder/dieharder-3.31.1.ebuild38
-rw-r--r--app-crypt/dieharder/files/dieharder-2.28.1-qafixes.patch33
-rw-r--r--app-crypt/dieharder/files/dieharder-3.31.1-build.patch27
-rw-r--r--app-crypt/dieharder/metadata.xml5
7 files changed, 188 insertions, 0 deletions
diff --git a/app-crypt/dieharder/Manifest b/app-crypt/dieharder/Manifest
new file mode 100644
index 000000000000..6957e01efdc3
--- /dev/null
+++ b/app-crypt/dieharder/Manifest
@@ -0,0 +1,2 @@
+DIST dieharder-2.28.1.tgz 766985 SHA256 748ec4716e64de38807e126f10335e45136fa789056e9f647a6bf73698205286 SHA512 35e210fd0fff9ecb3e68494058a9943e6684dd98d3a3ff70776b52a7de7fcbda28f10084f23f3872793da365ed8e16c0a91941266272e6e97575c9b146b17e14 WHIRLPOOL 8f17197f095831cc63601367ab73bac2ac19fda129ee321543883ee69477f9a253abaf3cc9a1e376bb531093bae56119dfd49f29deb29cad1ac411bccfa72a02
+DIST dieharder-3.31.1.tgz 1149780 SHA256 6cff0ff8394c553549ac7433359ccfc955fb26794260314620dfa5e4cd4b727f SHA512 e01ed4266b4fe5d5fadde3c92c30e430d0ca5f7fedd26b26ed2ab98b7602aa9c35bb5c8fd9314ef2f5235b5087645ab13e5e6550156e26643baa5aeb77088dc5 WHIRLPOOL eb10fffbe839b2448b1955841dd4c3dee45f21ab89eb5107e82c3fef8706f7386ee6b6c21aa947c2cbe1f16075c7882975c9eff5fb17876799c15ccce9b5eca1
diff --git a/app-crypt/dieharder/dieharder-2.28.1.ebuild b/app-crypt/dieharder/dieharder-2.28.1.ebuild
new file mode 100644
index 000000000000..943426c5e666
--- /dev/null
+++ b/app-crypt/dieharder/dieharder-2.28.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+
+WANT_AUTOCONF="2.5"
+inherit autotools eutils
+
+DESCRIPTION="An advanced suite for testing the randomness of RNG's"
+HOMEPAGE="http://www.phy.duke.edu/~rgb/General/dieharder.php"
+SRC_URI="http://www.phy.duke.edu/~rgb/General/${PN}/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="sci-libs/gsl"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-qafixes.patch
+ eautoreconf
+}
+
+src_compile() {
+ emake all-recursive || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc NEWS README* NOTES || die
+ docinto "dieharder"
+ dodoc dieharder/README dieharder/NOTES || die
+ docinto "libdieharder"
+ dodoc libdieharder/README libdieharder/NOTES || die
+}
diff --git a/app-crypt/dieharder/dieharder-3.31.1-r1.ebuild b/app-crypt/dieharder/dieharder-3.31.1-r1.ebuild
new file mode 100644
index 000000000000..49db3e0147f0
--- /dev/null
+++ b/app-crypt/dieharder/dieharder-3.31.1-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools eutils
+
+DESCRIPTION="An advanced suite for testing the randomness of RNG's"
+HOMEPAGE="http://www.phy.duke.edu/~rgb/General/dieharder.php"
+SRC_URI="http://www.phy.duke.edu/~rgb/General/${PN}/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND="sci-libs/gsl"
+DEPEND="${RDEPEND}
+ doc? ( dev-tex/latex2html )"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-build.patch"
+ eautoreconf
+}
+
+src_compile() {
+ emake -j1
+ use doc && emake -C manual
+}
+
+src_install() {
+ default
+ dodoc NOTES
+ docinto "dieharder"
+ dodoc dieharder/README dieharder/NOTES
+ docinto "libdieharder"
+ dodoc libdieharder/README libdieharder/NOTES
+
+ if use doc ; then
+ dodoc ChangeLog dieharder.html
+ docinto "manual"
+ dodoc manual/dieharder.pdf manual/dieharder.ps
+ fi
+}
diff --git a/app-crypt/dieharder/dieharder-3.31.1.ebuild b/app-crypt/dieharder/dieharder-3.31.1.ebuild
new file mode 100644
index 000000000000..92d7ad4d6817
--- /dev/null
+++ b/app-crypt/dieharder/dieharder-3.31.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+DESCRIPTION="An advanced suite for testing the randomness of RNG's"
+HOMEPAGE="http://www.phy.duke.edu/~rgb/General/dieharder.php"
+SRC_URI="http://www.phy.duke.edu/~rgb/General/${PN}/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND="sci-libs/gsl"
+DEPEND="${RDEPEND}
+ doc? ( dev-tex/latex2html )"
+
+src_compile() {
+ emake all-recursive
+ use doc && emake -C manual
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS README NOTES
+ docinto "dieharder"
+ dodoc dieharder/README dieharder/NOTES
+ docinto "libdieharder"
+ dodoc libdieharder/README libdieharder/NOTES
+
+ if use doc ; then
+ dodoc ChangeLog dieharder.html
+ docinto "manual"
+ dodoc manual/dieharder.pdf manual/dieharder.ps
+ fi
+}
diff --git a/app-crypt/dieharder/files/dieharder-2.28.1-qafixes.patch b/app-crypt/dieharder/files/dieharder-2.28.1-qafixes.patch
new file mode 100644
index 000000000000..265d566c801c
--- /dev/null
+++ b/app-crypt/dieharder/files/dieharder-2.28.1-qafixes.patch
@@ -0,0 +1,33 @@
+--- libdieharder/static_get_bits.c 2008-09-08 08:37:18.000000000 -0400
++++ libdieharder/static_get_bits.c.new 2010-12-21 09:39:02.000000000 -0500
+@@ -44,7 +44,7 @@
+ }
+ if(nbits > 32){
+ fprintf(stderr,"Warning! dieharder cannot yet work with\b");
+- fprintf(stderr," %u > 32 bit chunks. Exiting!\n\n");
++ fprintf(stderr," %u > 32 bit chunks. Exiting!\n\n", nbits);
+ exit(0);
+ }
+
+--- libdieharder/bits.c 2008-09-08 08:37:18.000000000 -0400
++++ libdieharder/bits.c.new 2010-12-21 09:45:51.000000000 -0500
+@@ -944,7 +944,7 @@
+ */
+ MYDEBUG(D_BITS) {
+ printf("bu = %d bl = %d\n",bu,bl);
+- printf(" init %2d: |");
++ printf(" init %2d: |",bleft);
+ dumpbits(&bits_rand[0],bu);
+ printf("|");
+ dumpbits(&bits_rand[1],bu);
+--- libdieharder/marsaglia_tsang_gcd.c 2008-09-08 08:37:19.000000000 -0400
++++ libdieharder/marsaglia_tsang_gcd.c.new 2010-12-21 09:47:40.000000000 -0500
+@@ -289,7 +289,7 @@
+ Vtest_destroy(&vtest_u);
+
+ if(verbose == D_USER_TEMPLATE || verbose == D_ALL){
+- printf("# user_marsaglia_tsang_gcd(): ks_pvalue_k[%u] = %10.5f ks_pvalue_w[%u] = %10.5f\n",kspi,ks_pvalue[kspi],ks_pvalue2[kspi]);
++ printf("# user_marsaglia_tsang_gcd(): ks_pvalue_k[%u] = %10.5f ks_pvalue_w[%u] = %10.5f\n",kspi,ks_pvalue[kspi],kspi,ks_pvalue2[kspi]);
+ }
+
+ kspi++;
diff --git a/app-crypt/dieharder/files/dieharder-3.31.1-build.patch b/app-crypt/dieharder/files/dieharder-3.31.1-build.patch
new file mode 100644
index 000000000000..4cbd5021c77c
--- /dev/null
+++ b/app-crypt/dieharder/files/dieharder-3.31.1-build.patch
@@ -0,0 +1,27 @@
+diff --git a/include/dieharder/libdieharder.h b/include/dieharder/libdieharder.h
+index 2138ebf..f6d471b 100644
+--- a/include/dieharder/libdieharder.h
++++ b/include/dieharder/libdieharder.h
+@@ -6,6 +6,8 @@
+
+ #include "copyright.h"
+
++#define _GNU_SOURCE
++
+ /* To enable large file support */
+ #define _FILE_OFFSET_BITS 64
+
+@@ -16,13 +18,11 @@
+ #include <sys/time.h>
+
+ /* This turns on uint macro in c99 */
+-#define __USE_MISC 1
+ #include <sys/types.h>
+ #include <sys/stat.h>
+ #include <unistd.h>
+
+ /* This turns on M_PI in math.h */
+-#define __USE_BSD 1
+ #include <math.h>
+ #include <limits.h>
+ #include <gsl/gsl_rng.h>
diff --git a/app-crypt/dieharder/metadata.xml b/app-crypt/dieharder/metadata.xml
new file mode 100644
index 000000000000..d68fe974c15a
--- /dev/null
+++ b/app-crypt/dieharder/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>crypto</herd>
+</pkgmetadata>