summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/hmaccalc/hmaccalc-0.9.13.ebuild')
-rw-r--r--app-crypt/hmaccalc/hmaccalc-0.9.13.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-crypt/hmaccalc/hmaccalc-0.9.13.ebuild b/app-crypt/hmaccalc/hmaccalc-0.9.13.ebuild
new file mode 100644
index 000000000000..1f4793401784
--- /dev/null
+++ b/app-crypt/hmaccalc/hmaccalc-0.9.13.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils multilib
+
+DESCRIPTION="Tools for computing and checking HMAC values for files"
+HOMEPAGE="https://fedorahosted.org/hmaccalc/"
+SRC_URI="https://fedorahosted.org/released/hmaccalc/hmaccalc-${PV}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+fips"
+
+DEPEND="dev-libs/nss
+ sys-devel/prelink"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ econf \
+ --enable-sum-directory=/usr/$(get_libdir)/${PN}/ \
+ $(use_enable !fips non-fips) \
+ || die "econf failed"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "emake install failed"
+ dodoc README
+}