summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/johntheripper-jumbo/johntheripper-jumbo-9999.ebuild')
-rw-r--r--app-crypt/johntheripper-jumbo/johntheripper-jumbo-9999.ebuild115
1 files changed, 74 insertions, 41 deletions
diff --git a/app-crypt/johntheripper-jumbo/johntheripper-jumbo-9999.ebuild b/app-crypt/johntheripper-jumbo/johntheripper-jumbo-9999.ebuild
index 0f5e65d9ac91..d4b9287e610c 100644
--- a/app-crypt/johntheripper-jumbo/johntheripper-jumbo-9999.ebuild
+++ b/app-crypt/johntheripper-jumbo/johntheripper-jumbo-9999.ebuild
@@ -1,53 +1,65 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-inherit flag-o-matic toolchain-funcs pax-utils
+inherit autotools flag-o-matic toolchain-funcs pax-utils
-DESCRIPTION="fast password cracker"
+DESCRIPTION="Fast password cracker, community enhanced version"
HOMEPAGE="http://www.openwall.com/john/"
-MY_PN="JohnTheRipper"
-
if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="https://github.com/magnumripper/${MY_PN}.git"
+ EGIT_REPO_URI="https://github.com/openwall/john.git"
+ EGIT_BRANCH="bleeding-jumbo"
inherit git-r3
else
- JUMBO="jumbo-1"
- MY_PV="${PV}-${JUMBO}"
- MY_P="${MY_PN}-${MY_PV}"
- SRC_URI="https://github.com/magnumripper/${MY_PN}/archive/${MY_PV}.tar.gz -> ${MY_P}.tar.gz"
- KEYWORDS="~alpha ~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
- S="${WORKDIR}/${MY_P}"
+ HASH_COMMIT="9daf16b5743b2c521d23c281e13ae8cdbd37b1eb"
+ SRC_URI="https://github.com/openwall/john/archive/${HASH_COMMIT}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/john-${HASH_COMMIT}"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
fi
LICENSE="GPL-2"
SLOT="0"
-#removed rexgen and commoncrypto
IUSE="custom-cflags kerberos mpi opencl openmp pcap"
-DEPEND=">=dev-libs/openssl-1.0.1:0
+DEPEND=">=dev-libs/openssl-1.0.1:=
+ virtual/libcrypt:=
mpi? ( virtual/mpi )
opencl? ( virtual/opencl )
kerberos? ( virtual/krb5 )
pcap? ( net-libs/libpcap )
- dev-libs/gmp:*
+ dev-libs/gmp:=
sys-libs/zlib
app-arch/bzip2"
-
+# Missing (unpackaged):
+# - Digest::Haval256
+# - Digest::x
+# See bug #777369.
RDEPEND="${DEPEND}
- !app-crypt/johntheripper"
+ dev-perl/Compress-Raw-Lzma
+ dev-perl/Digest-MD2
+ virtual/perl-Digest-MD5
+ dev-perl/Digest-SHA3
+ dev-perl/Digest-GOST
+ !app-crypt/johntheripper"
+RESTRICT="test"
+
+pkg_pretend() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
pkg_setup() {
- if use openmp && [[ ${MERGE_TYPE} != binary ]]; then
- tc-has-openmp || die "Please switch to an openmp compatible compiler"
- fi
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
}
src_prepare() {
- sed -i 's#$prefix/share/john#/etc/john#' src/configure || die
default
+
+ cd src || die
+ eautoreconf
+
+ sed -i 's#$prefix/share/john#/etc/john#' configure || die
}
src_configure() {
@@ -56,9 +68,9 @@ src_configure() {
use custom-cflags || strip-flags
econf \
+ --enable-pkg-config \
--disable-native-march \
--disable-native-tests \
- --without-commoncrypto \
--disable-rexgen \
--with-openssl \
--with-systemwide \
@@ -69,54 +81,75 @@ src_configure() {
}
src_compile() {
- emake -C src
+ # Uses default LD=$(CC) but if the user's set LD, it'll call it
+ # bug #729432.
+ emake LD="$(tc-getCC)" -C src
}
src_test() {
pax-mark -mr run/john
- #if use opencl; then
- #gpu tests fail in portage, so run cpu only tests
- # ./run/john --device=cpu --test=0 --verbosity=2 || die
- #else
- #weak tests
- # ./run/john --test=0 --verbosity=2 || die
- #strong tests
+
+ # this probably causes the following failure:
+ # Testing: as400-des, AS/400 DES [DES 32/64]... PASS
+ # Error, Invalid signature line trying to link to dynamic format.
+ # Original format=as400-ssha1
+ sed '/.include /d' run/john.conf > run/john-test.conf
+ if use opencl; then
+ # GPU tests fail in portage, so run cpu only tests
+ ./run/john --config=run/john-test.conf --device=cpu --test=0 --verbosity=2 || die
+ else
+ # Weak tests
+ ./run/john --config=run/john-test.conf --test=0 --verbosity=2 || die
+ # Strong tests
#./run/john --test=1 --verbosity=2 || die
- #fi
- ewarn "When built systemwide, john can't run tests without reading files in /etc."
- ewarn "Don't bother opening a bug for this unless you include a patch to fix it"
+ fi
+
+ rm john-test.conf || die
}
src_install() {
- # executables
+ # Executables
dosbin run/john
newsbin run/mailer john-mailer
pax-mark -mr "${ED}/usr/sbin/john"
# grep '$(LN)' Makefile.in | head -n-3 | tail -n+2 | cut -d' ' -f3 | cut -d/ -f3
+ local s
for s in \
unshadow unafs undrop unique ssh2john putty2john pfx2john keepass2john keyring2john \
zip2john gpg2john rar2john racf2john keychain2john kwallet2john pwsafe2john dmg2john \
hccap2john base64conv truecrypt_volume2john keystore2john
do
- dosym john /usr/sbin/$s
+ dosym john /usr/sbin/${s}
done
+ # Scripts
+ exeinto /usr/share/john
+ doexe run/*.pl
+ doexe run/*.py
insinto /usr/share/john
- doins run/*.py
+ doins -r run/lib
+ cd run || die
+
+ local s
+ for s in *.pl *.py; do
+ dosym ../share/john/${s} /usr/bin/${s}
+ done
+ cd .. || die
if use opencl; then
insinto /etc/john
- doins -r run/kernels
+ doins -r run/opencl
fi
- # config files
+ # Config files
insinto /etc/john
doins run/*.chr run/password.lst
doins run/*.conf
doins -r run/rules run/ztex
- # documentation
- dodoc -r doc/*
+ # Documentation
+ rm -f doc/README || die
+ dodoc -r README.md doc/*
}