summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/libnitrokey/libnitrokey-9999.ebuild')
-rw-r--r--app-crypt/libnitrokey/libnitrokey-9999.ebuild14
1 files changed, 11 insertions, 3 deletions
diff --git a/app-crypt/libnitrokey/libnitrokey-9999.ebuild b/app-crypt/libnitrokey/libnitrokey-9999.ebuild
index 8687d0d1b4e3..b37e5cdbd34f 100644
--- a/app-crypt/libnitrokey/libnitrokey-9999.ebuild
+++ b/app-crypt/libnitrokey/libnitrokey-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit udev cmake
@@ -29,7 +29,7 @@ RDEPEND="
virtual/udev"
DEPEND="
${RDEPEND}
- test? ( >=dev-cpp/catch-2.5.0:0 )"
+ test? ( <dev-cpp/catch-3:0 )"
BDEPEND="virtual/pkgconfig"
src_configure() {
@@ -45,3 +45,11 @@ src_configure() {
)
cmake_src_configure
}
+
+pkg_postinst() {
+ udev_reload
+}
+
+pkg_postrm() {
+ udev_reload
+}