summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/nitrocli/nitrocli-0.4.1.ebuild')
-rw-r--r--app-crypt/nitrocli/nitrocli-0.4.1.ebuild19
1 files changed, 15 insertions, 4 deletions
diff --git a/app-crypt/nitrocli/nitrocli-0.4.1.ebuild b/app-crypt/nitrocli/nitrocli-0.4.1.ebuild
index 769a5bd019b6..f41366c4a624 100644
--- a/app-crypt/nitrocli/nitrocli-0.4.1.ebuild
+++ b/app-crypt/nitrocli/nitrocli-0.4.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2017-2021 Gentoo Authors
+# Copyright 2017-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -19,7 +19,7 @@ getrandom-0.1.16
getrandom-0.2.2
heck-0.3.2
lazy_static-1.4.0
-libc-0.2.94
+libc-0.2.146
log-0.4.14
memchr-2.4.0
merge-0.1.0
@@ -93,13 +93,24 @@ RDEPEND="
RESTRICT="test"
QA_FLAGS_IGNORED="usr/bin/nitrocli"
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.4.1-fix-musl-1.2.4-build.patch
+)
+
+src_compile() {
+ cargo_src_compile --bin=nitrocli
+ # Install shell-complete binary into source directory to be able to
+ # use it later on.
+ cargo install --bin=shell-complete --path . --root "${S}" || die
+}
+
src_install() {
cargo_src_install --bin=nitrocli
- target/release/shell-complete bash > ${PN}.bash || die
+ "${S}"/bin/shell-complete bash > ${PN}.bash || die
newbashcomp ${PN}.bash ${PN}
- target/release/shell-complete fish > ${PN}.fish || die
+ "${S}"/bin/shell-complete fish > ${PN}.fish || die
insinto /usr/share/fish/vendor_conf.d/
insopts -m0755
doins ${PN}.fish